Filesystem not mounted after freeze

I installed OpenSUSE 11.1 on a friends computer after having a lot of trouble from ubuntu, and because I use it. It was working great when she got it home, but it locked up randomly and wouldn’t unfreeze so she turned it off and when she rebooted She got an error about there not being a file system present and that she needed to run a mount command, which didn’t work. After that, now it just says that there is no files system present and you ge tthe basic prompt. I had her run a live cd and run Gpartd and check and repair the partitions, but it did nothing. Any ideas?

More info required:

Do you get the green grub boot menu?

If you boot a live CD like Parted Magic, what is the output of:

fdisk -l

O.K. I finally got the computer to take a look at it and it seems like there is something more serious going on here. When I first turned it on it went through POST and then just said something like Grub2 error or something like that, then I restarted and I got the grub screen that gives the very basic command interface. but then after restarting again, i noticed it took a long time to detect the hard drive. I booted from an Ubuntu live disk, and when I got in, the hard drive was not detected at all.

I went into the BIOS and went to where the drives are listed, it had the correct drive name, but I decided to do auto detect and when I did that it screwed up and locked the bios and the name of the drive was changed to a bunch of weird characters. I tried this a few times with the same result. I restarted again with the live disk and this time the drive was found, and all tests came back as there was nothing wrong. But, I accidentally hit “create” instead of “cancel” when I mistakenly clicked on make new partition table (there really should be more warning about that) so I lost the partition table and it is apparently gone for good because when trying to use the openSUSE utilities on the disk to repair the partition table, it couldn’t find any partitions.

Well, I figured I would just reinstall since it was a fresh install that got messed up anyways, but when the installer was loading and trying to detect the hard drives it couldn’t find it.

I am guessing that the hard drive is about to die completely, I would doubt it would be the controller or motherboard. It is hard to tell exactly what the problem is because it happens intermittently. But I don’t think it is a very good brand of HDD, so my guess is on the drive dying. I have had to constantly fix this computer.

It started when her windows install got screwed up and I said I could put linux on it and she wouldn’t have any malware problems and I could use a Vm for windows so her mom could play her MSN games. I had problems constantly. Lockups messing everything up, Vbox constantly messing up, though I thought it was just Ubuntu 9.10 as I have had a lot of trouble with it at my school. I had a lot of trouble helping her fix things over the phone, so I thought I would put openSUSE on it because that is what I am used to. Obviously it is something else, and I had the same sort of problems on my computer at school when the hard drive was dying.

Get a scan program from the drive manufacturer and do a low level scan to check the drive. Could also be something like a loose connection.