Files lost on / partition

Hi I just got an msi wind with opensuse the other day, for some reason there was a 56G partition mounted on media/data, but i didnt like that because i couldn’t put all my music there, so what i did is i changed the partition to be home/[user] and now i can save there all that i need so I’m happy about it. My problem is that all the files that i previously had on home/[user] are now lost and using space on may / partition, how do i find and delete them? thanks!

Hello noiz777, welcome to the Forums.
I’m a bit confused by your question but that doesn’t matter too much because if you can remember just one of the files you should be able to track them all down.
Suppose for illustration that one of the music files was abc.wav. You can track it down with this console command:

su -c "find / -name abc.wav"

Then you can browse to it in Nautilus or Konqueror and presumably find all of the media files and delete them.

Hmm… I would think that noiz777 means that he/she has shifted the mount point for /media/data to /home/[user], hence concealing the previous contents of /home/[user], which would also make it unaccessible. But I could be wrong of course.

However, if that is the way things are, noiz777 merely needs to undo the change in mount points and all the “previous” files in /home/[user] should be accessible again.

I agree with @rackham. Either one partition is being mounted on top of another (assuming a separate original /home), or the 56GB partition being mounted at /home is overlaying what is in the /home directory within the root partition. In either case, the files will not be seen at all.

@noiz777, what specifically did you do to change the mount point? In a terminal window do this and post back the output:

cat /etc/fstab

Or if you know how to, just reverse what you did. The files are probably all there once you remove the mounting of the data partition on top of them.

Hi guys thanks for replying so soon, hmm ok so i did the search thing but i only find one file in the 56G partition, the other file doesn’t appear anywhere.

What i did specifically was to go into yast → partitions and then i saw my 56G partition redirected to the folder /media/data, so i thought i want it to be my home partition and did the change, probably something stupid cuz now it wont let me go back for some reason…the results for the other command:

noiz777@n011:~> cat /etc/fstab
/dev/sda1 / ext3 noatime,noacl,nodiratime,ba rrier=1 1 1
/dev/sda4 /home ext3 defaults 1 1
/dev/sda2 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

Originally was there a separate partition for /home? You stated that your media partition was mounted at /media/data; what is the name of that partition; is it /dev/sda4?

Also do this and post back the output (that’s a lower-case letter “l” as in “lazy”, not the numeral 1):

fdisk -l

Ok im sorry i really got frustrated with this not because of this problem but because I also lost the sound on my headphones so I decided to return to the factory settings…so you could say I’m back to where I started. I have the my home folder at /home and this partition is 10G, i also have the 56G partition under /media/data, now the question would be, what should i do so that i can save all my files in this big partition and also i would like to have a bit more space on my root to install new software cuz now it only has 900Mb freespace? Thanks

Simple. Create a symlink in /home/username that points to /media/data. This can be done several ways. Easiest is probably just to open Dolphin at /home/username and then on the left open the Folders display (at the top pull-downs, View/Panels/Folders), find /media/data, drag that folder to /home/username. Dolphin will ask if you want to Move, Copy, or Link the folder - choose Link. That will create a folder named data under /home/username which points to /media/data. When you open /home/username/data, you will actually be opening /media/data. Anything you do in /home/username/data, you are actually doing in /media/data - it’s just transparent that that’s what you’re doing.

Re adding space to the root partition: Where on the disk do you intend the space to come from? With your reply, pls also post the output of fdisk -l and again the contents of /etc/fstab as you did before (it has changed).

Ok so I couldn’t find Dolphin but I supposed it was something like Nautilus, so what I did is pretty much follow your instruction. I went to /media and created a link from data and then copied that on my /home/username. I had to load as root first and change the folder owner for my username and the users group to users, i hope that is not a security conflict. Problem Solved! :wink:

My idea was to re-dimention the 56G partition to 50 and move the other 6Gigs to my root partition. Sorry it says fdisk command not found, i send you what i send before in case it changed

noiz777@n011:~> cat /etc/fstab
/dev/sda1 / ext3 noatime,noacl,nodiratime,barrier=1 1 1
/dev/sda4 /media/data ext3 defaults 1 1
/dev/sda2 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

You are using Gnome; Nautilus is the counterpart to KDE’s Dolphin. Looks like you did the right thing with the permissions on the folder (no, not a security problem), but verify that you can write to any sub-folders. If you have a problem, you can change sda4’s line in /etc/fstab to be mounted by “users” rather than root which it is now. By the way, that last number 1 on that sda4 line is ordinarily a 2.

You got the fdisk error because you had not switched to root. Do:

fdisk -l

That will show the physical disk partitioning. How easily or whether you even can downsize sda4 and upsize sda1 depends on the layout. There is another alternative, which is to create the space, add another partition in that space, and use it for one of the root’s directories like /var or /usr or /opt (this is a common technique used on servers). When I see the disk layout I’ll be able to tell you if you can just resize or what risks there may be in doing that; that is the preferred approach but obviously only if it will work.

Excelent, no problem with the sub-folders :wink:

You are right my friend i needed…the fdisk -l gave me this:

n011:/home/noiz777 # fdisk -l

Disco /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Unidades = cilindros de 16065 * 512 = 8225280 bytes

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 * 1 1045 8393931 83 Linux
/dev/sda2 1046 1176 1052257+ 82 Linux swap / Solaris
/dev/sda3 1177 2393 9775552+ 83 Linux
/dev/sda4 2394 9729 58926420 83 Linux

If i were to make a partition only for the place where programs get installed which one of those you mentioned would it be?

What is on that ~10GB /dev/sda3?

Re the subdirectories: Depends on the system. KDE 3 and Gnome apps are mostly under /opt, although there are some libraries under /usr. Independent apps (gimp, cups, oo, xine, wine, vlc, etc.) are under /usr as is KDE 4. Shared libraries are under /lib (32-bit) or /lib64 (64-bit). On my system ~2/3 is under /usr, but on yours I wouldn’t be surprised if at least half is under /opt.

What is on that ~10GB /dev/sda3?

I’ve been wondering that too. Nothing so far has explained it’s purpose. Could it be a partition containing an installation repository used for factory reset, as was made in post #7?

Since the MSI Wind doesn’t have an optical drive (unless an external USB optical drive was used) the repo had to come from somewhere. From what I’ve heard the MSI Wind comes with SLED 10 preinstalled. Messing around with the partitions could possibly render the system unbootable and impossible to restore without an external optical drive. Well, just a though…

@rackham -

I thought sda3 might be /home, but it’s not being mounted in fstab.

You read my mind re the partition risks. Since sda4 is a static data partition, that’s why I considered taking the expansion space off the end of it for a new partition, then moving /usr or /opt there.

As Rackham mentioned that is the system restore partition which i used previously since I don’t have an external drive. So far things have worked well and I’ve realized that there is a lot of programs that I don’t need at all from which I can take some extra space. My real intention is to have a virtual machine installed for running XP since I can’t connect to the company’s VPN unless I use their VPN software, which only runs on XP and that is the reason why I want to have enough free space to run XP, I don’t even need to install anything else than that VPN software because I connect remotely to my PC at the office and do all my work there.

Well then, you are home free. If it’s a vm you’re after, you can put it anywhere you want - all of them support that. The software itself doesn’t take much room, it’s the vm that does. Just put it on sda4.

sda3 is a recovery partition??? Nearly always that is the first partition. If you moved it, it may not work anymore. Anyway, what is actually on it?

Interesting, is there any VM you recommend? I wanted to get virtualbox but it seems they don’t support SLED 10 SP1.

I’m not sure why it is on sd3 but I haven’t changed it and it worked fine last time I did the recovery. Hmm i tried to go into /dev/sda3 but is says it ain’t a directory :S how can I check what’s in it?

Interesting, is there any VM you recommend? I wanted to get virtualbox but it seems they don’t support SLED 10 SP1.

Have we all along been helping you with SLED 10? Not that I mind at all, but doesn’t that come with support from Novell? Anyway, yes, I would recommend VBox for its simplicity. I suspect the reason why SLED is not on the support list is because VBox requires Qt (the language KDE is written in) while Gnome uses GTK, and a commercial vendor will not support software that goes outside its architectural model. Doesn’t mean it won’t work though (it’s in the openSUSE repo and there is another repo that VBox maintains with the newest version; you would need to install the Qt libraries and some other dependencies - there is also an .rpm that can be downloaded). Having said that, VMware works well, too. You can use either the “Player” or the “Server” editions, both are free. Both vendors provide excellent manuals. The important thing is to do the reading and planning in advance. Nothing is particularly difficult, but users get into trouble with vm’s all the time because they rush in without prep. There are other choices, but these two are by far and away the easiest for your purpose. Note: You mentioned you’d be using the vm guest for a VPN app; then pay extra close attention to setting up networking. VBox supports several methods, the default is very simple and works for most everyone’s needs, but the other methods are a bit difficult to understand. VMware takes a bit more know-how to set up even the default, but on the other hand the other methods are easier to understand and set up.

I’m not sure why it is on sd3 but I haven’t changed it and it worked fine last time I did the recovery. Hmm i tried to go into /dev/sda3 but is says it ain’t a directory :S how can I check what’s in it?

Take a look in YaST Partitioner to see what file system it is formatted with and then mount it from a terminal window accordingly. But that may not work. I’ve only seen Windows recovery partitions, and they are a bit image of the factory-installed OS which can be copied from, using a utility program attached to the bios. That would work with Linux, although it may also just be a bootable partition using a compressed image. Now that I know you have SLED factory installed, the partitioning makes sense - the root and swap were already there. With this machine, it is probably wise to stay with what the factory did; they worked out all the hardware requirements.


Have we all along been helping you with SLED 10? Not that I mind at all, but doesn’t that come with support from Novell?

Yep… sorry I’m kinda new to this, I’ve played along with a few linux distros before, but just very informal. It was kind of a mayor decision for me to get a netbook with linux and not windows but i have to say I’m really happy with it. So far I’ve fallen in love with the OS there are just a few things I need to work out. 1. VPN for the office. 2. GuitarPro 3. Printer …besides that I love the way it feels…By the way, this might sound kinda stupid but, what kind of support do I get with SLED? I thought they would give me downloads and stuff but do they also help me personally like you are doing?..I happen to like a lot this community thing :smiley:

I’ll do my homework with Vbox and I’ll tell you how it went :wink: you have been really helpful, thanks

The partition is formated in Linux Native. Since you recommend it I will try to keep the system as it is. I just would like to get some extra software like tuxguitar and others but no luck so far… by the way, I tried to update to SP2 with YaST and somethings got broken like my sound card, I could hear through the speakers but not through the headphones :frowning: so I guess I do have to keep the original system. But as I said, this thing is marvelous.

I don’t know what level of support is bundled with the product. It occurred to me after my last post that SLED was installed on the machine when you purchased it; that makes it “oem”. In Windows land, support for the OS is provided by the manufacturer (such a deal for Microsoft, they sell a reduced-price license for the software to the manufacturer, but the oem picks up all the support costs); note that the manufacturer is granted rights to install/configure the OS differently than what is sold retail. You may be able to purchase support from Novell, but given your location you would want to be very clear in advance who/how is delivering the support. It’s perfectly fine to use the community forums, but very important that you be clear what you are using - the assumption will otherwise be openSUSE, which is not exactly the same. Your SLED 10 is probably closest to openSUSE 10.3 using Gnome. You probably cannot use the openSUSE repositories (maybe that’s how you broke the sound?), AFAIK you need to use Novell’s. Did you check the manufacturer’s documentation or website? If you are installing software such as .rpm’s from outside the repositories, you need to read up on how that is done in your particular setup.