File system is mounted read only when waking from sleep

Recently, I think when the 4.7.2 kernel became available to openSUSE Tumbleweed, my computer has not been waking from sleep properly. What happens is the system wakes but the file system is mounted read only. This causes errors, for example, in the terminal when pressing Tab to auto complete a typed command. Another example is trying to use sudo to execute a command.

I’m not sure exactly how to troubleshoot this, so I’m hoping for some direction on what services or areas of Linux have control over or are responsible for remounting the file system properly when resuming from sleep?

what is the content of the file /etc/fstab ?
also command sudo lsblk -o NAME,FSTYPE,SIZE,TYPE,MOUNTPOINT
or command sudo parted -l

Apologies, just saw your post this morning after doing a full system reset last night, so I don’t have the information you are requesting. However, the problem appears to be resolved, it seems that the file system was in an invalid state based on looking through the systemd journal logs. I noticed when trying to remount the file system rw after waking from sleep a BTRFS message about the file system state. I probably could have tried to boot from USB and fixed it, but I just formatted the disks and started fresh. Also, I switched to ext4 instead of BTRFS.