File sharing programs for opensuse

I can’t seem to find any file sharing apps in the repositories including pacman. I previously used frostwire and it worked great, but can’t get it installed on 11.4. Any suggestions for apps?

I can’t seem to find any file sharing apps in the repositories including pacman. I previously used frostwire and it worked great, but can’t get it installed on 11.4. Any suggestions for apps?
If you do a search on P2P, you can find a couple like MLDonkey you could try. I don’t use these clients and find it hard to recommended then to anyone due to the malware, viruses and illegal software that these services seem to provide to everyone on a regular basis. Due to the fact I don’t use them, perhaps someone else can provide better help. I can say that on my daughter’s computer, she was a Limewire user (before it was shutdown last year) and twice had her computer wiped out by a virus, while using Windows. Linux is generally not bothered by such stuff, but can still transmit viruses to Window’s computers even if they do not bother the Linux computer. I suggest you be very careful with any such software.

Thank You,

Thanks for the info. I installed mldonkey through YAST but it doesn’t show up in the app menu. I expect it to appear near where ktorrent is. I tried to start mldonkey from the command line, but it then stalls at the step “resolving [linux-lnk5]”. Oh well, no big deal.

aMule is in there (folks are still waiting for Frostwire)

I downloaded frostwire for linux and it works great on 11.3 and probably works fine on 11.4. The file is called frostwire-4.21.2.noarch.tar.gz. The file just needs to be extracted and then the file “” needs to be clicked.

I did that and it extracted into a subfolder under “Downloads” called " frostwire-5.0.8.noarch" but there is no install folder called “” I can run the application by using a terminal and typing “frostwire” in that folder (or clicking on it in Dolphin) but no icon is created anywhere and there is no entry in the menu. Not sure “Downloads” is a good permanent location either.

It works fine in 11.4 by using the above method, but I’d rather have it installed somewhere other than “Downloads.” I know there is a way to move the folder to /usr and manually edit the menu to add the icon, but I am wondering if the tarball has an install file that I missed or if I have to compile it.

.sh signifies that it’s an executable file, not a folder, .sh generally means ‘shell script’

Such programs I generally move into the folder /home/bin and create a menu entry to start it (right-click the launcher button and click Edit Applications to start the Menu Editor, menu items can be managed in there)

I know … I’m just saying there is no file in the extracted files with the extension “.sh”.

So if it runs from the folder ~/Downloads/frostwire-5.0.8.noarch by typing frostwire in a terminal or clicking on the file named “frostwire” how would you go about moving it to /home/bin and set it up to run from there? Would you just go “su” and mkdir /home/bin/Frostwire and then “mv” all the files from the “Downloads” folder there?

Second question: how is it that it runs without really being compiled or installed using yast or zypper?

In the extracted folder there is a file called : frostwire

Open a terminal in the same directory and do: ./frostwire
Hit enter

see this
SUSE Paste

It runs because it’s an executable bash script. No compiling or installation is needed.

Sorry to post again about this, but I followed my own instructions above and extracted the tarball into ~/bin, but now I wonder if I should have used /usr/bin? I guess the only difference is that if it is in my home folder under /bin then it would not be available to other users … is that right? (I am the only user on this machine)

Anyway, it extracted to ~/bin/Frostwire/frostwire-5.0.8.noarch/ which is not what I wanted but is probably just as well because I can track different versions. I was able to edit the KDE menu and add the entry under Applications → Internet → Peer to Peer and it runs. I noticed that some menu items have a suffix after the command. Like the firefox entry is “firefox %u”. Not sure what that means but it starts using just “frostwire” with no suffix.

Problem is there is no icon. There is a folder called “icns” but it says it is for a Mac. There is also a desktop file, but it expects to find the program in /usr/bin so it won’t work. I can substitute another icon, but any ideas how/where to download the Frostwire icon?

I guess I got it done, but its probably backwards from how it should be. Any suggestions?

… okay, that did something

user@linux-qq7f:~/bin/Frostwire/frostwire-5.0.8.noarch> ./frostwire
HOSTNAME IS linux-qq7f
Starting FrostWire…
Java exec found in PATH. Verifying…
Suitable java version found [java = 1.6.0_26]
Configuring environment…
Loading FrostWire:
CLASSPATH SET TO: .:lw-azureus.jar:lw-collection.jar:lw-common.jar:lw-io.jar:lw-resources.jar:lw-setting.jar:commons-logging.jar:FrostWire.jar:gettext-commons.jar:gson-1.4.jar:httpclient-4.0.jar:httpcore-4.0.1.jar:jdic.jar:messages.jar:MRJAdapter.jar:splash.jar:substance.jar:trident.jar Stream closed
1: Main.main(Ljava.lang.String;@7ca83b8a)

But it didn’t create a menu entry or icon. It runs the same as before from the menu entry I created. Did that just set environment variables like the location of java? (Looks like it already knew where it was …)

Place this icon in your user directory

And point the menu to it

Here is another one
SUSE Paste