File not found in repo, errors in YaST when updating

Hi, I’ve just installed OpenSuse 13.2 and everything went fine. Now I want to update my packages and when I go to YaST -> Software Repositories and do Refresh all I always get these 2 errors :

File ‘/repodata/repomd.xml’ not found on medium ‘http://download.opensuse.org/distribution/13.2/repo/non-oss/

File ‘/repodata/repomd.xml’ not found on medium ‘http://download.opensuse.org/distribution/13.2/repo/oss/

It’s strange since the URL is working fine in my browser… I live in a residence where we connect to an ethernet plug in the wall then I’m asked to enter my credentials to get internet but I’ve never experienced any internet issues before, neither with apt based Linux distros nor torrent downloading so I doubt the problem comes from there…

Here is the ouput of zypper lr

# | Alias               | Name                         | Enabled | Refresh
--+---------------------+------------------------------+---------+--------
1 | repo-non-oss        | openSUSE-13.2-Non-Oss        | Yes     | Yes    
2 | repo-oss            | openSUSE-13.2-Oss            | Yes     | Yes    
3 | repo-update         | openSUSE-13.2-Update         | Yes     | Yes    
4 | repo-update-non-oss | openSUSE-13.2-Update-Non-Oss | Yes     | Yes 

I think this is pretty problematic since when I go to YaST → Online Update it tries to find me update but don’t look into repo-oss and repo-non-oss hence I get a lot of warning saying that I will end up with broken packages if I do the update because it couldn’t resolve dependencies…

That often happens when the mirror is having temporary problems. Either try another mirror, or just wait until the repositories are working again at the current mirror.

Ok I fixed it : the repo was configured to point to http://download.opensuse.org/distribution/13.2/repo/non-oss/ and was requesting http://download.opensuse.org/distribution/13.2/repo/non-oss/**suse/**repodata/repomd.xml so I just added suse/ to the two repos that failed to download and everything went smooth.

Thanks for the quick reply though.