file /boot/grub2/x86_64_efi/normal.mod not found.. system not starting!

Hi everybody,

I have installed OpenSuse 12.3 on a new computer with a raid hard disk.

The installation seemed fine but after the reboot I got this error message:

file /boot/grub2/x86_64_efi/normal.mod not found.

Entering rescue mode…

I have now a sort of shell but it seems there are no commands available.

I have tried to install again the system but it seems impossible, it now reboots after it says: attempting boot from cdrom.

Is this a common issue?

If a partition, being mounted by the** /etc/fstab** file fails to mount, you can get this message. It seems that your boot works and perhaps root / mounts, but something else fails. For any partition that is NOT root /, /home or SWAP, you could add the fstab load option nofail as root. Try mc at the terminal prompt for Midnight Commander, a file manager with editor. The nofail option works good for USB drives and any none essential partition you want to ignor if it does not mount.

Thank You,

Hi, thank you for your suggestions.

Your explanation makes sense. I have tried to use the mc command but I get the Unknown command error message.

The only command that seems working is ls but it lists the partitions:

(hd0) (hd1) … etc

If the boot works, because the BIOS finds it OK, but the root / partition does not mount because it is a RAID, not understood by the kernel initrd image, you may be unable to startup. If you could move root / to a standard drive partition, it may be able to bring up the RAID once the full kernel is loaded. I don’t know what is wrong for sure, but it sounds like a required partition like root / does not mount.

Thank You,

Hi what do you mean with standard drive partition?

I’ve just tried to install ubuntu and the installation seemed ok. I rebooted and I got the same message.

I’ve tried also the Rescatux live cd to make to repair grub but same message also in this case…

I think the problem is this EFI… with the normal BIOS I never had problems

EDIT:

tried the system recovery option in the bios but it gives me the same error message and console

UPDATE:

I have tried the Archlinux live cd

I have selected boot existing OS and found opensuse and it booted

in opensuse I have used yast to change the boot loader to use the MBR and now it doesn’t boot anymore

I can try to re-install opensuse and use archlinux to boot but I don’t know later what to do

Maybe try a reinstall. And this time, select “elilo” to handle the booting.

There are no guarantees, of course.

My understanding is that if you use “elilo”, then the kernel and “initrd” are put into the EFI partition. Hopefully that would be enough to get RAID working.

I tried to select elilo and grub2-efi but it said they were not compatible with the architecture… I don’t know why…

thanks however :slight_smile:

By standard boot, imagine that you add a hard drive, as small as 40 GB, install boot and root / all on this drive and let it startup your RAID. Its sounds like once the boot finishes, it can locate the real root on the RAID partition, but something there is not working at the very start. Using a second hard drive for booting is like using the ARCH Linux to boot.

Thank You,

Do you mean hardware RAID or fake RAID or Linux MD RAID? Your description is too vague.

The installation seemed fine but after the reboot I got this error message:

file /boot/grub2/x86_64_efi/normal.mod not found.

Entering rescue mode…

This means grub2 cannot find device where filesystem with /boot/grub2 is located. One common case would be adapter that requires special driver but does not support booting from it (i.e. is not accessible via BIOS/EFI).

Tell more details about your hardware.

The message above is from grub2.

are you saying to install grub on a drive and the rest of the system in the other?

Yes hardware raid, two disks: sda and sdb.

I’ve tried to install grub both in the extended partition and the MBR but no results.

I want to add that my partition table is this:

sda1 7,8 GB -->fat32
sda2 7,8 GB—> fat 32
sda3 915 GB—> extended
sda5 20 GB —> ext4 —> mounted as /
sda6 895 GB → ext4 —> mounted as /home

sdb1 150 MB–> Efi boot
sdb2 6 GB ----> swap
sdb3 20 GB—> ext4
sdb4 895 GB–>ext4

I have tried to install elilo and grub2-efi but it say it is not possible to use them with my firmware…

Edit: I can’t select to boot from sdb1

Edit2: tried to select sdb but no success

I’ve downloaded Rescatux (linux rescue cd) and with that I am able to boot opensuse but it doesn’t fix grub anyway. I can access to opensuse only with that cd but I need a permanent solution… any other idea?

Edit: I have succeed in installing grub2-efi and now it works!