fglrx with ATI Radeon Xpress - black screen

hi, suse X gurus and ati experts here’s one for you:

  • openSUSE 11
  • ATI Radeon Xpress Series (RS482 5874)
  • DELL 2407WFP monitor

I can’t get ATI drivers working. Tried the YAST repository drivers, ATI site, and openSUSE 1-click. Whenever X starts with an ATI driver, I just get a black screen - whenever the driver is set to ‘fglrx’. If I set back to ‘radeon’, I get graphics, but even if I set to native resolution in X, I only get 1600x1200 (native is 1920x1200). I found several similar threads in the forums here, but no solutions there that solved my particular problem.

Anyone have any luck setting up native resolution for this monitor?

also, if more info would help, lmk.


There’s some xorg.conf settings in the linked thread that look interesting for your setup…
‘Re: 1920x1200 resolution from ATI RADEON Xpress 200?’ - MARC](http://marc.info/?l=netbsd-help&m=113798794222994&w=2)

well, i never got fglrx working… even after applying the patches at: Martin’s Miscellaneous Patches, which successfully compiled and installed the module. (i was getting kernel errors before).

but i found out why i wasn’t getting native resolution… X says the monitor doesn’t support reduced blanking, so it was ignoring the modeline. so i created a normal blanking modeline:

> cvt 1920 1200 60

1920x1200 59.88 Hz (CVT 2.30MA) hsync: 74.56 kHz; pclk: 193.25 MHz

Modeline “1920x1200_60.00” 193.25 1920 2056 2256 2592 1200 1203 1209 1245 -hsync +vsync

and that gave the resolution i was looking for - what i really wanted from the proprietary ati driver anyway. restarted x and i was ok… i’ll try the ati drivers some other day.

update - after adding “ReducedBlanking” Option to Monitor section in /etc/X11/xorg.conf, I can now use the reduced modeline.