fglrx/openradeon problems w/ properly displaying my desktop

OpenSuse 13.2 64

I updated my fglrx drivers to the latest via zypper update. When I did that, my desktop effects were really choppy and transparency didn’t work. So I decided to go w/the open radeon drivers since I didn’t need much 3d support. I uninstalled the fglrx drivers (using zypper rm fglrx*), which probably wasn’t the best way to do it, and rebooted.

The system restarted, and loaded me into a gui that looked similar to my desktop settings previous to the fglrx upgrade, except the my dual monitors didn’t display properly: the left monitor and right monitors were switched. My desktop configurations didn’t seem to hold either, because the icons weren’t there, the taskbars weren’t in the proper locations.

I also can not load yast2 or google-chrome (only gui applications I tried.) Yast2 gave me no error messages, however google-chrome gave me some, which I failed to log. Opening google-chrome again gave me a different sort of status message, implying it was opening a new tab rather than a new instance of the program. Lead me to believe that when the system boots, it attempts to load an unworkable resolution layout.

I tried to install and uninstall the fglrx drivers a couple more times, thinking I could simply overwrite whatever it is I screwed up.

I then thought that reinstalling kde4 would do the trick, since reinstalling teh fglrx drivers didn’t work. This is where I am now. It doesn’t appear as if I’m getting a weird resolution, however my old desktop configuration is still not coming up when the system boots. Additionally, when I leave->logout, the login screen looks really skewed and only displays about half the log in page.

I’m desperately trying to get away from Windows, as well as my old habits for troubleshooting windows issues. How do I get my system back to how it was before I screwed everything up with updating fglrx?

Enter YaST->Software Management, type fglrx into the search field, and uninstall all packages that were found.
That should get the radeon driver working at least.

If you still have problems, please post the file /var/log/Xorg.0.log (upload to http://susepaste.org or similar and post a link).

I did as you instructed.

Booted back into the kde plasma ui, same flipped monitor situation as before. I noticed that I could move my mouse further beyond what he limits of my second monitor should be. That’s what it dawned upon me that my oculus was acting as a first screen … messing everything up without me realizing it.

I’ve since fixed the issue, installed the fglrx drivers, and everything seems to be working.

Only problem now is it reconfigure my desktop to how I want it. Is there a chance my old configs are still around and I can simply go back to them?

So you installed them again and it is working now?
Then you probably didn’t correctly remove/reinstall them before.

Only problem now is it reconfigure my desktop to how I want it. Is there a chance my old configs are still around and I can simply go back to them?

What old configs?
Did you change your desktop settings/panels/widgets by mistake?
I’m afraid the old ones are lost then.

I agree that I didn’t uninstall them properly the first time.

Lesson: learned.