fglrx freezes system on 11.1

Hi there, sorry to open a separated thread. I’v already saw some posts around regarding to the same issue but none works for me.

I 'm using 11.1 and when I installed the latest ATI official driver 8.12 the system hangs after starting X server.

I tried installing the driver directly, build and install release specific package (rpm), also inistall from repository at www2.ati.com/suse/11.1 or something like that, but the result is the same.

I followed every steps and troubleshooting steps in all kinds of documents I can find online, including removing the 32-bit so file and create a symbolic link from the 64-bit one, but all in vain.

Here is my symptom:

  1. After installing the driver package, run aticonfig --initial. The xorg.conf is successfully replaced. Part in the file regarding to the device section:

Section “Device”
BoardName “Radeon HD 2600 Pro”
Driver “fglrx”
Identifier “Device[0]”
BusID “PCI:1:0:0”
Option “BusType” “PCIE”
Option “Capabilities” “0x00000000”
Option “VideoOverlay” “on”
Option “OpenGLOverlay” “off”
Option “FSAAEnable” “off”
Option “FSAAScale” “0”
Option “XAANoOffscreenPixmaps” “true”
Option “BlockSignalsOnLock” “on”
Option “KernelModuleParm” “locked-userpages=0”
Option “UseFastTLS” “2”
Option “UseInternalAGPGART” “no”
Option “VideoOverlay” “on” # setting this to be “off” may fix tty switch problems?
Option “mtrr” “off”
Option “no_accel” “no”
Option “no_dri” “no”
Option “EnablePrivateBackZ” “no”
Option “backingstore” “true”
VendorName “ATI”
EndSection

Some options here are added manually for troubleshooting, but the result is the same when you remove all options.

  1. When running sax2 -r -m 0=fglrx, sax2 hangs after switching to graphical mode. The keyboard is also locked and I cannot switch back to tty1 or reboot. The only way to get through is to press the reset button on the PC.

There is no error information in the file SaX.log. Only information about the device, but no lines begin with [EE].

Framebuffer is disabled from GRUB.

  1. If I just start system to run level 5, or run startx to open X server, system also hangs after switching to graphical mode with no keybord response.

I checked the Xorg.0.log file, and there are no (EE) lines in the file either, but every time the last block of the log file seems to be the same:

(II) fglrx(0): [drm] DRM interface version 1.0
(II) fglrx(0): [drm] created “fglrx” driver at busid “PCI:1:0:0”
(II) fglrx(0): [drm] added 8192 byte SAREA at 0x2000
(II) fglrx(0): [drm] mapped SAREA 0x2000 to 0x7f242cbf7000
(II) fglrx(0): [drm] framebuffer handle = 0x3000
(II) fglrx(0): [drm] added 1 reserved context for kernel
(II) fglrx(0): DRIScreenInit done
(II) fglrx(0): Kernel Module Version Information:
(II) fglrx(0): Name: fglrx
(II) fglrx(0): Version: 8.56.4
(II) fglrx(0): Date: Dec 1 2008
(II) fglrx(0): Desc: ATI FireGL DRM kernel module
(II) fglrx(0): Kernel Module version matches driver.
(II) fglrx(0): Kernel Module Build Time Information:
(II) fglrx(0): Build-Kernel UTS_RELEASE: 2.6.27.7-9-default
(II) fglrx(0): Build-Kernel MODVERSIONS: no
(II) fglrx(0): Build-Kernel SMP: yes
(II) fglrx(0): Build-Kernel PAGE_SIZE: 0x1000
(II) fglrx(0): [drm] register handle = 0x00004000

X server seems to stop after the last line is generated.

  1. Running fglrxinfo any time gives the following result:

X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 143 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 10
Current serial number in output stream: 10

  1. I also tried to install an eralier version of the driver (8.11). The result is almost the same, except that SaX seems to be running for once, but only once. Later it still fails. Another difference is when X started, despite the black screen, the keyboard still has response, but it is still imposible to switch to other tty or soft reboot. Only the Numlock key still works.

Can anyone help on this?
Thanks!

I found Yast to be very problematic with the new ATI driver. Instead of using SAX after running the initial ati-config command start X and use the ati catalyst control center to configure the display.

But how can I start X after running aticonfig? When the aticonfig --initial is done, the file xorg.conf is already changed and X hangs immediately after switching to graphic mode with this conf file. I have no chance to run CCC at all.

Have you looked at any messages from /var/log/Xorg.0.log. It might point you in the right direction.

Yes, see my original message on the top floor. There is a block quoted from the last part of this file. As I said there is nothing begin with (EE) in the log.

The Ati repository for opensuse 11.1 is up and running.
just add the ati repo from community and you check the
appropriate boxes.
p, li { white-space: pre-wrap; } URL: http://www2.ati.com/suse/11.1
Linked from: http://opensuse-community.org/openSUSE_111_Community_Additional.xml
Summary: ATI Driver Repository
Description: Repository containing the drivers for ATI graphics cards. It provides the display driver files for the ATI RADEON (8500 and later), MOBILITY RADEON (M9 and later), RADEON XPRESS IGP and FireGL series of graphics graphics accelerators.

Thanks. I also tried installing the driver from that repository, as I mentioned above, and the result is the same.

well if your in Runlevel 5, you should be in run level 3 to install the driver. That way after installing the driver you can run the startx command and if X doesn’t start , then it simply doesn’t start and shouldn’t lock the machine. Once you have a working xorg.conf file, then when in X open the catalyst control center.

Well, to tell you the truth, I installed the driver in run level 3, and after running aticonfig, when I run startx, the X server hangs after switching to graphic mode and the keyboard has no response. The only way I can start X server is to remove the section added by aticonfig in the xorg.conf file. But in that case, when I run command amdcccle, it tells me that catalyst control center cannot start because ATI driver is not running…:\

Try un-installing the opensuse rpm that the ATI installer generated and use the generic installation instead. I had nothing but trouble with the generated rpm…