fglrx 10.6 black boxes

This is a common question from what I’ve seen, but I can’t seem to find a way to fix it. After installing latest Catalyst driver (from the repository, CCC reports as 10.6 but 10.8 release notes say that the bug is still there anyway), I see black boxes in firefox and elsewhere. A lot of sources say that it can be fixed by running “aticonfig --set-pcs-str=DDX,ForceXAA,TRUE”, however, that didn’t help me. Here’s my current xorg.conf:
INI file | Section “ServerLayout” Ident - GreatEmerald - etPMZ1qc - Pastebin.com

Is there a reason why the command won’t work correctly for me?

Same as here : Catalyst 10.8 issues with Mobility Radeon HD 2400 XT (iMac 20’’)

Solution: use radeonhd

Works fine here, with both 10.6 and 10.8 on a Radeon HD 3470 Mobility.
Here’s what I did:

  1. su (become root first)
  2. init 3 (temporarily change the runlevel to leave X)
  3. login as root to a console
  4. aticonfig --set-pcs-str=DDX,ForceXAA,TRUE
  5. reboot

thanks for your post since i was unaware of this aticonfig parameter workaround, it worked on the 3850HD box which had previously had the same issue on a previous install of the 10.8 driver. Sorry it didn’t work well for you. :slight_smile:

i’ll have to find out what DDX really is, the ForceXAA parameter is redundant since that is the default method.

Yeah the aticonfig command worked wonders for my firefox too!

Good Luck and Thanks!