ffmpeg and libfaac

I’ve recently updated a system I do a lot of video work on to 11.3 I am converting video’s to a variety of formats for devices that use aac audio

When I try to encode a video with ffmpeg using " -acodec libfaac " I now get the message: Unknown encoder ‘libfaac’

I see that ffmpeg does not return the --enable-libfaac when the ffmpeg command is given.

It looks like the build of ffmpeg I am using (0.6.0.25296-1.1-x86_64)
from the Videolan repository Index of /pub/vlc/SuSE/11.3/ wasn’t compiled with support for libfaac

Is there a package available for 11.3 that supports libfaac?

I’ve tried using the ffmpeg package for 11.2 but I still get the same error

Try using the packman versions they are kept up-to-date and should give you full functionality.

Always worth chacking
FFmpeg Documentation

The same issue happened with packman packages. This was not a problem with 11.2, so I have tried installing the same 11.2 package from the 11.2 videolan repository. It does not solve the problem

On another machine I have the packman 11.3 packages installed. I have ffmpeg 0.625512snv-2.pm3.1 from packman on another linux system and I have the same error.

I

Please make sure you do NOT have the Videolan repo enabled
Then use the package switcher to make sure all packages are from Packman

In kde: http://dl.dropbox.com/u/10573557/Switcher%20Pics/packman.jpg
In Gnome: http://dl.dropbox.com/u/10573557/Switcher%20Pics/packman%20in%20gnome.png

Thats pretty neat:
http://thumbnails33.imagebam.com/10300/bbc912102992771.jpg](http://www.imagebam.com/image/bbc912102992771)

I know openSUSE’s KDE’s QT YaST has had this for a while … was this just introduced in openSUSE-11.3 gnome’s YaST ?

I know openSUSE’s KDE’s QT YaST has had this for a while … was this just introduced in openSUSE-11.3 gnome’s YaST ?
AFAIK Yes
Much better isn’t it

I am trying to this on a non-critical system as a test. I am using packman from packman.iu-bremen.de/suse/11.3 and am getting Wrong Digest errors stating
The expected checksum of file xxxxx is xxxx but the current checksum is yyyy

This means that the file has been changed by accident or by an attacker since the repository created signed it.

I get this error for almost every package.

I believe there are other packman repository mirrors - should I try one?

Even when I configure a different mirror packman.jacobs-university/de/suse/211.3 I get the same error messages when I try to switch packages to packman. Could I have corrupted the authentication infomation on my own system?

I’ve tried a number of mirrors, packman unixheads in US geht.schon in germany same errors. Packman will sucessfully install one or two packages, and then return a Wrong Digest error.

I realize I can’t complain its opensource, but I am using this professionally have for the past year, but now its not working well. I’m looking like an idiot. What can I do to help solve this?

On 2010-10-21 02:36, holtslander-g wrote:

> I believe there are other packman repository mirrors - should I try
> one?

No, wait a day or a week. It is known that packman has that problem since today.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

On 2010-10-20 04:36, holtslander-g wrote:
>
> I’ve recently updated a system I do a lot of video work on to 11.3 I am
> converting video’s to a variety of formats for devices that use aac
> audio
>
> When I try to encode a video with ffmpeg using " -acodec libfaac " I
> now get the message: Unknown encoder ‘libfaac’

This is in my 11.2:

cer@Telcontar:~> ffmpeg -codecs | less -S

Codecs:
D… = Decoding supported
.E… = Encoding supported
…V… = Video codec
…A… = Audio codec
…S… = Subtitle codec
…S… = Supports draw_horiz_band
…D. = Supports direct rendering method 1
…T = Supports weird frame truncation

DEA aac Advanced Audio Coding

cer@Telcontar:~> rpm -qa | grep libfaac
libfaac0-1.28-2.pm.3.1.x86_64

I assume you have libfaac0 installed?

> I see that ffmpeg does not return the --enable-libfaac when the ffmpeg
> command is given.

Me neither.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

On 2010-10-21 03:09, holtslander-g wrote:

> I realize I can’t complain its opensource, but I am using this
> professionally have for the past year, but now its not working well.
> I’m looking like an idiot. What can I do to help solve this?

Now, very little… except download the sources and compile them yourself.

Other time, keep your local copy (repos: keep cache of downloaded packages), which means you can
reinstall the older version locally.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

Using the packman repository at ftp.uni-erlangen.de I have disabled the VideoLan repository and switched all the system packages to the packman respositry. With this repository I was able to successfully install all the packman packages, however it does not solve my initial problem. When I run ffmpeg with “-acodec libfaac” I am still returned a message stating “unknown encoder libfaac”

The details:

I get this output if I call a bash script using ffmpeg:

FFmpeg version UNKNOWN, Copyright (c) 2000-2010 the FFmpeg developers
built on Oct 1 2010 22:08:47 with gcc 4.4.1 [gcc-4_4-branch revision 150839]
configuration: --prefix=/usr --mandir=/usr/share/man --libdir=/usr/lib64 --shlibdir=/usr/lib64 --enable-pthreads --enable-shared --enable-avfilter --disable-static --enable-libmp3lame --enable-libxvid --enable-libx264 --enable-postproc --enable-shared --enable-libdc1394 --enable-libtheora --enable-libschroedinger --enable-libvpx --enable-gpl --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3
libavutil 50.32. 0 / 50.32. 0
libavcore 0. 9. 0 / 0. 9. 0
libavcodec 52.92. 0 / 52.92. 0
libavformat 52.79. 0 / 52.79. 0
libavdevice 52. 2. 2 / 52. 2. 2
libavfilter 1.48. 0 / 1.48. 0
libswscale 0.12. 0 / 0.12. 0
libpostproc 51. 2. 0 / 51. 2. 0

Seems stream 0 codec frame rate differs from container frame rate: 30000.00 (30000/1) -> 29.97 (30000/1001)
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from ‘CH_074.mp4’:
Metadata:
major_brand : isom
minor_version : 512
compatible_brands: isomiso2mp41
encoder : Lavf52.64.2
Duration: 00:00:23.37, start: 0.000000, bitrate: 3457 kb/s
Stream #0.0(und): Video: mpeg4, yuv420p, 1920x1080 [PAR 1:1 DAR 16:9], 3327 kb/s, 29.97 fps, 29.97 tbr, 30k tbn, 30k tbc
Stream #0.1(und): Audio: mp3, 44100 Hz, 2 channels, s16, 127 kb/s

Unknown encoder ‘libfaac’

video@linux-z616:~/NewVideoChinese> ffmpeg
FFmpeg version UNKNOWN, Copyright (c) 2000-2010 the FFmpeg developers
built on Oct 1 2010 22:08:47 with gcc 4.4.1 [gcc-4_4-branch revision 150839]
configuration: --prefix=/usr --mandir=/usr/share/man --libdir=/usr/lib64 --shlibdir=/usr/lib64 --enable-pthreads --enable-shared --enable-avfilter --disable-static --enable-libmp3lame --enable-libxvid --enable-libx264 --enable-postproc --enable-shared --enable-libdc1394 --enable-libtheora --enable-libschroedinger --enable-libvpx --enable-gpl --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3
libavutil 50.32. 0 / 50.32. 0
libavcore 0. 9. 0 / 0. 9. 0
libavcodec 52.92. 0 / 52.92. 0
libavformat 52.79. 0 / 52.79. 0
libavdevice 52. 2. 2 / 52. 2. 2
libavfilter 1.48. 0 / 1.48. 0
libswscale 0.12. 0 / 0.12. 0
libpostproc 51. 2. 0 / 51. 2. 0
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [infile options] -i infile]… {[outfile options] outfile}…

I’ve tried using the current version of ffmpeg as well as the previous versions avialable though the 11.2 reposiroy from packman

On 2010-10-21 04:36, holtslander-g wrote:
>
> Unknown encoder ‘libfaac’

It is aac. No “lib”.


encoder ‘aac’ is experimental and might produce bad results.
Add ‘-strict experimental’ if you want to use it.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

Recieved a reply from the packager of the Packman fffmpeg package he said:

“Sorry, my fault. libfaad is no longer needed for ffmpeg, looks like i’ve
also removed libfaac support. I’ll reenable it ASAP”

I expect a newer package (oct 21-2010) will fix this problem.
Thanks everyone for your hel9

On 2010-10-22 01:36, holtslander-g wrote:
>
> Recieved a reply from the packager of the Packman fffmpeg package he
> said:
>
> “Sorry, my fault. libfaad is no longer needed for ffmpeg, looks like
> i’ve
> also removed libfaac support. I’ll reenable it ASAP”

Curious. Perhaps my package is older, and thus I did not have the problem.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)

I have just upgraded to 11.3 from 11.2 and had the same issue, I found this from the changelog in YaST “15 November - disable faac support by default, as it makes the resulting packages break the GPL and hence may not be redistributed”.

So, how can I use libfaac in ffmpeg?

Is “aac” the same as “libfaac” or an alternate library?

Thanks

On 2010-12-10 17:36, Guymer wrote:
>
> I have just upgraded to 11.3 from 11.2 and had the same issue, I found
> this from the changelog in YaST “15 November - disable faac support by
> default, as it makes the resulting packages break the GPL and hence may
> not be redistributed”.
>
> So, how can I use libfaac in ffmpeg?

Is what it says is true, you would have to recompile it yourself.

> Is “aac” the same as “libfaac” or an alternate library?

Sometimes the ffmpeg people change the command line interface. They changed
a few things that broke my scripts.


Cheers / Saludos,

Carlos E. R.
(from 11.2 x86_64 “Emerald” at Telcontar)