FF10: default app for opening pdfs has changed.

Before Firefox 10.0, if I clicked on a hyperlink for a pdf, the default
application to be used was Okular. Now it has changed to Gimp(default)
with the only other option being “other…”

How is Gimp suddenly the default? In System Settings, File Associations,
for .pdf, the default apps are Okular and Gimp in that order of preference.


Graham Davis, Bracknell, Berks.
openSUSE 12.1 (64-bit); KDE 4.7.4; AMD Phenom II X2 550 Processor;
Video: nVidia GeForce 210 (using nouveau driver);
Sound: ATI SBx00 Azalia (Intel HDA); Wireless: BCM4306

It has done the same for .rar and .zips - opening Fileroller instead of ark. Needs changing in FF Edit-Preferences-File Associations

On 02/09/2012 04:06 PM, Graham P Davis wrote:

> How is Gimp suddenly the default? In System Settings, File Associations,
> for .pdf, the default apps are Okular and Gimp in that order of preference.

what you have set in KDE or Gnome (in system settings) tells KDE or
Gnome apps what to do, and has nothing to do what what Firefox thinks
you want [remember, firefox is a mozilla app, not a KDE or Gnome app],
so go in FF10

File > Edit > Preferences > Applications

give it a moment to fill in the bottom pane of the new window, then in
the search block type pdf

soon will show PDF Document and a spin to set selector to its right
where you can choose what you want to be done with PDF files…

if you don’t like what is offered there, choose “Use other” and navigate
your way to, and then click on /usr/bin/okular


DD
Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

On 09/02/12 15:33, DenverD wrote:
> On 02/09/2012 04:06 PM, Graham P Davis wrote:
>
>> How is Gimp suddenly the default? In System Settings, File Associations,
>> for .pdf, the default apps are Okular and Gimp in that order of
>> preference.
>
> so go in FF10
>
> File > Edit > Preferences > Applications
>
> give it a moment to fill in the bottom pane of the new window, then in
> the search block type pdf

Tried that yesterday but didn’t work. I see from your info that I had
not got it quite right so tried again but FF froze solid before it would
fill the bottom pane. Had to kill it.

Followed advice of caf4926 in “Firefox 10?” thread and reverted to FF9.
Clicked on PDF hyperlink and Okular appeared as default. Hooray!

As TB10 needs to be started twice before it will work, I may revert to
version 9 of that also. Don’t you just love this mania for issuing a new
version every few weeks?

Thanks for the advice; sorry I didn’t have the tenacity to give it
another try after the freeze.


Graham Davis, Bracknell, Berks.
openSUSE 12.1 (64-bit); KDE 4.7.4; AMD Phenom II X2 550 Processor;
Video: nVidia GeForce 210 (using nouveau driver);
Sound: ATI SBx00 Azalia (Intel HDA); Wireless: BCM4306

On 02/09/2012 07:04 PM, Graham P Davis wrote:
> As TB10 needs to be started twice before it will work, I may revert to
> version 9 of that also. Don’t you just love this mania for issuing a new
> version every few weeks?

i am using FB v 10 with no problems…none at all…

well, i am on 32 bit openSUSE 11.4 with KDE4.6.0
and oh of course Flash sucks…but, that is not a FF problem…


DD
Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

My 11.4_64/KDE4.8 with FF10 is working OK as well.

I tried on my 12.1_64/KDE4.8 test box and observed something unusual.
I was running FF9.0 from the 12.1 Updates repo.
I added the Mozilla 12.1 repo and installed Firefox 10.

Crashed on first start.
On restart, opened up and displayed my last (FF9) session tabs, so looked OK.
Looked in File > Edit > Preferences > Applications, there was no pdf content type to change .
Hmmm
Did a google search on “news in pdf” to get some URLs to try, selected first one, it opened with inkscape, a svg graphics program I use.
Looked again in File > Edit > Preferences > Applications, and there was pdf content type, I was able to make the change to /usr/bin/okular, which is now in effect.

My suspicions:
An upgrade (all?) to Firefox now resets some or all application/content types.
On first try , e.g. opening a file.pdf, Firefox chooses the most recent application to register as being pdf friendly, which in my case could be inkscape but on a clean install might be the gimp but in general could be one of many applications.
Whatever gets chosen can then be changed at File > Edit > Preferences > Applications .

Perhaps this behavior is what caf4926 calls ‘lack of KDE integration’ ?

Anyway, My FF10 on 12.1_64/KDE4.8 now seems good, opening items with okular.

I experienced the same behaviour following the update to FF10 (openSUSE 11.4, KDE 4.6.5), a few days ago, with the gimp set as default for pdf files. It was a simple matter to change (as already outlined by others).

I suppose it could be ‘corrected’ automatically for KDE users, with a ‘KDE-Firefox’ application integration package, but its difficult to correct manually for most users.

On 02/09/2012 09:46 PM, deano ferrari wrote:
> I experienced the same behaviour following the update to FF10 (openSUSE
> 11.4, KDE 4.6.5), a few days ago, with the gimp set as default for pdf
> files.

hmmmmmm…i had FF9 (and previous) set to always save pdf (rather than
open) and after 10 was installed that was still set…so, if anyone with
the problem ever gets around to logging a bug please come back here with
the bug number and i’ll add my detail to it…maybe it (save was kept
but Okular is replaced with GIMP) will help them find and squash


DD
Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

Sorry, I meant ‘…but its not difficult to correct manually for most users’.

On 09/02/12 15:33, DenverD wrote:
> so go in FF10
>
> File > Edit > Preferences > Applications
>
> give it a moment to fill in the bottom pane of the new window, then in
> the search block type pdf
>
> soon will show PDF Document and a spin to set selector to its right
> where you can choose what you want to be done with PDF files…
>
> if you don’t like what is offered there, choose “Use other” and navigate
> your way to, and then click on /usr/bin/okular

After having installed the new FF10 from “updates,” I succeeded in doing
what you recommended - after a fashion.

There was no entry for file type PDF in the “applications” list, so I
wasn’t able to alter the settings that way. Instead, I clicked on a pdf
link, “GIMP (default)” appeared, so I selected “other” in the pop-up
window and ticked “always use this…” I later checked “preferences =>
applications” and “PDF” had appeared in the list.

One more thing puzzles me. As there was originally no PDF entry in the
“applications” list, how did FF pick GIMP as default?


Graham Davis, Bracknell, Berks.
openSUSE 12.1 (64-bit); KDE 4.7.4; AMD Phenom II X2 550 Processor;
Video: nVidia GeForce 210 (using nouveau driver);
Sound: ATI SBx00 Azalia (Intel HDA); Wireless: BCM4306

On 02/11/2012 05:29 PM, Graham P Davis wrote:

> After having installed the new FF10 from “updates,” I succeeded in doing
> what you recommended - after a fashion.

what??? last i looked FF10 hadn’t flowed via update yet… (but, i hadn’t
looked since Friday!)

> One more thing puzzles me. As there was originally no PDF entry in the
> “applications” list, how did FF pick GIMP as default?

no idea…sounds like something is alive inside is crawling
around…and, you are not the first to find it…

begin here: http://tinyurl.com/nzhq7j


DD
Read what Distro Watch writes: http://tinyurl.com/SUSEonDW

Hi All,

This has happened as a result of an FF10 build being unexpectedly pushed to “updates”. A bug report has already been filed on Bugzilla here, but as a result of another symptom, namely that the KDE file manager is no longer used by FF10 on a KDE installation.

I can also confirm that on 11.4, 32 and 64 bit versions, that installing this update to FF10 also causes Gimp to be set as my default pdf viewer. This is an annoyance as, whilst I can set FF to use Okular in the preferences, I can’t get FF to ask me what to do AND have Okular as the default viewer if I choose to view the file. I’ll be adding my observations to the bug report in due course.

Ta, Bruno

I wonder which bright spark thought it a good idea to push this update through!
Hence I rolled back to v.9 and life is good.

On 02/17/2012 06:16 PM, brunoDEV wrote:
>
> I can also confirm that on 11.4, 32 and 64 bit versions, that
> installing this update to FF10 also causes Gimp to be set as my default
> pdf viewer.

i wonder why, with 11.4/32 with KDE4.6.0 i let the update flow from FF9
to FF10 and i continued to have PDF’s pre-selected to “always save” (as
i had selected) and just now switched it to “always ask” and now it does
that…

only strange thing here is it now offers only Acrobat, while my “file
associations” in KDE’s systems settings is set with these four, in this
order:
Okular
Acrobat Reader
GIMP
ePDFViewer

something is not right…i have added to the bug…thinking it might
help sniffing out the prob.


DD
Read what Distro Watch writes: http://tinyurl.com/SUSEonDW