fetchmail triggering modprobe


I have problems retrieving mails. Fetchmails throughput is slower than 1 email per second. It takes more than a minute to get 50 mails.

I’m using latest opensuse with all patches and a fetchmail->exim setup. (exim is not the problem; I tested fetchmail with a smtp-sink setup (from postfix) and with “–bsmtp /tmp/fetchmailtest”. Still less than 1 email per second. pushing hundreds of mails to exim via smtp-source is also fine)

The Internet connection is not even partly busy, the routers traffic activity LED is off most time.

At my old gentoo system everything is much faster using the same fetchmailrc and exim config, so I think it’s a problem inside my own PC and it’s a configuration issue inside the OpenSuSE System.

The system is nearly 0% IDLE while fetchmail is running (it’s a 1.6GHz Athlon w/ 1GB RAM) and it starts many “/sbin/modprobe -q – net_pf_10” and “[khelper]” processes. (with fast increasing PID)

Fetchmail seems to trigger some ipv6-configuration, so I tried to disable ipv6 in modprobe.conf.local (“alias net-pf-10 off” and “alias ipv6 off”) with no success. I tried to use “atop” (ATOP System & Process Monitor) to monitor old/died/removed processes but it seems OpenSuSEs default kernel does not support this kind of process accounting. I even tried to bind fetchmail to an IPv4-Address with no success. Disabling SuSEs firewall doesn’t help neither.

Does anyone has a solution? Maybe others having problems with many many “modprobe net_pf_10” without using fetchmail?

Thanks, T.Seelbaum

Sorry, no problems at all with fetchmail going into postfix here on openSUSE 11.1. No messages in syslog about net-pf-10 either.

But try the suggestions in this posting on how to disable net-pf-10:

‘Re: net-pf-10, 2.6.1’ - MARC](http://marc.info/?l=linux-kernel&m=107562975806592&w=2)

As I wrote, I did that already. If I remember correctly the “install net-pf-10 /bin/true” part is even set by default.

There is no error while modprobing, the only problem I see is the time it takes to fetch mails.

Definitely there are hundreds of processes forked while fetchmail runs because if I do a “ps” before and after fetching one single mail the PID differs so much (>300).

e.g.: I do a “ps” -> the ps-process has PID 1000, then I start fetchmail to fetch one single mail, then I do a “ps” a second time -> the ps-process has PID 1300. So there were nearly 300 processes forked while starting fetchmail, but I do not know what kind of processes. If I run “ps” while fetchmail runs I can only find process named fetchmail, khelper and modprobe.

The only program I know which is able to log process history is atop, but atop seems not to work with the OpenSuSE standard kernel :frowning:

Are there any other (standard) tools to log the history of processes?

I think “linux process accounting” and the little tool called “acct” is what I’m searching for. I’ll give it a try next time…

Have you looked to see if there are any clues in /var/log/fetchmail?

You might also want to add -v to FETCHMAIL_EXPERT_OPTIONS in /etc/sysconfig/fetchmail to get more log messages.