Fehlermeldung nach Installation von Codecs

Hallo

Habe auf meinem Leap 15 versucht die Codecs zu installieren, was auch problemlos geklappt hat, allerdings erhalte ich nach der Installation 2 Fehlermeldungen wenn ich in Discover nach Updates suche, unzwar wird angezeigt, “Repository unknown”, gleich zwei mal hintereinander.

Kann jetzt gar keine Programme mehr installieren, wird “Interner Fehler: Repository unknown” angezeigt.

Hatte diese Anleitung benutzt: SDB:Installing codecs from Packman repositories - openSUSE Wiki

Vielen Dank für eure Hilfe.

Und was wenn du mit YaST > Software > Onliune Updates, oder zypper up die Updates versuchst?

Das sind nämlich die beide openSUSE eigene Pfade zum Update.

Am besten du nuimmst

zypper up

dann ist es einfacher um das alles hier zu zeigen wenn was schief geht.

Und natürlich, zeige bitte die Repoliste:

zypper lr -d
1 Like

Es musste ein Schlüssel importiert werden, nachdem ich den Befehl von dir eingegeben habe. habe ich gemacht, nun kommt folgendes bei dem Befehl von dir, wenn ich ihn danach nochmal eingebe:

max@linux:~> sudo zypper up
Problem beim Abrufen der Dateien von 'openSUSE-Leap-15.5-1'.
Leeres Ziel in URI: hd:/?device=/dev/disk/by-id/usb-USB_SanDisk_3.2Gen1_040170b87b25bdf5f87bb20c503cb4224511f2fadde59c88f6a014b27547dcd5c0cf00000000000000000000e8e052a7ff1a7c1891558107a72c356e-0:0-part1
In der Fehlermeldung oben finden Sie einen entsprechenden Hinweis.
Warnung: Repository 'openSUSE-Leap-15.5-1' wird aufgrund des obigen Fehlers übersprungen.
Einige der Repositorys konnten aufgrund eines Fehlers nicht aktualisiert werden.
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

Die folgenden 50 Paketaktualisierungen werden NICHT installiert:
  ffmpeg-4 libass9 libavcodec57 libavcodec58_134 libavdevice57 libavdevice58_13 libavfilter6 libavfilter7_110
  libavformat57 libavformat58_76 libavresample3 libavresample4_0 libavutil55 libavutil56_70 libfdk-aac2
  libgbm1 libheif1 libpipewire-0_3-0 libpostproc54 libpostproc55_9 libquicktime0 libswresample2
  libswresample3_9 libswscale4 libswscale5_9 libvlc5 libvlccore9 libvulkan_intel Mesa Mesa-dri Mesa-gallium
  Mesa-libEGL1 Mesa-libGL1 Mesa-libglapi0 Mesa-libva Mesa-vulkan-device-select pipewire pipewire-alsa
  pipewire-lang pipewire-modules-0_3 pipewire-pulseaudio pipewire-spa-plugins-0_2 pipewire-spa-tools
  pipewire-tools vlc vlc-codec-gstreamer vlc-lang vlc-noX vlc-qt vlc-vdpau
Keine auszuführenden Aktionen.

Hier die Repositorys:

max@linux:~> zypper lr -d
#  | Alias                       | Name                                                                                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                                                                                                                    | Service
---+-----------------------------+---------------------------------------------------------------------------------------------+---------+-----------+---------+----------+--------+----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+--------
 1 | openSUSE-Leap-15.5-1        | openSUSE-Leap-15.5-1                                                                        | Ja      | (r ) Ja   | Ja      |   99     | rpm-md | hd:/?device=/dev/disk/by-id/usb-USB_SanDisk_3.2Gen1_040170b87b25bdf5f87bb20c503cb4224511f2fadde59c88f6a014b27547dcd5c0cf00000000000000000000e8e052a7ff1a7c1891558107a72c356e-0:0-part1 | 
 2 | packman                     | packman                                                                                     | Ja      | (r ) Ja   | Ja      |   90     | rpm-md | https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.5/                                                                                                                    | 
 3 | repo-backports-debug-update | Update repository with updates for openSUSE Leap debuginfo packages from openSUSE Backports | Nein    | ----      | ----    |   99     | N/A    | http://download.opensuse.org/update/leap/15.5/backports_debug/                                                                                                                         | 
 4 | repo-backports-update       | Update repository of openSUSE Backports                                                     | Ja      | (r ) Ja   | Ja      |   99     | rpm-md | http://download.opensuse.org/update/leap/15.5/backports/                                                                                                                               | 
 5 | repo-debug                  | Debug Repository                                                                            | Nein    | ----      | ----    |   99     | N/A    | http://download.opensuse.org/debug/distribution/leap/15.5/repo/oss/                                                                                                                    | 
 6 | repo-debug-non-oss          | Debug Repository (Non-OSS)                                                                  | Ja      | (r ) Ja   | Ja      |   99     | rpm-md | http://download.opensuse.org/debug/distribution/leap/15.5/repo/non-oss/                                                                                                                | 
 7 | repo-debug-update           | Update Repository (Debug)                                                                   | Ja      | (r ) Ja   | Ja      |   99     | rpm-md | http://download.opensuse.org/debug/update/leap/15.5/oss/                                                                                                                               | 
 8 | repo-debug-update-non-oss   | Update Repository (Debug, Non-OSS)                                                          | Nein    | ----      | ----    |   99     | N/A    | http://download.opensuse.org/debug/update/leap/15.5/non-oss/                                                                                                                           | 
 9 | repo-non-oss                | Non-OSS Repository                                                                          | Ja      | (r ) Ja   | Ja      |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.5/repo/non-oss/                                                                                                                      | 
10 | repo-openh264               | Open H.264 Codec (openSUSE Leap)                                                            | Ja      | (r ) Ja   | Ja      |   99     | rpm-md | http://codecs.opensuse.org/openh264/openSUSE_Leap/                                                                                                                                     | 
11 | repo-oss                    | Haupt-Repository                                                                            | Ja      | (r ) Ja   | Ja      |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.5/repo/oss/                                                                                                                          | 
12 | repo-sle-debug-update       | Update repository with debuginfo for updates from SUSE Linux Enterprise 15                  | Nein    | ----      | ----    |   99     | N/A    | http://download.opensuse.org/debug/update/leap/15.5/sle/                                                                                                                               | 
13 | repo-sle-update             | Update repository with updates from SUSE Linux Enterprise 15                                | Ja      | (r ) Ja   | Ja      |   99     | rpm-md | http://download.opensuse.org/update/leap/15.5/sle/                                                                                                                                     | 
14 | repo-source                 | Source Repository                                                                           | Nein    | ----      | ----    |   99     | N/A    | http://download.opensuse.org/source/distribution/leap/15.5/repo/oss/                                                                                                                   | 
15 | repo-update                 | Hauptaktualisierungs-Repository                                                             | Ja      | (r ) Ja   | Ja      |   99     | rpm-md | http://download.opensuse.org/update/leap/15.5/oss                                                                                                                                      | 
16 | repo-update-non-oss         | Aktualisierungs-Repository (Nicht-Open-Source-Software)                                     | Ja      | (r ) Ja   | Ja      |   99     | rpm-md | http://download.opensuse.org/update/leap/15.5/non-oss/                                                                                                                                 | 
max@linux:~> 

Erstens solltest du das Repo das mit hd: started mindestens “disabled” machen, oder sogar löschen. Das ist dein Installationsmedium. Brauchst du nicht mehr.

2 Likes

Danke, habe das deaktiviert und nun wird folgendes beim “up”-Befehl angezeigt:

max@linux:~> sudo zypper up
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...

Die folgenden 50 Paketaktualisierungen werden NICHT installiert:
  ffmpeg-4 libass9 libavcodec57 libavcodec58_134 libavdevice57 libavdevice58_13 libavfilter6 libavfilter7_110 libavformat57 libavformat58_76 libavresample3 libavresample4_0 libavutil55 libavutil56_70 libfdk-aac2
  libgbm1 libheif1 libpipewire-0_3-0 libpostproc54 libpostproc55_9 libquicktime0 libswresample2 libswresample3_9 libswscale4 libswscale5_9 libvlc5 libvlccore9 libvulkan_intel Mesa Mesa-dri Mesa-gallium
  Mesa-libEGL1 Mesa-libGL1 Mesa-libglapi0 Mesa-libva Mesa-vulkan-device-select pipewire pipewire-alsa pipewire-lang pipewire-modules-0_3 pipewire-pulseaudio pipewire-spa-plugins-0_2 pipewire-spa-tools
  pipewire-tools vlc vlc-codec-gstreamer vlc-lang vlc-noX vlc-qt vlc-vdpau
Keine auszuführenden Aktionen.
max@linux:~> 

So, habe den Befehl für die Codecs Installation nochmal durchgeführt und es scheint nun keine Fehlermeldungen mehr beim Befehl zu geben. Vielen Dank für die Hilfe.

Welche der Variante aus dem Wiki hast du zum installieren der Codecs verwendet? Vendor-change durchgeführt?

sudo zypper dist-upgrade --from packman --allow-vendor-change
1 Like

Hier: SDB:Installing codecs from Packman repositories - openSUSE Wiki Option 2. Hatte aber Option 1 auch hinzugefügt, ist das ein Problem?

max@linux:~> sudo zypper dist-upgrade --from packman --allow-vendor-change
Repository-Daten werden geladen...
Installierte Pakete werden gelesen...
Distributions-Aktualisierungen werden verarbeitet...
Keine auszuführenden Aktionen.
max@linux:~> 

Sieht eigenlich gut aus.

Die angegebene Pakete werden nich geladen weil die Updates von OSS sind und du jetz die Packan Pakete hast.

Zufällig sehen die Versionsangaben “neuer” aus. Aber weil Packman seine eigene Versionsbenennung hat ist das unwichtig.

1 Like

Ok, was ist “packman” kenne das von Manjaro, is das da nicht irgendwie der Paketmanager für das System?

Der Paketmanger heißt pacman.

packman hingegen ist ein Repository welches Pakete bereitstellt welche aus Lizenzgründen nicht in den offiziellen Repos vertrieben werden können…

1 Like