feedreader doesn't seem to work

I’ve tried to install feedreader to try its Feedly integration, but it does not seem to work, at least I could not find how to do it.

When I try to run it, an empty window appears, where you supposedly have to connect to an account, but I can’t find out how.

It seem to be a Gnome app and I’m running on Plasma Desktop, but so far I have used other Gnome apps without any problem, I don’t understand why this one seems not to work.

Any clues?


Based on a 2 second glance at the FeedReader website at https://jangernert.github.io/FeedReader/

Feedreader doesn’t seem to consume feeds directly, but may be a really nice way to format and organize your different RSS feeds.
You likely need to point FeedReader to one of the apps or services you see on the FeedReader website.

If you have problems setting it up, post again…
It looks like an interesting and useful enhancement somebody (including myself) might be willing to spend more time on.

Based on a 2 second glance and not reading documentation,

Yes, I was exactly trying to use it in conjunction with my Feedly account, but I can’t find how to connect it.

According to the screenshot that I posted earlier, I should be able to select a supported service from the box in that window. But it is empty, and I can’t figure out how to connect to any service.

Could it be because this app is integrated with some Gnome services/frameworks and I’m trying to use it under KDE Plasma?

Nope, looks like it’s broken… tested here and see the same on GNOME DE…

Bug report time;
openSUSE:Submitting bug reports - openSUSE

I would attach the daemon and ui logs to the bug report down in ~/.local/share/feedreader directory.

Apparently this was already submitted here https://bugzilla.opensuse.org/show_bug.cgi?id=1042352

It was also marked as solved but apparently the problem persists.

Reported the bug here https://bugzilla.opensuse.org/show_bug.cgi?id=1076289

On Wed 17 Jan 2018 01:06:01 AM CST, sekhemty wrote:

Reported the bug here

I see it’s been fixed now :wink:

However I decided to build the 2.2-dev release and have created an
issue on github about it…

If you want to try the dev version the project is here;

Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.3|GNOME 3.20.2|4.4.104-39-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

It was marked as fixed but on my (updated) system the problem persists.

This looks like it might fix your problem:
(it also references the bug report)

Note that it hasn’t been accepted to the devel project yet, so will still take some time until it would be available in Tumbleweed.

Thanks, I’m not too much informed about all the development process, so I had no idea that the bug could be closed before the fix is applied.

Sure, everybody can close bugs whenever they like, even you. This is openSUSE after all. :wink:

In general, a bug report is normally closed as fixed when the fix is submitted, not when it is actually available in the repos.

In this case, that bug report has been closed half a year ago already though. So probably it was fixed, but reappeared again now. Or maybe the previous fix didn’t really work as intended and nobody noticed until now.

I put it down to cmake and macro changes as Tumbleweed has moved on…

Fighting the dev version and CMAKE_SOURCE_DIR and CMAKE_BINARY_DIR and vala…

In any case, the submission to Tumbleweed is on the way:

After the last update the app is working fine, and it is a really good one too.

This apps seems to still have some problems: I have reported it here