Feedback on openSUSE Tumbleweed installer

I recently moved to openSUSE from Debian and I wanted to share two feedbacks on the installer:

  • The installer should strongly recommend btrfs since then you’ll get automatic snapshots when the system does updates using zypper. This is not obvious to new users. The snapshots, per my understanding, don’t take up a lot of space so it’s worth having. Especially if they are new to openSUSE, they may muck things up when they install things, and being able to revert is super nice.
  • If someone selects installing KDE or Gnome, then it should disable the SSH service/port by default, unless the user checks it. Right now it defaults to SSH service/port enabled and open. If someone is installing a DE, they are most likely not doing remote connections into it. If they are, then they know what they are doing and would know to enable it.

No need for recommendation as the openSUSE installer already sets up btrfs as standard. You already need to use the expert partitioner to use a specialized/adapted setup. So what is your question here?

But there are a lot of users who need other setups as btrfs as they have other backup and system maintenance strategies. I don’t use btrfs on any of my Tumbleweed machines and never needed snapshots as there are enough other ways to reach the same goals…

As this is the users-help-users forum, this is the wrong channel for such requests as the devs don’t read here.You should file a feature request or bugreport if you want to get that changed.

If you use the recommended partitioning, you will get “btrfs”.

If you use the expert partitioner and create a new partition for root, it will suggest “btrfs”.

If you use the expert partitioner, but just reuse an existing partition, it will default to the current file system on that partition.

To me, this seems strong enough.

Are you sure?

I’ll admit that it is a few months since I last installed Tumbleweed.

My impression is that the default is leave the “sshd” service disabled an the firewall port closed for “ssh”. However, if it finds an existing linux system already there on your disk, then it decides whether to enable “sshd” and open the port based on what was used by the existing system. I’m inclined to think that should work well for most users.

When I did it the other day and chose KDE the defaults were:

  • firewall enabled
  • sshd enabled
  • port opened for ssh

I thought it was a little odd and switched off the last two myself before proceeding.

I saw the same on a recent install of Leap 15.5.

However, on another install to a clean disk (in a VM) it gave me:

  • sshd disabled
  • firewall closed for ssh.

The installer has a nice page: openSUSE Leap 15.4 | Start-Up | Installation steps

Users may want to check settings before performing the installation. Experienced users rely on a checklist of their own.

That’s true. Unlike Leap versions, each time you UPGRADE (zypper dup) Tumbleweed, sshd is disabled!!! I don’t like that, but that’s how it’s working in Tumbleweed.

This topic is about initial installation. If you have question about zypper dup please start new topic with clear subject.

True. I guess it’s not obvious that zypper will automatically take snapshotots if you have a btrfs filesystem. That’s a good thing to know during the installation process. I’ve always used ext4 and could see many others doing the same. In fact, reading the comments in the #opensuse IRC channel, I think many still do use ext4 and probably don’t know/realize about the auto-snapshots with btrfs and zypper. I am just saying I think the installer should have some kind of help text on that screen that says btrfs is recommended because then zypper will automatically take snapshots which will let users restore to a previous point, including file level restoral.

I saw where to submit bugs. I can’t find where to submit requests. Would it just be a submission to the bug report site?

See my comment above how it’s unobviousness that with btrfs, zypper will automatically take snapshots before doing anything. That’s a super, super slick feature and the installer should let users know. IMHO.

Yes. I just went through the installer 4 times cause I kept mucking my OS up. This latest time I used btrfs. But each time, both SSH checkboxes were checked by default.

Each time I installed, I pre-formatted my main disk so there was no existing OS.

Not sure how that relates to what I’m talking about? It mentions nothing about zypper taking auto snapshots with btrfs. Additionally, there is a mistake on that page. This statement is wrong:

The SSH service is enabled by default, but its port (22) is closed in the firewall.

All 4 times I installed openSUSE Tumbleweed, SSH was enabled and port 22 was open.

I don’t follow? Is this post-install? I’m talking about during the installation screen.

This statement is about Leap 15.4 and your topic is about Tumbleweed. You cannot claim that documentation for Leap 15.4 is wrong because Tumbleweed behaves differently.

True. But then someone posted it here, a thread about Tumbleweed, so I assumed they were implying it applies to Tumbleweed too.

As others pointed out, a separate topic would be good to discuss this; I will state, though, that I run zypper dup on my TW installation fairly regularly, and it’s never turned off sshd.

Indeed. To the extent I understand installer it should enable sshd for non-sererver roles if no root password was provided which is only possible if public key was imported. And (transactional) server roles explicitly enable sshd. But sshd gets enabled e.g. for KDE desktop.

It sounds like a bug. You may consider bug report.

P.S. documentation for Leap does not seem to be accurate either. I do not see where current YaST would enable sshd - default is disabled. Again, I readily admit I may have missed something.

I just tried a fresh install into a VM with clean disk, with KDE as desktop.

You are correct. It wants to enable sshd and open the ssh port.

This is a relatively recent change. Personally, I prefer it this way, so I won’t be complaining.

The installer easily gives shows the option for SSH and the Open Port, and anyone can easily change it. I see no issue here. For me, I see it as Enabled and Open. That’s fine for my use case. No complaints from me.

As far as the choice for BTRFS on the partitioning screen, BTRFS is the default, as it should be. However, I can see your reasoning for some explanation on the screen, as there is plenty of room for that and it would just be an addition of some text.

The YAST installer is a bit long in the tooth, and very old, but it is still the most powerful installer I have seen on any distro. People complain about it, but I prefer it to any installer out there. I just wish is was faster. :smiley:

IMO it’s far and away the best installer I’ve ever used, though I’ve seen it’s capability diminish over the years. Its speed is a non-issue here, competence being totally more important than speed.

1 Like

I agree. I overlook the speed just because it is still the best. The ability to have the full YAST package manager at a (details) button click is something no other installer has.

1 Like

Sure. A program failing to do what it was told to do is no issue. Why bother?

I had not researched the bug report. I had no idea that it was failing to do something it is supposed to do. I only stated that the installer showed that it was enabled and gave the option to change it and that I had no issue with that. I guess I was wrong and should have issue with it, but I don’t.

I agree. It is a very well designed and robust installer.

Agreed. I don’t need my installer fast cause I’m only installing once.

1 Like