Fedora not showing up in bootloader


I partitioned my hard disks into different compartments after installing Windows 8. I then installed Fedora 20 in one of the empty partitions. I installed OpenSuse (GNOME) in yet another partition and made sure it wasn’t installed in either the Fedora or Windows partition. The installation was successful but now, Fedora is not showing up in the bootloader (GRUB 2). How do I make GRUB see the Fedora OS?

Thank you.:slight_smile:

I have not tried Fedora 20, so I’m not sure why that is happening.

One option would be to manually enter grub boot commands in “/etc/grub.d/40_custom” (on your opensuse install). Then, when grub.cfg is rebuilt, it will contain those commands.

Mount the fedora root partition in openSUSE
then run

su -
grub2-mkconfig -o /boot/grub2/grub.cfg

Should not be needed. But you need to enable "Probe for foreign OS "in yast bootloader.