Fed up with Google Earth

Okay, I have been trying to get Google Earth to work on my laptop for about the last 5 months. I keep checking the forums to see if there is some magic answer or to see if there is a new version. For some reason it never seams to work for me.
When I was running SUSE 10.2 GE was working fine with as an older version that I cannot download now. Once I upgraded to 11.0 I started to have all the problems.
Right now I have downloaded the 4.3 version of GE, deleted the libcrypto file and it will finally open. The problem is that it is so slow it is pretty much useless.
Please point me in the right direction to get GE up and running.

It’s probably not GE’s fault…
Did you install the proper drivers for your graphic card?
Remember, usually, when you compile the driver yourself, you need to run sax to enable it … or tweak it.
If you are on a laptop, makes sure you are using the ‘native resolution’ otherwise things tend to slow down (I have no idea why).

NVIDIA: NVIDIA - openSUSE
ATI: ATI - openSUSE
(You can find out which card you have in the ‘My System’: sysinfo:/

Good advice by catcatmu. It depends on your grapgics hardware and drivers used. Some intel graphics hardware / drivers have problems with GE. Post further details if you require more assistance.

Two useful commands:

/usr/sbin/hwinfo --gfxcard
glxinfo |grep direct

I used the commands to find this out about my graphics card. But I cant tell if it is NVIDIA or ATI.

27: PCI 02.1: 0380 Display controller
[Created at pci.310]
UDI: /org/freedesktop/Hal/devices/pci_8086_27a6
Unique ID: ruGf.nBtp4Kcx6AF
SysFS ID: /devices/pci0000:00/0000:00:02.1
SysFS BusID: 0000:00:02.1
Hardware Class: graphics card
Model: “Intel Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller”
Vendor: pci 0x8086 “Intel Corporation”
Device: pci 0x27a6 “Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller”
SubVendor: pci 0x103c “Hewlett-Packard Company”
SubDevice: pci 0x30a0
Revision: 0x03
Memory Range: 0xd8180000-0xd81fffff (rw,non-prefetchable)
Module Alias: “pci:v00008086d000027A6sv0000103Csd000030A0bc03sc80i00”
Config Status: cfg=no, avail=yes, need=no, active=unknown

28: PCI 02.0: 0300 VGA compatible controller (VGA)
[Created at pci.310]
UDI: /org/freedesktop/Hal/devices/pci_8086_27a2
Unique ID: _Znp.jVgxkmy9GP8
SysFS ID: /devices/pci0000:00/0000:00:02.0
SysFS BusID: 0000:00:02.0
Hardware Class: graphics card
Model: “Intel 945 GM”
Vendor: pci 0x8086 “Intel Corporation”
Device: pci 0x27a2 “945 GM”
SubVendor: pci 0x103c “Hewlett-Packard Company”
SubDevice: pci 0x30a0
Revision: 0x03
Memory Range: 0xd8100000-0xd817ffff (rw,non-prefetchable)
I/O Ports: 0x1800-0x1807 (rw)
Memory Range: 0xc0000000-0xcfffffff (rw,prefetchable)
Memory Range: 0xd8200000-0xd823ffff (rw,non-prefetchable)
IRQ: 16 (2555959 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v00008086d000027A2sv0000103Csd000030A0bc03sc00i00”
Driver Info #0:
XFree86 v4 Server Module: intel
Driver Info #1:
XFree86 v4 Server Module: intel
3D Support: yes
Extensions: dri
Config Status: cfg=no, avail=yes, need=no, active=unknown

From your message:

Model: “Intel Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller”

you have an Intel graphic card.

that is what I thought, so how do I go about making sure that I have the current drivers for it?

Have a read of this thread first, (discusses the problem you’re having). It contains a link to this blog, which mentions that a recent X.Org patch is available for intel driver from this repo:

Index of /repositories/X11:/XOrg/openSUSE_11.1

Follow the instructions outlined in medwinz’s blog and see how you get on.

Note that it is suggested that compiz needs to be disabled as well. (If using KDE 4.X, kwin works well for most anyway).

Good luck.

Okay I think that was able to add the repository that you linked me to, but I am running 11.0 right now and had to go with the other repo. I updated my system and the drivers should be good. I opened up Compiz Config but I am not sure how to disable it.

Still no luck in figuring out the Compiz issues or if it is even needed. I am able to open GE and it appears to be running but it is so slow that I really cannot use it.
I have a VM on the same machine running WinXP and GE works fine on it, just a little slower because it is on my VM.
I am starting to wonder if it just is an issue with the Linux GE version

Google Earth 4.3.7284.3916 (beta)
Build Date Jul 8 2008
Build Time 18:49:58
Renderer OpenGL
Operating System Linux (2.6.25.20)
Video Driver Tungsten Graphics, Inc
Max Texture Size 2048x2048
Server kh.google.com

For openSUSE 11.0, the relevant repo is:

Index of /repositories/X11:/XOrg/openSUSE_11.0

What desktop are you using? If KDE 4.x, you can set kwin from

Configure Desktop > KDE Components > Session Management.

Ignore last post about configuring kwin (if using KDE 4.x)… confusion. Just do Alt-F2, then enter

kwin --replace

That should do it.

I ran the command and there was no difference in how GE worked. It is still super slow also when it is running it slows my computer down.
I also uninstalled and reinstalled GE to see if for some crazy reason the new 5.0 version would work.
If you have any other ideas please let me know.

If Google Earth crashes during startup, remove the hidden folder “.googleearth” in your home-directory.

Google Earth is extremely slow on Intel graphics. You can make it much faster by disabling View -> Atmosphere.

Teuniz, you are the man. I am a little pissed my self because it was so simple as turning the atmoshpere off.

I am happy now that I can actually use GE, I guess I will take another stab at the new 5.0 version another day to see if I can get it to actually open up. I guess the next step after that is to be able to use my GPS with it.