fcitx / mozc issues in lates tumbleweed update

Tried to update to latest snapshot today from 20220210 (Plasma)
Getting the following re fcitx / mozc

Problem: the to be installed fcitx-mozc-2.26.4660.102-1.1.x86_64 requires 'libfcitx-config.so.4()(64bit)', but this requirement cannot be provided
  deleted providers: libfcitx-4_2_9-
not installable providers: libfcitx-config4-[repo-oss]
 Solution 1: deinstallation of fcitx-mozc-2.26.4276.102-2.4.x86_64
 Solution 2: deinstallation of libFcitx5Config6-5.0.13-1.1.x86_64
 Solution 3: install fcitx-mozc-2.26.4276.102-3.2.i586 despite the inferior architecture
 Solution 4: keep obsolete fcitx-mozc-2.26.4276.102-2.4.x86_64
 Solution 5: keep obsolete libFcitx5Config6-5.0.13-1.1.x86_64
 Solution 6: keep obsolete libfcitx-4_2_9-
 Solution 7: break fcitx-mozc-2.26.4660.102-1.1.x86_64 by ignoring some of its dependencies

can anyone point me to the correct solution?
I tried option 4 but then got a long list of other issues.

I think I’ve worked it out.
Looks like fcitx has updated from fcitx (fcitx4) to fcitx5 and some manual intervention is required to complete the migration.

How did you solve the problems?

I just ran the wizard but, nothing works and the menu is in Chinese now, instead of the system locale.

yast is in Chinese after the wizard :open_mouth: that is not right. What stupid things happened here