fcgi + Apache

I have been running an apache server with PHP5 and MySQL for a couple of months now and ive tried to to install rails for ruby. Rails comes with its own web server which works fine (but if set to port 80 would conflict with apache).

Ive tried to setup the fcgi module for apache2. I Have ruby gems installed and working, and rails works fine. The fcgi module for ruby has been installed and i think is working.

mod_fcgid.so exists in /usr/lib/apache2 but when i add these lines to httpd.conf it just breaks

LoadModule fcgid_module /usr/lib/apache2/mod_fcgid.so
# in case of mod_fcgid you may want to add 
<IfModule mod_fcgid.c>
    AddHandler fcgid-script .fcgi
    IPCCommTimeout 40
    IPCConnectTimeout 10
    DefaultInitEnv RAILS_ENV production
    SocketPath /tmp/fcgidsock

when i use apache2ctl start i get no error messages, but why i try to start it through system services in Yast it says that an unspecified error occoured

Check /var/log/apache2/error_log and paste any errors you get here.

the error log contains:

[Tue Jun 17 11:15:50 2008] [notice] caught SIGTERM, shutting down
[Tue Jun 17 11:15:53 2008] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Tue Jun 17 11:15:53 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
[Tue Jun 17 11:15:54 2008] [emerg] (2)No such file or directory: mod_fcgid: Can't create share memory for size %zu byte

Perhaps it’s related to:
[Bug 337566] New: missing SharememPath setting in default mod_fcgid.conf](http://lists.opensuse.org/opensuse-bugs/2007-10/msg12368.html)

Do not use fcgi to run RoR. use Phusion passenger instead.