FATAL: Module matroxfb_maven not found.

Inspecting /boot/System.map-2.6.27.7-9-default
Cannot find map file.
No module symbols loaded - kernel modules not enabled.

Cannot build symbol table - disabling symbol lookups

Setting up (localfs) network interfaces:
lo
lo IP address: 127.0.0.1/8
IP address: 127.0.0.2/8
doneInitializing random number generatordone
Framebuffer setup: matroxfb_base matroxfb_maven FATAL: Module matroxfb_maven not found.
matroxfb_crtc2 failed
eth0 device: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
eth0 IP address: 192.168.1.100/24
<notice>checkproc: /usr/bin/kdm 2087

Starting X Font Server<notice>startproc: execve (/usr/bin/xfs) /usr/bin/xfs -nodaemon -user nobody -port 7100 ], CONSOLE=/dev/console ROOTFS_FSTYPE=ext3 SHELL=/bin/sh TERM=linux ROOTFS_FSCK=0 LC_ALL=POSIX INIT_VERSION=sysvinit-2.86 REDIRECT=/dev/tty1 COLUMNS=80 PATH=/bin:/sbin:/usr/bin:/usr/sbin vga=0x317 DO_CONFIRM= RUNLEVEL=5 PWD=/ SPLASHCFG= PREVLEVEL=N LINES=43 HOME=/ SHLVL=2 splash=silent SPLASH=no ROOTFS_BLKDEV=/dev/disk/by-id/ata-SAMSUNG_SV4012H_0455J1ATB01543-part7 _=/sbin/startproc DAEMON=/usr/bin/xfs ]
done
Starting Firewall Initialization (phase 2 of 2) done
done
Master Resource Control: runlevel 5 has been reached
Failed services in runlevel 5: fbset
Skipped services in runlevel 5: nfs splash
<notice>killproc: kill(1787,3)

shown above are parts of boot.msg
boot up always get to a point where i have to enter and select a font for console 1-9

framebuffer message i dont understand.

what about the missing module?

otherwise system seems to work ok.

how do i pass a ‘no frame buffer’ option to kernel?

ramaswamyps schrieb:
>> doneInitializing random number generatordone
>> Framebuffer setup: matroxfb_base matroxfb_maven FATAL: Module
>> matroxfb_maven not found.
>> matroxfb_crtc2 failed
>
> shown above are parts of boot.msg
> boot up always get to a point where i have to enter and select a font
> for console 1-9
>
> framebuffer message i dont understand.
>
> what about the missing module?
>
> otherwise system seems to work ok.

You give precious little information about your system to go by.

What type is your graphics adapter? Is it or isn’t it from Matrox?
What’s your kernel command line? Has it worked previously? If so,
did you change anything? Or is this a fresh install? If so, did
everything work fine during the installation itself? Which graphics
driver did you install?

my graphi card is 845 integrated i810.
i had to use vesa to install .
it is still running at default vesa res of 800x600 mode not changeable.
if so why it should look for matrox module?
i get kde4 transparency also work sometimes.
i am not able to load any other mode for the screen resolution.

if i can use screen without fb probably i810 driver might work.

what boot option for nofb?

ramaswamyps schrieb:
> my graphi card is 845 integrated i810.
> i had to use vesa to install .
> it is still running at default vesa res of 800x600 mode not
> changeable.

Strange. When I last set up a system with that graphics adapter it worked
fine. So perhaps you should look for the problem there. What happens if
you try to set it up normally?

> if so why it should look for matrox module?

It shouldn’t. Something is wrong there.

> i get kde4 transparency also work sometimes.

Don’t try to take the second step before the first.

> i am not able to load any other mode for the screen resolution.

What did you try? In which way did it not work?

> if i can use screen without fb probably i810 driver might work.

What do you mean, “without fb”?

if i mention intel driver in xorg.conf
i get blank screen or un-synchronised vertical color lines for X
vesa only works.
but it does not read xorg,conf for normal boot up.
nofb means no frame buffer .
i dont think my monitor supports fb.
i installed with yast2 command line.
matroska module search only surprises me.

linux-3fxc:~ # lspci
00:00.0 Host bridge: Intel Corporation 82845G/GL[Brookdale-G]/GE/PE DRAM Controller/Host-Hub Interface (rev 03)
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GEChipset Integrated Graphics Device (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 82)
00:1f.0 ISA bridge: Intel Corporation 82801DB/DBL (ICH4/ICH4-L) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801DB (ICH4) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC’97 Audio Controller (rev 02)
01:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
linux-3fxc:~ #

any suggestions for mode 1020x768?