Fatal Error - No Screens Found

… when installing NVidia 185 drivers according to the guide
Nvidia Installer HOWTO for SUSE LINUX users

I have:-

Downloaded drivers tonight (latest 185.18.14 IIRC)
init 3
sh NVIDIAxxx -q
“Installed ok”
sax2 -r -m 1=nvidia (1 because it’s a PCI card, 0 is the on-board one).

I then get “XC: Sorry could not start configuration server”
the log files simply write “Fatal Server Error: No screens found”.

If i use “sax2 -m 1=vesa” then I get a display but it’s quite awful and jerky :frowning:

I am using Suse 11.0 PAE Kernel and a NV 6200 card.

Please, if someone can help I would very much appreciate it.
Oh, and before I forget, I copied another /etc/X11/xorg.conf from another machine (which has the same video card in) onto this one, rebooted without running sax2 and I still don’t get X server running :frowning:

Are you certain you downloaded the correct nVidia driver?

You may have a misconfigured xorg file, try reconfiguring your card again with sax2 (just run it without any parameters) and if it succeeds, it’ll write a new xorg file. If not, post errors and such here so we’ll know where to go to from here

Oldcpu - yes, I have the exact same card in another machine and had the 180 drivers already, to be sure I downloaded the newer 185 drivers from the NVidia website freshly.

microchip8 - sax2 errors even when run with no parameters:


        (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
        (EE) NVIDIA:     system's kernel log for additional error messages.
        (II) UnloadModule: "nvidia"
        (II) Unloading /usr/lib/xorg/modules//drivers/nvidia_drv.so
        (EE) Failed to load module "nvidia" (module-specific error, 0)

I changed to DEFAULT kernel and re-compiled (sh NVxxx -q) the drivers yet still get the same message.

If i change to VESA drivers (sax2 -r -m 1=vesa) then I get a display and X starts OK but it’s bad, jerky and so on - although I noticed in “my computer” that it said the graphics were NV6200)

/var/log/messages says:


Jul 17 08:52:27 bgrmedia04 kernel: nvidia: module license 'NVIDIA' taints kernel                                                             .
Jul 17 08:52:27 bgrmedia04 kernel: klogd 1.4.1, ---------- state change --------                                                             --
Jul 17 08:52:27 bgrmedia04 kernel: NVRM: The NVIDIA probe routine was not called                                                              for 1 device(s).
Jul 17 08:52:27 bgrmedia04 kernel: NVRM: This can occur when a driver such as ri                                                             vafb, nvidiafb or
Jul 17 08:52:27 bgrmedia04 kernel: NVRM: rivatv was loaded and obtained ownershi                                                             p of the NVIDIA
Jul 17 08:52:27 bgrmedia04 kernel: NVRM: device(s).
Jul 17 08:52:27 bgrmedia04 kernel: NVRM: Try unloading the rivafb, nvidiafb or r                                                             ivatv kernel module
Jul 17 08:52:27 bgrmedia04 kernel: NVRM: (and/or reconfigure your kernel without                                                              rivafb/nvidiafb
Jul 17 08:52:27 bgrmedia04 kernel: NVRM: support), then try loading the NVIDIA k                                                             ernel module again.
Jul 17 08:52:27 bgrmedia04 kernel: NVRM: No NVIDIA graphics adapter probed!

here is the xorg.conf as it stands now:


# /.../
# SaX generated X11 config file
# Created on: 2009-07-16T22:07:29+0100.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [SaX2] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
  FontPath     "/usr/share/fonts/misc:unscaled"
  FontPath     "/usr/share/fonts/local"
  FontPath     "/usr/share/fonts/75dpi:unscaled"
  FontPath     "/usr/share/fonts/100dpi:unscaled"
  FontPath     "/usr/share/fonts/Type1"
  FontPath     "/usr/share/fonts/URW"
  FontPath     "/usr/share/fonts/Speedo"
  FontPath     "/usr/share/fonts/PEX"
  FontPath     "/usr/share/fonts/cyrillic"
  FontPath     "/usr/share/fonts/latin2/misc:unscaled"
  FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
  FontPath     "/usr/share/fonts/latin2/Type1"
  FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
  FontPath     "/usr/share/fonts/baekmuk:unscaled"
  FontPath     "/usr/share/fonts/japanese:unscaled"
  FontPath     "/usr/share/fonts/kwintv"
  FontPath     "/usr/share/fonts/truetype"
  FontPath     "/usr/share/fonts/uni:unscaled"
  FontPath     "/usr/share/fonts/CID"
  FontPath     "/usr/share/fonts/ucs/misc:unscaled"
  FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
  FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/misc:unscaled"
  FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
  FontPath     "/usr/share/fonts/hellas/Type1"
  FontPath     "/usr/share/fonts/misc/sgi:unscaled"
  FontPath     "/usr/share/fonts/xtest"
  FontPath     "/opt/kde3/share/fonts"
  InputDevices "/dev/gpmdata"
  InputDevices "/dev/input/mice"
EndSection

Section "Module"
  Load         "dbe"
  Load         "type1"
  Load         "freetype"
  Load         "extmod"
  Load         "glx"
EndSection

Section "ServerFlags"
  Option       "AllowMouseOpenFail" "on"
  Option       "ZapWarning" "on"
EndSection

Section "InputDevice"
  Driver       "kbd"
  Identifier   "Keyboard[0]"
  Option       "Protocol" "Standard"
  Option       "XkbLayout" "gb"
  Option       "XkbModel" "microsoftpro"
  Option       "XkbRules" "xfree86"
EndSection

Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "9"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "ImExPS/2 Logitech Explorer Mouse"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
  DisplaySize  340 270
  HorizSync    30-50
  Identifier   "Monitor[0]"
  ModelName    "SONY TV"
  Option       "DPMS"
  Option       "PreferredMode" "1280x768"
  VendorName   "SNY"
  VertRefresh  43-62
  UseModes     "Modes[0]"
EndSection


Section "Modes"
  Identifier   "Modes[0]"
  Modeline 	"1280x768" 78.80 1280 1344 1480 1680 768 769 772 795
  Modeline 	"1280x768" 65.75 1280 1328 1360 1440 768 771 778 790 +HSync -Vsync
  Modeline 	"1024x768" 66.33 1024 1080 1184 1344 768 769 772 796
  Modeline 	"1024x768" 57.00 1024 1072 1104 1184 768 771 775 791 +HSync -Vsync
  Modeline 	"800x600" 39.49 800 832 912 1024 600 601 604 622
  Modeline 	"800x600" 36.00 800 848 880 960 600 603 607 618 +HSync -Vsync
EndSection


Section "Device"
  BoardName    "GeForce 6200"
  BusID        "10:9:0"
  Driver       "vesa"
  Identifier   "Device[0]"
  VendorName   "NVIDIA"
EndSection


Section "Screen"
  DefaultDepth 16
  SubSection "Display"
    Depth      15
    Modes      "1280x768" "1024x768" "800x600" 
  EndSubSection
  SubSection "Display"
    Depth      16
    Modes      "1280x768" "1024x768" "800x600" 
  EndSubSection
  SubSection "Display"
    Depth      24
    Modes      "1280x768" "1024x768" "800x600" 
  EndSubSection
  SubSection "Display"
    Depth      8
    Modes      "1280x768" "1024x768" "800x600" 
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection


Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Keyboard[0]" "CoreKeyboard"
  InputDevice  "Mouse[1]" "CorePointer"
  Screen       "Screen[0]"
EndSection


Section "DRI"
    Group      "video"
    Mode       0660
EndSection


I have even tried MV’ing this file (eg xorg.old) and letting sax re-create it but it still fails with the same errors :frowning:

I really can’t understand why this is not working, I have had OS11.0 working flawlessly on this machine for AGES (I wiped it to install XP for games and then re-added Suse as Dual-boot).

I don’t know much about using the proprietary graphic driver, as I have always (until very recently) used the openGL driver.

You noted that the VESA driver is too slow. How does the openGL driver work ? ie …
sax2 -r -m 1=nv

Is there any chance that your motherboard graphics are switched ON in your BIOS, and hence for some inexplicable reason when compiling the graphic driver with "sh Nxxxxx -q " the script is building the driver against the wrong graphic device (this is wild speculation) ?

… anyway, my knoweldge is next to zero here, so its likely best I bow out of this thread.

Good luck.

Hi Oldcpu; I appreciate your input very much!
Although I am now at work so only have SSH access (which isn’t really any good for working with Sax!) I did run

sax2 -r -m 1=nv

and I don’t appear to have received any errors this time.
Now, like I said, I can’t confirm if this has solved the problem or not until lunchtime at the earliest when I can nip home to check, but it looks promising!

Oh and no, the on-board card is on but I did “sax2 -p” to show which number is assigned to the Nvidia card

0=intel
1=nvidia

it is also a procedure i am used to, i have 2 identical machines the only difference between them is one’s connected to the 32" TV and the other a 19" monitor.

I shall try to nip home at lunchtime and see if this works (i work only a short way away from home so not a big deal, and besides, i forgot to put the cat out this morning!)

badger

Wow ! Doing this by ssh for graphics !! I maintain my mother’s PC remotely (she is in a different continent) via ssh, but I never use the proprietary graphic driver on her PC. Instead I stick with the openGL driver, as IMHO it is less susceptible to breakage from kernel updates and X11 updates. I confess I’m very reluctant to do anything remotely with graphics on her PC, as the flight from Europe to North America can’t be done over lunch time. rotfl!

OK, but note that “nv” is a different graphic driver from “nvidia”. “nv” is an open source graphic driver, and it does not have the same performance as the “nvidia” proprietary driver, although it should have superior performance to the “vesa” graphic driver.

I understand, but IMHO that is applicable to sax2 and I do not think for certain that it is relevant to the nvidia installation script (where the script is used for building an update to the proprietary graphic driver).

I do not know how the nvidia script functions but it may build it self specific to one’s hardware ? …

Does your motherboard also have nvidia graphics ? If so, is it possible the nvidia script, built itself against the wrong graphic hardware ? … Again, note this is wild speculation on my part, as in truth I know nothing about this, and hence my thoughts should be considered only speculation.

Good luck !

I am just confused why the install of the drivers worked fine on this machine once already, yet when I re-install it refuses to work!

/sigh/ computers eh, gotta love em (after all, they’re too expensive to just punt out of the nearest window).

How would I go about ripping out all the NVidia stuff and starting over? I could wipe the linux partitions and reinstall from the OS up but GRUB will be a mess. I could blat the disk but will loose the windows installation which I’ve got looking and working as I want (so not really an option!).

Remove everything installed by the NV driver with nvidia-installer --uninstall
After this recompile the driver again

I mentioned this in another thread - I also have a video card with an nVidia 6200 chip. It’s AGP and made by eVGA. For some reason, the driver that’s supposed to work with it doesn’t. I have to use the legacy driver, which works just fine.

Might be worth a try.