Fatal BTRFS error leading to "B/W screen of death"

This now happened the second time within 24 hrs. While playing Youtube music videos in Firefox, suddenly the system halts and prints out a bunch of messages:

ata5.00: ACPI cmd f5/00:00:00:00:00:00(SECURITY FREEZE LOCK) filtered out
ata5.00: ACPI cmd b1/c1:00:00:00:00:00(DEVICE CONFIGURATION OVERLAY) filtered out
ata5.00: supports DRM functions and may not be fully accessible
ata5.00: ATA-10: CT250MX500SSD1, M2CR045, mac UDMA/133
...
sd 4:0:0:0: [sdb] Stopping disk
scsi 4:0:0:0: Direct-Access    ATA     CT250MX500SSD1   045  PQ: 0 ANSI: 5
...
BTRFS warning: duplicate device  /dev/sdc3 devid 1 generation 7620 scanned by (udev worker) (4883)
BTRFS error (device sdb3: state EA): bdev /dev/sdb3 errs: wr 75, rd 0, flush 0, corrupt 0, gen 0

I tried to google the BTRFS error but have not found anything related. What do you suggest how to further analyze or handle this?

(This is a physical box that I built purely as a music player, not a VM).

Just guessing here, but do you possibly have two harddisks in the box, and did you maybe copy one of the disks (or partitions) to the other? At least the kernel sees /dev/sdb and /dev/sdc, and /dev/sdb3 and /dev/sdc3 seem to contain the same btrfs.
So, if your system runs on /dev/sdb, and sdb is stopped, it cannot continue to operate, even though sdc is identical.

Hi, your assumption is right, there are two disks. However, one is a SSD, containing only OS partitions, and the over is 3TB data disk with a single NTFS partition. There is only a single BTRFS partition on the two disks which is the one that holds the root fs for Tumbleweed.

As said, this is a multiboot system. After the error occured and I posted here, I tried to start up Windows. Got a read error and full stop there, too.

I am now believing this is a faulty SSD and have already announced it to the seller for RMA.