faster boot now

Because of mkinitrd error “missing /etc/scsi_id.conf”
I did as root:

echo 'vendor="ATA",options=-p 0x80' >>/etc/scsi_id.conf
cd /boot && mv initrd-2.* initrd_sic 

Now openSUSE factory seems to boot faster. Or due to recently upgraded packages, I don’t know…

It does boot a lot faster, even without updates.

Knurpht wrote:

> It does boot a lot faster, even without updates.

Did you do the same thing as the OP? If so then maybe it should be
reported that way it will boot even faster out of the box :wink:

“We must plan for freedom, and not only for security, if for no other
reason than only freedom can make security more secure.” Karl Popper

Had not done that, although I’d seen the error. Since I boot from SSD it’s already fast as lightning.

Issued the commands, they are not correct

echo ‘vendor=“ATA”,options=-p 0x80’ >>/etc/scsi_id.conf
cd /boot && mv initrd-2.* initrd_sic

should be:
echo ‘vendor=“ATA”,options=-p 0x80’ >>/etc/scsi_id.config
cd /boot && mv initrd-2.

Will now reboot and report back.

Boots OK, not faster than before, still very fast:
from GRUB to full desktop with autologin: 37 secs
from GRUB out of suspend : 23 secs.
The error disappeared, when invoking mkinitrd, so I’ll stick to this.


Since a few days I get as first message when booting:
“Failed to get NUMA …”

I know “NUMA” to be special processor features my old intel centrino doesn’t has.

Is there any config I do miss that fastens my boot process?
Is there a mkinitrd config to tell not to search for NUMA?

For all the better:
Are such config decissions been made at install time of openSUSE-11.2?
(I came to factory through a dist-upgrade from 11.1 via “zypper dup”)