fastcgi on opensuse 13.1

I need some help for enabling perl fast cgi on apache. I installed mod_perl and fast cgi but I’m not able to run a fast cgi script.
I added a virtual host and it’s configuration is here:

VirtualHost template

Note: to use the template, rename it to /etc/apache2/vhost.d/yourvhost.conf.

Files must have the .conf suffix to be loaded.

See /usr/share/doc/packages/apache2/README.QUICKSTART for further hints

about virtual hosts.

NameVirtualHost statements can be added to /etc/apache2/listen.conf.

Almost any Apache directive may go into a VirtualHost container.

The first VirtualHost section is used for requests without a known

server name.

<VirtualHost *:80>
ServerAdmin emrullah@localhost
ServerName projeler

# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
DocumentRoot /home/emrullah/Projects/web/htdocs

# if not specified, the global error log is used
ErrorLog /var/log/apache2/projeler-error_log
CustomLog /var/log/apache2/projeler-access_log combined

# don't loose time with IP address lookups
HostnameLookups Off

# needed for named virtual hosts
UseCanonicalName Off

# configures the footer on server-generated documents
ServerSignature On

# Optionally, include *.conf files from /etc/apache2/conf.d/
# For example, to allow execution of PHP scripts:
# Include /etc/apache2/conf.d/php5.conf
# or, to include all configuration snippets added by packages:
# Include /etc/apache2/conf.d/*.conf

# ScriptAlias: This controls which directories contain server scripts.
# ScriptAliases are essentially the same as Aliases, except that
# documents in the realname directory are treated as applications and
# run by the server when requested rather than as documents sent to the client.
# The same rules about trailing "/" apply to ScriptAlias directives as to
# Alias.
ScriptAlias /cgi-bin/ "/home/emrullah/Projects/web/cgi-bin/"

# "/srv/www/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have one, and where ScriptAlias points to.
&lt;Directory "/home/emrullah/Projects/cgi-bin"&gt;
AllowOverride None
Options +ExecCGI -Includes
Order allow,deny
Allow from all

# UserDir: The name of the directory that is appended onto a user's home
# directory if a ~user request is received.
# To disable it, simply remove userdir from the list of modules in APACHE_MODULES
# in /etc/sysconfig/apache2.
&lt;IfModule mod_userdir.c&gt;
# Note that the name of the user directory ("public_html") cannot simply be
# changed here, since it is a compile time setting. The apache package
# would have to be rebuilt. You could work around by deleting
# /usr/sbin/suexec, but then all scripts from the directories would be
# executed with the UID of the webserver.
UserDir public_html
# The actual configuration of the directory is in
# /etc/apache2/mod_userdir.conf.
Include /etc/apache2/mod_userdir.conf
# You can, however, change the ~ if you find it awkward, by mapping e.g.
# --&gt; /home/karl-heinz/public_html/
#AliasMatch ^/users/([a-zA-Z0-9-_.]*)/?(.*) /home/$1/public_html/$2

# This should be changed to whatever you set DocumentRoot to.
&lt;Directory "/home/emrullah/Projects/web/htdocs"&gt;

# Possible values for the Options directive are "None", "All",
# or any combination of:
#   Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
# Note that "MultiViews" must be named *explicitly* --- "Options All"
# doesn't give it to you.
# The Options directive is both complicated and important.  Please see
# [core - Apache HTTP Server](
# for more information.
Options Indexes FollowSymLinks

# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
#   Options FileInfo AuthConfig Limit
AllowOverride None

# Controls who can get stuff from this server.
Order allow,deny
Allow from all


Fast CGI ayarları

ScriptAlias /fcgi-bin/ "/home/emrullah/Projects/web/fcgi-bin/"

&lt;Directory "/home/emrullah/Projects/web/fcgi-bin"&gt;               
SetHandler fastcgi-script

AddHandler fastcgi-script .fcgi
Options +ExecCGI
Order allow,deny
Allow from all


In /usr/lib64/apache2-prefork folder I couldn’t see a module related with fast cgi. But when I try to run the script I get this error message.

client denied by server configuration

In loadmodule.conf I don’t see mod fast cgi. And at the top of the file it says “do not edit”. Is there any one who can help me please?

OK. I solved it. It’s my bad.

first I run “a2enmod fcgid”. Then I configured host conf and corrected two lines:

SetHandler fcgid-script
AddHandler fcgid-script fcgi fpl

and it works. it really works :smiley: