Fast, non-stop beeping *after* GRUB text on boot screen

It started happening today in box for a media center I’m building from parts I had around:

CPU i3-3240 non-overclocked
M/B Asus P8H61-M LX3 R2.0 (LGA 1155), BIOS version 1107 x64 (02/25/2014)
8GB RAM DDR3-1333 Kingston non-overclocked
PSU Wise model WS-600W-1x12, outdated and a bit on the cheap side, but has worked nicely in my old rig.
One WD Blue 320GB desktop HDD (sda) bought in 2010 (and on storage for a couple of years) and one Samsung (HP branded) 320 GB notebook HDD (sdb) bought when Vista was MS’ latest and greatest.

W7 and openSUSE installed on sda, sdb is slower, for media only.

Things had been going well, kodi database rebuilt, steam games restored both on oS and W7 sda partitions.

After a reboot today POST executed normally, then the text GRUB appears in the text boot screen and, before the graphic boot menu appears, the system seems to lock with very fast beeps non-stop.

I think the relevant info is:

  1. I can get into BIOS, change settings, etc., so I understand that the beeping is not POST-related.
  2. I can run memtest from the oS 64-bit DVD - I just finished one pass (32 min) without errors. Note: if I boot the DVD as UEFI I don’t get the option to run the installed oS system, so it seems I installed it as legacy - the same as W7.
  3. I can boot the parted magic distro (PMD), in the standard RAM-only 64-bit option.
  4. Both HDs pass SMART quick tests with PMD.
  5. BIOS monitor section report good voltages, temperatures and fan speeds.
  6. This problem only started this afternoon. The system have been rebooted at least a dozen times into oS and W7 without issues.
  7. The only things that changed in oS before the failed reboot today where that I (a) installed scummvm form the community games repo and (b) accepted the recommended updates for wicked (0.6.18-15.1) and alsa-utils (1.0.28-5.3.1). I haven’t booted in W7 since yesterday, I think.

The only reference to a similar problem I found here is an old post by caprus: https://forums.opensuse.org/showthread.php/493553-Lenovo-P580-laptop-failed-to-boot-(Solved)
In BIOS, Network Stack Driver Support is disabled (whatever that means) and there’s no boot-from-network in the boot option priorities.

CSM (Compatibility Support Module) is enabled, “… to fully support non-UEFI driver add-on devices, or the Windows UEFI mode”.

In the Secure Boot menu, OS type is set to “Other OS”, but setting to “Windows UEFI Mode” makes no difference (and also would stop oS from loading, right?).

So, apart for reinstalling GRUB, I’m out of ideas. Any help would be enormously appreciated.

Thanks,

Also, tried without, with a ps2 and with a wireless usb keyboard. No difference. The ps2 keyboard works in BIOS and in the PMD text editor, no stuck characters.

On Thu, 07 May 2015 05:56:02 +0000, brunomcl wrote:

> Also, tried without, with a ps2 and with a wireless usb keyboard. No
> difference. The ps2 keyboard works in BIOS and in the PMD text editor,
> no stuck characters.

Does it happen with no keyboard connected?

It sounds a lot like a stuck key, maybe a faulty I/O circuit.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Hi Jim,

Thank you, but that’s not it, see post #2 above.

Reinstalling grub2 did the trick, but now I can’t boot W7. It might be because I messed around a bit with UEF/Secureboot settings in BIOS.

Given that I also had to reinstall Gub in my main desktop (see FLEXNET "rootkit" warning after grub2 reinstall - Install/Boot/Login - openSUSE Forums ), I think this problem was not aleatory, there’s something messing up grub in recent (today/yesterday)'s history.

Also I just checked that I hadn’t done the updates in item 7 on the main desktop. I have blacklisted them for now, but given that they weren’t installed on the desktop I don’t know what the cause may be.

But I think more people will have this issue. Once is coincidence, twice is a pattern - or I’m really running low on luck…

And it’s already 03:48 hs here, won’t work worth sh*t today.

My best,

Bruno

W7 does not support Secure boot. leave it off

If one OS is installed in legacy mode and one in EFI mode you can not chain. them. You have to use the EFI BIOS boot menu to select

This thing is giving me a headache. W7 repair tool - that fails - says:

Root cause found:
-----------------------------
The partition table does not have a valid System Partition.

Report action: Partition table repair
Result: Completed successfully. Error code = 0x0
Time taken: 2574 ms

But no change. I can boot in oS but if I choose W7 it starts the splash screen and then reboot.

# fdisk -l

Disco /dev/sda: 298,1 GiB, 320072933376 bytes, 625142448 setores
Unidades: setor de 1 * 512 = 512 bytes
Tamanho de setor (lógico/físico): 512 bytes / 512 bytes
Tamanho E/S (mínimo/ótimo): 512 bytes / 512 bytes
Tipo de rótulo do disco: dos
Identificador do disco: 0x000a9419

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1  *         2048    206847    204800   100M  7 HPFS/NTFS/exFAT
/dev/sda2          206848 314574847 314368000 149,9G  7 HPFS/NTFS/exFAT
/dev/sda3  *    314574848 625141759 310566912 148,1G  f W95 Ext'd (LBA)
/dev/sda5       314576896 331356159  16779264     8G 82 Linux swap / Solaris
/dev/sda6       331358208 373303295  41945088    20G 83 Linux
/dev/sda7       373305344 625121279 251815936 120,1G 83 Linux

Disco /dev/sdb: 298,1 GiB, 320072933376 bytes, 625142448 setores
Unidades: setor de 1 * 512 = 512 bytes
Tamanho de setor (lógico/físico): 512 bytes / 512 bytes
Tamanho E/S (mínimo/ótimo): 512 bytes / 512 bytes
Tipo de rótulo do disco: dos
Identificador do disco: 0xffaede82

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sdb1            2048 209711103 209709056   100G  7 HPFS/NTFS/exFAT
/dev/sdb2       209713152 625141759 415428608 198,1G 83 Linux

When checking the disks with gparted I noticed there where some partitions flagged as GPT IINM. I have to look further into this.

But the thing is: It was dualbooting OK, and AFAIK I didn’t change anything except installing steam, scummvm and oS updates of yesterday.

Ah, the joys of technology…

Another thing to fix are probably the two bootable flags in your partition table. You should have only one. When i had grub-legacy installed in an extended partition and a bootable flag on that partition , some windows repair tools stumbled over that and I had to activate the windows boot partition to run them sucessfully. And after that I had reactivate the extended partition to reenable grub.

I have an opinion here, not a solution.

You assembled a PC from hardware that was around. The different pieces of hardware may not necessarily all be compatible to each other.

Now, what at all can cause the beep, before you get the graphic boot menu?

There are only very, very few candidates.

The first one would be GRUB. But does GRUB give beeps?

The second candidate is your BIOS. That can give beeps as error codes.

Much luck!
Mike

Maybe as well the plug of the HDD hasn’t a proper contact anymore?

Beep before the grub menu is BIOS error code (Also known as post code) consult your BIOS docs for the meaning. They are generally in a pattern and it indicates the BIOS found a hardware or some other problem. Do not install an OS on faulty hardware :wink:

My first instinct, because of the beeping, was a POST/Keyboard problem. From searching around, Continuous/very fast beeps at POST indicate RAM or power issues. However my beeps are AFTER grub (at least the fist stage) loads, hence the GRUB letters in the screen (see items 1-4 in post #1). So I doubt it’s a BIOS/POST issue

Also note that the system works normally when accessing the BIOS and booting from DVD, and reinstalling grub fixed the beeping and allowed me to boot into the HDD-installed openSUSE 13.2, but not in W7 (post # 4 above).

What I think is that something borked grub in both desktops here, with a day of interval between them, and it’s improbable (but not impossible) that it was a hardware problem.

Apparently it does, and it’s nothing new too: https://www.redhat.com/archives/rhl-list/2009-June/msg00674.html

Seaching for grub beeps have a number of results, many related to keyboard presses (nota my case as I tried different keyboards and even no keyboard).

Yes, I don’t know how that happened - or better, it was probably the windows repair tool I mentioned in post #6.
In the other desktop with pretty much the same setup only the extended (sda3) partition is marked as bootable. I understand I’ll have to remove that flag, possibly with the parted magic distro or something, and restore the W7 loader, or whatever it’s called.

This is similar to your observations. But the reasons for that kind of behaviour aren’t explained there either at all!!

Again:

You say that the beeps aren’t caused by your keyboard.

Fine. But what is a possible cause?
Thinking logical, it can neither be windoze nor openSUSE.

If the system won’t boot because of an error in the data on the HDD, then you should observe a different behaviour!

So, there isn’t much left as a possible cause of your problems, and contact problems at the plugs of your hardware could be a reason.

Or perhaps your power supply isn’t sufficient when booting from the HDD?

I don’t follow. What would that be?

Sorry, I forgot to mention in the first post. One of the tests was booting with the minimum hardware (m/b, cpu+cooler, RAM and only the boot HDD). I also switched sata cables, but no change.
I don’t think the 500W PSU is faulty - there’s no lock-up nor anything like that under heavy use, and BIOS reports voltages very near nominal.

Is there something hardware-related that borks the boot sector only? Does fsck indicate boot sector problems or only errors in formatted partitions?

Thanks,

It has to be grub. Neither oS or W7 have even started to load at this stage, and the hardware has already passed BIOS POST. AFAIK Grub is the only thing happening between them.

I don’t think it’s a bug or anything like that, I think it may be a grub warning at a very basic level (first stage, probably). A search for grub beep codes, however, yields nothing…

So…?

Did you try fixing the boot flags?

In that referenced redhat thread, fixing the boot flags fixed the problem.:slight_smile:

Yes, removed it with parted magic and rebooted, but no change. openSUSE loads OK, but W7 reboots about one second after it’s splash screen animation start.

I suppose I’ll have to reinstall windows??? :cry:

After flag removal:

# fdisk -l

Disco /dev/sda: 298,1 GiB, 320072933376 bytes, 625142448 setores
Unidades: setor de 1 * 512 = 512 bytes
Tamanho de setor (lógico/físico): 512 bytes / 512 bytes
Tamanho E/S (mínimo/ótimo): 512 bytes / 512 bytes
Tipo de rótulo do disco: dos
Identificador do disco: 0x000a9419

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1            2048    206847    204800   100M  7 HPFS/NTFS/exFAT
/dev/sda2          206848 314574847 314368000 149,9G  7 HPFS/NTFS/exFAT
/dev/sda3  *    314574848 625141759 310566912 148,1G  f W95 Ext'd (LBA)
/dev/sda5       314576896 331356159  16779264     8G 82 Linux swap / Solaris
/dev/sda6       331358208 373303295  41945088    20G 83 Linux
/dev/sda7       373305344 625121279 251815936 120,1G 83 Linux

Disco /dev/sdb: 298,1 GiB, 320072933376 bytes, 625142448 setores
Unidades: setor de 1 * 512 = 512 bytes
Tamanho de setor (lógico/físico): 512 bytes / 512 bytes
Tamanho E/S (mínimo/ótimo): 512 bytes / 512 bytes
Tipo de rótulo do disco: dos
Identificador do disco: 0xffaede82

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sdb1            2048 209711103 209709056   100G  7 HPFS/NTFS/exFAT
/dev/sdb2       209713152 625141759 415428608 198,1G 83 Linux

sda1 contains:

/media/sda1# ls -aR
.:
.                          ..                         BOOTSECT.BAK               Boot                       MAUVI                      System Volume Information  bootmgr

./Boot:
.                BCD.Backup.0001  BCD.LOG2         cs-CZ            el-GR            fi-FI            it-IT            memtest.exe      pl-PL            ru-RU            zh-CN
..               BCD.LOG          BOOTSTAT.DAT     da-DK            en-US            fr-FR            ja-JP            nb-NO            pt-BR            sv-SE            zh-HK
BCD              BCD.LOG1         Fonts            de-DE            es-ES            hu-HU            ko-KR            nl-NL            pt-PT            tr-TR            zh-TW

./Boot/Fonts:
.              ..             chs_boot.ttf   cht_boot.ttf   jpn_boot.ttf   kor_boot.ttf   wgl4_boot.ttf

./Boot/cs-CZ:
.                ..               bootmgr.exe.mui

./Boot/da-DK:
.                ..               bootmgr.exe.mui

./Boot/de-DE:
.                ..               bootmgr.exe.mui

./Boot/el-GR:
.                ..               bootmgr.exe.mui

./Boot/en-US:
.                ..               bootmgr.exe.mui  memtest.exe.mui


....... (+ a bunch of localized i18n directories here, all with the same content, name-wise)

./Boot/pt-BR:
.                ..               bootmgr.exe.mui

.......

./System Volume Information:
.             ..            tracking.log
root@PartedMagic:/media/sda1#

Logs are empty or have a few bytes of binary code. Who cares about text logs, M$?

fsck on /dev/sda1 reports no bad sectors.