Fast machine suddenly has choppy video playback

Hello, I am new to OpenSUSE (and to linux) as of about six months ago, but not to computers. I knew about UNIX in general (basics that is) and its shells (sh ash bash crash) but not much, and nothing about gnome/kde front ends. I’ve been educating myself, but bear with me if I overlook something obvious :slight_smile:

Okay, anyway: the machine : 2600MHz, Phenom II x3 (4th core can be enabled, I often run it this way, it’s stable and does not affect problem)
4gigs ram, onboard ATI (radeonHD I believe) graphics
running OpenSUSE 64-bit with KDE on top

the problem : beginning about 4 days ago, resizing a window with a video playback results in rapidly increasing dropping of frames, esp during moments of rapid motion on the picture; during these times wide horizontal bands become apparent. At fullscreen it is extreme. Audio track is generally unaffected.
During these times System Activity reports that process “Xorg” is using all the resources of one of the cores (ie, 25% or 33%) and that its size has increased dramatically to over 120k from ~75k. System responsiveness is quite sluggish as long as a large window showing motion picture is visible on screen. Before this machine could playback an .iso beautifully fullscreen at 1920x1080 while copying a DVD to another .iso, WHILE Firefox ran in the background, doing whatever, and it did not show hardly any lag; in short, it was a beast, and now it’s wimpy.

occurs during playback of files locally and via Internet (ie, DVD in drive, .iso on HDD, .flv from Hulu or youtube etc.); occurs under multiple apps (Kaffeine, Firefox/Adobe)

I have been simply okaying everything kupdater applet has wanted to install; these had been the only software changes before the problem.

Since then I used yast to “update” everything related to “codec”, “video”, “Xorg”, and a few others. No effect. I’ve tried 4-core operation, 3-core operation. Nada. I simply don’t know where to look because I am not familiar enough with what is going on behind the scenes.

Perhaps Adobe has screwed with some driver with their latest update?

Anyway, I cannot find a log of what kupdaterapplet has been doing all this time, and the system logs were not too helpful, but maybe I just don’t know what to look for.
Should I trust kupdaterapplet?

I also have no virus protection, assuming they’re all written for windows. Could it be virus? What kind of protection should I be using?

Please Help, Thanks in Advance!

Please post result of this from a terminal

zypper lr -d

You should follow this for success with multi-media
Multi-media and Restricted Format Installation Guide - openSUSE Forums

Did you try re-installing your graphics driver (or did you ever install one)

Should I trust kupdaterapplet?

I don’t use it!:open_mouth:

The radeonHD driver packaged with openSUSE-11.2 was a bit buggy. You could try to see if updating that driver helps. If nothing else, such an update will take that consideration out of the loop, so to speak.

FIRST: There is an update to the radeonhd driver in the official Novell/SuSE-GmbH “UPDATE” repository, but since that keeps the same version of Mesa, I am not convinced that update will succeed in solving your problem. But try that “official” update to the xorg-x11-driver-video-radeonhd and the xorg-x11-driver-video rpms first. After installation, restart your PC and test.

Assuming that does not work, then there are two ways that I recommend you proceed. Either :

  • SECOND
    . update the opensource radeon and radeonhd drivers again (this time using the cutting edge Xorg : X11 repository packaged version of those driver ) ; or
  • THIRD
    . install the proprietary ATI graphic driver

SECOND APPROACH: For the “SECOND” (update radeon/radeonhd) approach, please read post #11 in this thread: openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums
… you may need to also read post#1 in order to understand post#11. Apologies for just pointing to links but its a lot of typing for me to selectively retype all that.

Note the biggest problem users have in trying that SECOND approach is they fail to update the rpms !! After adding the repository, One needs to go to YaST > Software > Software Management, and go to “repositories” and select on the left the new Xorg : X11 repository and then under each rpm (Mesa, xorg-x11-driver-input, xorg-x11-driver-video, xorg-x11-driver-video-radeonhd) ensure the “version” tab is selected so you can see the versions, and then select the Xorg : x11 packaged version for each of those applications. Installing those may drag in a few more rpms as dependencies. Do NOT install one rpm more than you have to. Keep this lean and mean.

Ok, once that is done, reboot and test.

THIRD APPROACH: Now for the THIRD approach , which is to install the proprietary ATI driver, there are lots of wiki and guides. One example is this guide: ATI/The Hard Way - openSUSE - as you know there are many ways to do things in Linux, and I do not like the ATI drivers - openSUSE way recommended in that guide (to be used instead) but instead I prefer the guide ATI/The Hard Way - openSUSE … Sorry about that confusion. What can I say ? There is not always agreement in the Linux world.

I hope that the above helps, and sorry that I did not answer your specific questions, and sorry that I confused you about many ways to do this, but there are limits to my somewhat feeble knowledge on this subject.

oldcpu: good info, I will look into the driver. Is there a practical difference between option 2 and 3 besides the installation?
caf: here you go:
kevin@linux-erc9:~> zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

–±-------------±----------------------±--------±--------±---------±-------±----------------------------------------------------------------±-------
1 | Packman | Packman | Yes | Yes | 99 | rpm-md | ftp://packman.iu-bremen.de/%2Fsuse/11.2 |
2 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
3 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
4 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
5 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss |
6 | repo-update | openSUSE-11.2-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.2 |
kevin@linux-erc9:~>

Yes there is a MASSIVE difference. The second approach is an update to the open source free software (free as in free software foundation definition of free) radeon and readonhd drivers. The third approach is installing the free (free as in free beer, but not free to modify the code and code details hidden) priorietary ATI graphic driver.

Typically the proprietary ATI driver has the superior performance.

You really need to read this URL (post #1 and #11 openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums ) to understand what I am proposing. Else its really a waste of my trying to explain. Sorry, but I am NOT going to retype all of those posts.

oldcpu:

well okay, I tried the x.org drivers, but that caused the x system not to start;

no error messages, it just would go straight to the console login; ctrl-alt-f7 did nothing, and if I tried to start sax2, the system would hang, and I’d have to hard boot; so I used yast to revert to prev versions and now I’m back to the original drivers.

I read the posts in questions, and I think I understand more now; at least I know where the problem lies!

I’m going to try to use an older version of these drivers, cause they worked a couple weeks ago! then I’ll try the ati drivers; thanks for your help!

Next time you try those drivers, before you roll back, please provide the output of:

rpm -qa '*Mesa*'
rpm -qa '*driver*'

apologies but I am very suspicious that you failed to properly install the rpms. If I had to place money, I probably would bet against you on this. Please don’t be insulted, … but if I had 100 euros for every user who stated they installed the noted rpms but in fact did not, I could buy myself a nice sport car. For some reasons most users fail miserably in updating applications from 3rd party repositories in YaST.

Okay, so I have reverted to the OSS (instead of Update) versions of these drivers:

xorg-x11-driver-input
xorg-x11-driver-video
xorg-x11-driver-video-32-bit
xorg-x11-driver-video-radeonhd
xorg-x11-virtualbox-ose

The system is back to it’s old level of performance! :slight_smile:
Although I suspect xorg…radeonHD due to your information, I will go through one by one and confirm the source of the problem.

I noted that mesa does not have a different version than the OSS ver, and that it is not causing the problem

I may even still try the ATI driver…esp since you report that performance would be better.

Anyway, will report. Thanks again!

oldcpu:

With regards to the X.org drivers, I confirmed with yast (from the console when X wouldn’t start) that the versions in question were in fact installed…I followed all instructions in the referenced posts.

Also, this is not the first time I have used an unofficial repository, as I previously successfully installed rpms from Packman.

Please, I can not help you, as much as I want, if you do not provide the information that I ask. I asked for:

rpm -qa '*Mesa*'
rpm -qa '*driver*' 

and you gave me:


xorg-x11-driver-input
xorg-x11-driver-video
xorg-x11-driver-video-32-bit
xorg-x11-driver-video-radeonhd
xorg-x11-virtualbox-ose

Thats not what I asked. At most it is a minor subset.

I don’t know why you don’t provide the sort the exact details that I ask. I guess you figure my questions are silly. My apologies for appearing so silly to you.

I’m sorry, but as someone trying to help, this frustrates and annoys. Given I can not easily get answers, I don’t really think it is possible for me to help.

Hopefully someone else who can communicate better can succeed, where I fail to communicate.

I’ll let someone else pick up the ball as I move on to other threads where users find my questions are helpful instead of annoying. Sorry that my questions for detail annoy.

Good luck in your efforts.

MaskNMI, I really need to see this for myself. Sorry. I am from Missouri on this. I have seen users mess this up over a dozen times and EACH time they stated they KNEW they had it correct (and they did not).

oldcpu:

Please do not be offended; I had not even read your last message before I posted the quoted; I simply posted what I had just finished doing based on the direction you pointed me in.

I will switch back to the experimental drivers and post the output of what you specified; in the future I could be convinced to do so without being berated. Thank you, and I apologize if I appeared ungrateful.

Thank you.

I updated post#11 here to make it more clear:
openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums
Please look at the image I added.

To be doubly certain , after you think you have the update in place, please check the version numbers. As of today, the version numbers in the X11 : Xorg repository for 64-bit (32-bit will be a bit different) are as follows (this will change every few days as there is a new rebuild):

  • Mesa-7.7.99-12.1.x86_64.rpm
  • Mesa-32bit-7.7.99-12.1.x86_64.rpm
  • xorg-x11-driver-input-7.4-47.1.x86_64.rpm
  • xorg-x11-driver-video-7.5-14.1.x86_64.rpm
  • xorg-x11-driver-video-32bit-7.5-14.1.x86_64.rpm
  • xorg-x11-driver-video-radeonhd-1.3.0_20100216_79a0ab2-20.3.x86_64.rpm

It would assure me as well, that after you believe you have successfully applied the update, if you provide me the output of


rpm -qa '*Mesa*'
rpm -qa '*driver*'

when you think you have the update in place. Of course I will immediately check the versions.

My apologies for being blunt in my last post, but the frustration in me was building as I was being given answers that was speculated I wanted, as opposed to simply answering the question.

… and I’ve seen this very specific point Xorg : X11 messed up over a dozen times by different users, (and a few dozen times wrt something similar with alsa sound drivers) and as noted, each of the many dozen times the users are insistent that they did a proper update, when they did not. YaST refused to switch to a 3rd party repository for them, and they blindly assumed the update was either done or not needed, when nothing could have been further from the truth.

When you try the drivers, please try both radeonhd (and if that fails) then try the radeon. Commands being:

sax2 -r -m 0=radeonhd

and

sax2 -r -m 0=radeon

and like you did before, roll back if that makes things worse.

Good luck.

It may not have a bearing on this issue but, as a workaround, one thing to try (in oS 11.2 KDE4) is to disable 3D effects when playing video. I’ve seen tearing with ATI graphics (but not with NVidia).

You can easily toggle 3D on/off with ALT+SHIFT+F12.

Okay; I checked your replies BEFORE posting this time :slight_smile:

So I will have to do the switch again real quick to get that other info, but here’s what you asked for before:

cups-drivers-1.3.9-4.1.x86_64
xorg-x11-driver-video-7.5-14.1.x86_64
xorg-x11-driver-video-32bit-7.4-87.88.1.x86_64

Okay; I checked your replies BEFORE posting this time :slight_smile:

The X11 drivers had the same effect on the X system as before (console only)
So I will have to do the switch again real quick to try the radeon driver , but here’s what you asked for before:

cups-drivers-1.3.9-4.1.x86_64
xorg-x11-driver-video-7.5-14.1.x86_64
xorg-x11-driver-video-32bit-7.4-87.88.1.x86_64
xorg-x11-driver-video-unichrome-20091020-1.1.1.x86_64
xorg-x11-driver-virtualbox-ose-3.0.6-9.10.4.x86_64
xorg-x11-driver-video-radeonhd-1.3.0_20100216_79a0ab2-20.3.x86_64
xorg-x11-driver-input-7.4-47.1.x86_64

Those version numbers you posted are the ones yast reported as being installed, although I did not include xorg-x11-driver-video-32bit or mesa-32bit in the Xorg : x11 update, as it was not one of the four originally discussed as being in question (mesa, …driver-input, …driver-video, and …driver-video-radeonhd)

Should the update include these as well? Are they even supposed to be installed? also, are the unichrome and virtualbox drivers relavent to this?

One last thing, I looked at the picture in the post, and that is what I did, except that in my yast2 - softwaremanagement window, there is no “repositories” tab; I accomplished update by going to Configuration: Repositores, enabling xorg : x11 repository, then using the search tab to find the drivers in question and select them for update to the x11 versions.

Sorry about the fragment post.

Oldcpu:

Btw, I confirmed that it is xorg-x11-driver-radeonhd causing the problem;

specifically, updating from 1.3.0_20091026_8b89b9-1.1.1 to 1.3.0_20100216_79a0ab2-0.1.1 causes the original problem.

Okay, now I go to try the xorg : x11 radeon driver

Oldcpu:

So this time I included mesa-32bit and xorg…video-32bit in the update to the xorg :x11 versions; it had one for video-unichrome as well but it had such a slew of unmeetable dependencies, that I just stuck with the installed unichrome driver. Upon reboot, the same effect, no X window system

Confirming the versions, then using sax2, both 0=radeonhd and 0=radeon have the same effect; that is to say sax2 starts, does a little song and dance, brings up a screen which says it has automatically configured the graphics and asks you if you like the cfg, want to change it, or just want to give up on life. Only, you can’t answer because the system will not accept any input from the mouse or the keyboard. However, linux does respond to the power button to the motherboard and halts system without having to do a hard reset, so I guess it’s not really frozen.

But anyway, if you don’t want to spend anymore on this, I understand. I am currently sticking with the OSS version of xorg-x11-driver-video-radeonhd, with plans to experiment with ATI’s driver using your instructions. It seems that the xorg : x11 drivers do not get along with my machine, but using the oss radeonhd driver I can watch movies again, so I am happy.

Listen, I really appreciate your help with this; I had been a WinNT fan for years but was always interested in unix. I recently built this machine and tried all different OS on it. Windows xp, other linux distributions all had various problems immediately, but since trying opensuse I have quickly grown fond of it for its smooth installation (it automatically set up my LAN and put me online when Xp couldn’t even detect my NIC properly), ease of interaction, versatility, and capability. I think it combines the best traits of windows and unix and I love it! Since it is free and I am no master coder, what is the best way to make a contribution to its development?

those are for 64-bit openSUSE install. Presumably yours is a 32-bit openSUSE install ?

Likely this is a result of sax2 being depreciated and all maintenance work on it stopping (assuming you also updated Mesa - that was critical).

So sax2 is not able to do the configuration, and hence its possible those rpms are good, bug unfortunately we have no software wizard (such as sax2) to configure with those drivers in place.

Thats unfortunate, although given they have stopped maintenance on sax2 this was bound to happen sooner or later and unfortunately it is now happened with these latest X11 : Xorg updates.

Too bad. :frowning:

Reference a contribution what you are doing now is the best way. Test software. Write bug reposts when they don’t work. Help other users. :slight_smile: