Fast Ethernet, but slow wireless

Suse 11.1 installed on a desktop machine, Intel Pentium4 CPU 2.40GHz

My ethernet connection is providing over 4Mb/s download and 600kb/s upload. My wireless connection (rt2500 PCI card), though, is providing only 10% of this rate.

Same router is being used for ethernet and wireless connections - D-link DIR300.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Four megabits per second is really quite slow for ethernet… on a 100
megabit connection you should get 100 Mbit (twenty-five times faster).
If you meant four megabytes (4 MB) per second then that’s closer.
Either way if your wireless is 802.11b you only have 11 Mbit total
possibility, so about 1/10 of what you are getting, though if you are
only getting 400 kbps you’re not using your full wireless connection
either. Even though your switch can handle 100 Mbit doesn’t mean it can
do as much with wireless… chances are it cannot so you should usually
assume slower connections over wireless… always.

Good luck.

sylmobile wrote:
> Suse 11.1 installed on a desktop machine, Intel Pentium4 CPU 2.40GHz
>
> My ethernet connection is providing over 4Mb/s download and 600kb/s
> upload. My wireless connection (rt2500 PCI card), though, is providing
> only 10% of this rate.
>
> Same router is being used for ethernet and wireless connections -
> D-link DIR300.
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFJZVL/3s42bA80+9kRAm4WAJ9JU2gJsBbCjhV4cqToYVwox4Y3NACffAL7
C+iTAUhwfR8rTAgcpJZXses=
=SP74
-----END PGP SIGNATURE-----

Thanks AB

it’s an ADSL home connection. And yes that’s bits, not bytes… :’(

I do have a macbook that achieves 3Mb/s plus wirelessly.

I suppose 4Mb/s is the limit of your internet provider plan. Your wireless should support that and much more. If you can plug another computer in the network try transferring a large file and compare transfer rates (wired x wireless or wireless x router nominal transfer rate).

With a 2 Mb/s internet connection both wired and wireless in a D-Link DI-524, rated at 54 Mb/s, transfer at the same speed, about 215 KB/s (or 2 Mb/s). Local file transfers run at approx. 6 MB/s, which is the nominal top speed of the wireless.

Output from /sbin/lspci -v

02:01.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)
Subsystem: Giga-byte Technology Device e932
Flags: bus master, slow devsel, latency 32, IRQ 21
Memory at fc004000 (32-bit, non-prefetchable) [size=8]
Capabilities: [40] Power Management version 2
Kernel driver in use: rt2500pci
Kernel modules: rt2500, rt2500pci[/size]

running nm-tool gave the following output, which is confirming that the ethernet connection has a 100Mb/s capability listed, whereas the wireless has 1Mb/s capability only.

Anyone have advice on whether this is configurable into the driver or elsewhere?

[Start Dump] *****

  • Device: eth0 ----------------------------------------------------------------
    Type: Wired
    Driver: r8169
    State: connected
    Default: yes
    Capabilities:
    Supported: yes
    Carrier Detect: yes
    Speed: 100 Mb/s

  • Device: wlan0 ----------------------------------------------------------------
    Type: 802.11 WiFi
    Driver: rt2500pci
    State: connected
    Default: no
    Capabilities:
    Supported: yes
    Speed: 1 Mb/s

[End Dump] *****

I worked out what was going on: the bit rate for the interface is configurable after all.

The following command will provide the available bit rates for the wireless interface:

iwlist scanning

In my case I was informed that the interface wlan0 had Bit Rates of:
1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s; 11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s

Recalling that the following reported I had a 1 Mb/s wireless interface capability:

/usr/sbin/iwconfig

Setting it to something other than 1Mb/s increased the bit rate. And of course, the same utility ‘iwconfig’ sets parameters as well. In my case, the following exceeds what my ADSL provider supplies, and results in the wireless card matching the ethernet link to the ADSL router:

iwconfig wlan0 rate 6M

Phew! Got there in the end.

Seems the cause has probably to do with the Realtek driver. I hit the same issue when installing on a system with a same type wifi card using the ‘rt2500pci’ driver.

Setting the rate to auto (iwconfig wlan0 rate auto) stays at 1M. Setting it to 48M or ‘forcing’ it to 54M sets the speed correctly.

Seems we will have to apply the rate setting after each reboot until a fix is known…

Thanks for the solution!
Wj

I have similar problems. But it does not only stay at that speed - at some point in the night (machine stays on) the wlan seems to reset and it is back to 1Mbit… Restarting the network via YAST sets it back to the good speed as iwconfig then does not work (sets it but the speed is not applied)… this seems odd and is very frustrating

is there a way to update rtl8180 without having to wait for a new kernel???

TarQuin06 wrote:
> is there a way to update rtl8180 without having to wait for a new
> kernel???

Try compat-wireless.