[FAQ] Compiz Fusion

Q: I have to re-enable Desktop Effects at each login!
A: Try running ‘rm -rf ~/.config/compiz’ (This will also delete all of compiz settings!)

Q: I have a white screen! HELP!
A: DRI is broken, reinstall the fglrx driver.

Q: It doesn’t load!
A: Compiz Fusion only works on Intel, ATi, and Nvidia cards

Q: I have Nvidia, but it doesn’t work!
A: Install the Nvidia driver, and run ‘su -c “nvidia-xconfig --composite --add-argb-glx-visuals -d 24”’

Q: I have ATi, but it doesn’t work!
A: Install the ATi driver, and follow this guide to speed things up

Q: I have Intel, but it’s sloooooooooow!
A: EXA acceleration might be slowing it down, add this to the device section of your /etc/X11/xorg.conf ‘Option “MigrationHeuristic” “greedy”’

Q: Do I need the proprietary ATi driver?
A: Not on most older cards, and if you just want to run compiz, using the open-source drivers is recommended

Q: Why do I need to delete my compiz settings to get compiz autostarting?
A: If you use your old /home partition, there is a file that the system looks at to see if compiz should run, and autostarting is broken during an upgrade.

Q: How do I get to the advanced settings?
A: Press Ctrl+Alt+F2, and type ‘ccsm’

What exactly is that supposed to do? I have a T61 w/965GM chipset and it made no noticeable difference.

Forgot this, add ‘Option “AccelMethod” “EXA”’

Thanks for these! :cool: They really helped.

Tried adding

Option “AccelMethod” “EXA”
Option “MigrationHeuristic” “greedy”

to my xorg.conf and it made scrolling in Firefox 3 very choppy and slow. In addition, it made general desktop effects fairly choppy. I’m using AIGLX - do these options work better with XGL? Or has Intel updated their drivers to work better without EXA?

EXA is supposed to work better than the older method, XAA. In git, EXA for almost all drivers is significantly faster than XAA, though the changes haven’t been released yet.

The Option “MigrationHeuristic” “greedy” is a workaround for a bug in EXA, for now if EXA isn’t good for you just remove the Option “MigrationHeuristic” “greedy”, and change the RenderAccel line to XAA, or delete it all together

Still have to turn it on at each login.

You could put fusion-icon in a bash script and put that in ~/.kde4/Autostart/

That’s what I always did, anyway.

Looks like there were some xorg-x11-driver-video updates along with other x11/xorg updates pushed through the channel. Once I installed those, Compiz Fusion became very choppy - just like when I tried the EXA accelleration. So, I inserted an option in the Device section of my xorg.conf to use XAA and all is better now.

graphics card: Intel 965GM (x3100) on a T61