Fan Speed not being reported

I have an Asus X99-E WS motherboard. I’ve looked through forums and so forth and so far have not found a solution to seeing my fan speed. Also, you’ll see from below it’s only picking up the cpu fan as existing but there are 4 other fans although only the cpu fan is 4 wire.

Has anyone managed to make this work with the Asus X99 series motherboard?

sensor-detect shows this:

Now follows a summary of the probes I have just done.
Just press ENTER to continue: 

Driver `nct6775':
  * ISA bus, address 0x290
    Chip `Nuvoton NCT6791D Super IO Sensors' (confidence: 9)

Driver `coretemp':
  * Chip `Intel digital thermal sensor' (confidence: 9)

Sensors shows this:

radeon-pci-0700
Adapter: PCI adapter
temp1:        +61.5°C  (crit = +120.0°C, hyst = +90.0°C)

asus-isa-0000
Adapter: ISA adapter
cpu_fan:        0 RPM

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +58.0°C  (high = +87.0°C, crit = +105.0°C)
Core 0:         +52.0°C  (high = +87.0°C, crit = +105.0°C)
Core 1:         +50.0°C  (high = +87.0°C, crit = +105.0°C)
Core 2:         +51.0°C  (high = +87.0°C, crit = +105.0°C)
Core 3:         +47.0°C  (high = +87.0°C, crit = +105.0°C)
Core 4:         +49.0°C  (high = +87.0°C, crit = +105.0°C)
Core 5:         +51.0°C  (high = +87.0°C, crit = +105.0°C)
Core 6:         +51.0°C  (high = +87.0°C, crit = +105.0°C)
Core 7:         +49.0°C  (high = +87.0°C, crit = +105.0°C)

Hi
As root user try;


modprobe nct6775
sensors

or
modprobe force_id=0x290 nct6775
sensors

The first one had no effect, the second gave me this:

modprobe force_id=0x290 nct6775
modprobe: FATAL: Module force_id=0x290 not found.

I opened up yast software management and looked for nct6775 and it didn’t find anything, not sure if that is of any consequence.

Hi
It’s a kernel module… :wink:

Try;


modinfo nct6775
modprobe -r nct6775
modprobe nct6775 force_id=0x290

Still not working unfortunately, when I did that I got the following result:


# modinfo nct6775
filename:       /lib/modules/4.4.62-18.6-default/kernel/drivers/hwmon/nct6775.ko
license:        GPL
description:    Driver for NCT6775F and compatible chips
author:         Guenter Roeck <linux@roeck-us.net>
srcversion:     2A5126D6834A6F8AC1B292F
depends:        hwmon-vid
intree:         Y
vermagic:       4.4.62-18.6-default SMP mod_unload modversions 
signer:         openSUSE Secure Boot Signkey
sig_key:        03:32:FA:9C:BF:0D:88:BF:21:92:4B:0D:E8:2A:09:A5:4D:5D:EF:C8
sig_hashalgo:   sha256
parm:           force_id:Override the detected device ID (ushort)
parm:           fan_debounce:Enable debouncing for fan RPM signal (ushort)

# modprobe -r nct6775

# modprobe nct6775 force_id=0x290
modprobe: ERROR: could not insert 'nct6775': No such device

The closet I was able to get to a clue to the driver was this which suggests the chipset:
http://www.guru3d.com/articles-pages/asus-x99-deluxe-motherboard-review,5.html

I’m not sure if this will help but I did yast hardware info. dump which I couldn’t post here for being too long and I didn’t see a way to add an attachment but I did some grepping on it which might help:

cat hwinfo-out.txt |grep -A 2 -B 2 -in fan


 97-  ebf90  4f 55 54 00 00 08 09 19 00 01 1f 00 00 1d 41 41  "OUT...........AA"
 98-  ebfa0  46 50 00 00 08 09 1a 00 01 ff 00 00 ff 43 50 55  "FP...........CPU"
 99:  ebfb0  5f 46 41 4e 00 00 08 09 1b 00 01 ff 00 00 ff 43  "_FAN...........C"
100-  ebfc0  50 55 5f 4f 50 54 00 00 09 11 1c 00 01 b1 0d 04  "PU_OPT.........."
101-  ebfd0  04 01 00 0c 01 04 00 03 00 50 43 49 45 58 31 36  ".........PCIEX16"
--
375-       str1: "AAFP"
376-  type 0x08 [0x001a]: 08 09 1a 00 01 ff 00 00 ff
377:       str1: "CPU_FAN"
378-  type 0x08 [0x001b]: 08 09 1b 00 01 ff 00 00 ff
379-       str1: "CPU_OPT"
--
40604-  Port Connector: #26
40605-    Type: 0xff (Other)
40606:    Internal Designator: "CPU_FAN"
40607-    Internal Connector: 0xff (Other)
40608-  Port Connector: #27
--
41056-  Formfactor: "desktop"
41057-  Driver Info #0:
41058:    Driver Status: thermal,fan are not active
41059:    Driver Activation Cmd: "modprobe thermal; modprobe fan"
41060-  Config Status: cfg=no, avail=yes, need=no, active=unknown
41061-

cat hwinfo-out.txt |grep -A 2 -B 2 -in pch


21551-          radeon: /devices/pci0000:00/0000:00:03.0/0000:03:00.0/0000:04:08.0/0000:07:00.0
21552-          radeon: module = drm
21553:          shpchp: module = shpchp
21554-      parport_pc: module = parport_pc
21555-        xhci_hcd: /devices/pci0000:00/0000:00:14.0
--
24056-          radeon: /devices/pci0000:00/0000:00:03.0/0000:03:00.0/0000:04:08.0/0000:07:00.0
24057-          radeon: module = drm
24058:          shpchp: module = shpchp
24059-      parport_pc: module = parport_pc
24060-        xhci_hcd: /devices/pci0000:00/0000:00:14.0
--
25053-  
25054-  I: Bus=0000 Vendor=0000 Product=0000 Version=0000
25055:  N: Name="HDA Intel PCH Front Mic"
25056-  P: Phys=ALSA
25057-  S: Sysfs=/devices/pci0000:00/0000:00:1b.0/sound/card1/input11
--
25063-  
25064-  I: Bus=0000 Vendor=0000 Product=0000 Version=0000
25065:  N: Name="HDA Intel PCH Rear Mic"
25066-  P: Phys=ALSA
25067-  S: Sysfs=/devices/pci0000:00/0000:00:1b.0/sound/card1/input12
--
25073-  
25074-  I: Bus=0000 Vendor=0000 Product=0000 Version=0000
25075:  N: Name="HDA Intel PCH Line"
25076-  P: Phys=ALSA
25077-  S: Sysfs=/devices/pci0000:00/0000:00:1b.0/sound/card1/input13
--
25083-  
25084-  I: Bus=0000 Vendor=0000 Product=0000 Version=0000
25085:  N: Name="HDA Intel PCH Line Out Front"
25086-  P: Phys=ALSA
25087-  S: Sysfs=/devices/pci0000:00/0000:00:1b.0/sound/card1/input14
--
25093-  
25094-  I: Bus=0000 Vendor=0000 Product=0000 Version=0000
25095:  N: Name="HDA Intel PCH Line Out Surround"
25096-  P: Phys=ALSA
25097-  S: Sysfs=/devices/pci0000:00/0000:00:1b.0/sound/card1/input15
--
25103-  
25104-  I: Bus=0000 Vendor=0000 Product=0000 Version=0000
25105:  N: Name="HDA Intel PCH Line Out CLFE"
25106-  P: Phys=ALSA
25107-  S: Sysfs=/devices/pci0000:00/0000:00:1b.0/sound/card1/input16
--
25113-  
25114-  I: Bus=0000 Vendor=0000 Product=0000 Version=0000
25115:  N: Name="HDA Intel PCH Front Headphone"
25116-  P: Phys=ALSA
25117-  S: Sysfs=/devices/pci0000:00/0000:00:1b.0/sound/card1/input17
--
25208-  is_joystick = 0
25209-unknown non-USB input device
25210:bus = 0, name = HDA Intel PCH Front Mic
25211-  handlers = event11
25212-  mouse buttons = 0
--
25215-  is_joystick = 0
25216-unknown non-USB input device
25217:bus = 0, name = HDA Intel PCH Rear Mic
25218-  handlers = event12
25219-  mouse buttons = 0
--
25222-  is_joystick = 0
25223-unknown non-USB input device
25224:bus = 0, name = HDA Intel PCH Line
25225-  handlers = event13
25226-  mouse buttons = 0
--
25229-  is_joystick = 0
25230-unknown non-USB input device
25231:bus = 0, name = HDA Intel PCH Line Out Front
25232-  handlers = event14
25233-  mouse buttons = 0
--
25236-  is_joystick = 0
25237-unknown non-USB input device
25238:bus = 0, name = HDA Intel PCH Line Out Surround
25239-  handlers = event15
25240-  mouse buttons = 0
--
25243-  is_joystick = 0
25244-unknown non-USB input device
25245:bus = 0, name = HDA Intel PCH Line Out CLFE
25246-  handlers = event16
25247-  mouse buttons = 0
--
25250-  is_joystick = 0
25251-unknown non-USB input device
25252:bus = 0, name = HDA Intel PCH Front Headphone
25253-  handlers = event17
25254-  mouse buttons = 0
--
32007-  E: ID_PATH_TAG=pci-0000_00_1b_0
32008-  E: MODALIAS=input:b0000v0000p0000e0000-e0,5,kramlsfw4,
32009:  E: NAME="HDA Intel PCH Front Mic"
32010-  E: PHYS="ALSA"
32011-  E: PRODUCT=0/0/0/0
--
32037-  E: ID_PATH_TAG=pci-0000_00_1b_0
32038-  E: MODALIAS=input:b0000v0000p0000e0000-e0,5,kramlsfw4,
32039:  E: NAME="HDA Intel PCH Rear Mic"
32040-  E: PHYS="ALSA"
32041-  E: PRODUCT=0/0/0/0
--
32067-  E: ID_PATH_TAG=pci-0000_00_1b_0
32068-  E: MODALIAS=input:b0000v0000p0000e0000-e0,5,kramlsfwD,
32069:  E: NAME="HDA Intel PCH Line"
32070-  E: PHYS="ALSA"
32071-  E: PRODUCT=0/0/0/0
--
32097-  E: ID_PATH_TAG=pci-0000_00_1b_0
32098-  E: MODALIAS=input:b0000v0000p0000e0000-e0,5,kramlsfw6,
32099:  E: NAME="HDA Intel PCH Line Out Front"
32100-  E: PHYS="ALSA"
32101-  E: PRODUCT=0/0/0/0
--
32127-  E: ID_PATH_TAG=pci-0000_00_1b_0
32128-  E: MODALIAS=input:b0000v0000p0000e0000-e0,5,kramlsfw6,
32129:  E: NAME="HDA Intel PCH Line Out Surround"
32130-  E: PHYS="ALSA"
32131-  E: PRODUCT=0/0/0/0
--
32157-  E: ID_PATH_TAG=pci-0000_00_1b_0
32158-  E: MODALIAS=input:b0000v0000p0000e0000-e0,5,kramlsfw6,
32159:  E: NAME="HDA Intel PCH Line Out CLFE"
32160-  E: PHYS="ALSA"
32161-  E: PRODUCT=0/0/0/0
--
32187-  E: ID_PATH_TAG=pci-0000_00_1b_0
32188-  E: MODALIAS=input:b0000v0000p0000e0000-e0,5,kramlsfw2,
32189:  E: NAME="HDA Intel PCH Front Headphone"
32190-  E: PHYS="ALSA"
32191-  E: PRODUCT=0/0/0/0
--
40388-  soundcore 16384 1 snd, Live 0xffffffffa0221000
40389-  ac97_bus 16384 1 snd_ac97_codec, Live 0xffffffffa09c0000
40390:  shpchp 36864 0 - Live 0xffffffffa0d07000
40391-  fjes 32768 0 - Live 0xffffffffa1359000
40392-  wmi 16384 2 asus_wmi,mxm_wmi, Live 0xffffffffa00dc000
--
41144-  Module Alias: "pci:v00008086d00002F02sv00008086sd00000000bc06sc04i00"
41145-  Driver Info #0:
41146:    Driver Status: shpchp is active
41147:    Driver Activation Cmd: "modprobe shpchp"
41148-  Config Status: cfg=no, avail=yes, need=no, active=unknown
41149-
--
41164-  Module Alias: "pci:v00008086d00002F03sv00008086sd00000000bc06sc04i00"
41165-  Driver Info #0:
41166:    Driver Status: shpchp is active
41167:    Driver Activation Cmd: "modprobe shpchp"
41168-  Config Status: cfg=no, avail=yes, need=no, active=unknown
41169-
--
41185-  Module Alias: "pci:v00008086d00002F04sv00008086sd00000000bc06sc04i00"
41186-  Driver Info #0:
41187:    Driver Status: shpchp is active
41188:    Driver Activation Cmd: "modprobe shpchp"
41189-  Config Status: cfg=no, avail=yes, need=no, active=unknown
41190-
--
41205-  Module Alias: "pci:v00008086d00002F08sv00008086sd00000000bc06sc04i00"
41206-  Driver Info #0:
41207:    Driver Status: shpchp is active
41208:    Driver Activation Cmd: "modprobe shpchp"
41209-  Config Status: cfg=no, avail=yes, need=no, active=unknown
41210-
--
41442-  Module Alias: "pci:v00008086d00008D10sv00001043sd00008600bc06sc04i00"
41443-  Driver Info #0:
41444:    Driver Status: shpchp is active
41445:    Driver Activation Cmd: "modprobe shpchp"
41446-  Config Status: cfg=no, avail=yes, need=no, active=unknown
41447-
--
41462-  Module Alias: "pci:v00008086d00008D16sv00001043sd00008600bc06sc04i00"
41463-  Driver Info #0:
41464:    Driver Status: shpchp is active
41465:    Driver Activation Cmd: "modprobe shpchp"
41466-  Config Status: cfg=no, avail=yes, need=no, active=unknown
41467-
--
41482-  Module Alias: "pci:v00008086d00008D18sv00001043sd00008600bc06sc04i00"
41483-  Driver Info #0:
41484:    Driver Status: shpchp is active
41485:    Driver Activation Cmd: "modprobe shpchp"
41486-  Config Status: cfg=no, avail=yes, need=no, active=unknown
41487-
--
41599-  Module Alias: "pci:v000010B5d00008747sv000010B5sd00008747bc06sc04i00"
41600-  Driver Info #0:
41601:    Driver Status: shpchp is active
41602:    Driver Activation Cmd: "modprobe shpchp"
41603-  Config Status: cfg=no, avail=yes, need=no, active=unknown
41604-  Attached to: #29 (PCI bridge)
--
41621-  Module Alias: "pci:v000010B5d00008747sv000010B5sd00008747bc06sc04i00"
41622-  Driver Info #0:
41623:    Driver Status: shpchp is active
41624:    Driver Activation Cmd: "modprobe shpchp"
41625-  Config Status: cfg=no, avail=yes, need=no, active=unknown
41626-  Attached to: #48 (PCI bridge)
--
41643-  Module Alias: "pci:v000010B5d00008747sv000010B5sd00008747bc06sc04i00"
41644-  Driver Info #0:
41645:    Driver Status: shpchp is active
41646:    Driver Activation Cmd: "modprobe shpchp"
41647-  Config Status: cfg=no, avail=yes, need=no, active=unknown
41648-  Attached to: #48 (PCI bridge)
--
41663-  Module Alias: "pci:v000010B5d00008112sv00000000sd00000000bc06sc04i00"
41664-  Driver Info #0:
41665:    Driver Status: shpchp is active
41666:    Driver Activation Cmd: "modprobe shpchp"
41667-  Config Status: cfg=no, avail=yes, need=no, active=unknown
41668-  Attached to: #50 (PCI bridge)
--
41759-  Module Alias: "pci:v000010B5d00008747sv000010B5sd00008747bc06sc04i00"
41760-  Driver Info #0:
41761:    Driver Status: shpchp is active
41762:    Driver Activation Cmd: "modprobe shpchp"
41763-  Config Status: cfg=no, avail=yes, need=no, active=unknown
41764-  Attached to: #28 (PCI bridge)
--
41781-  Module Alias: "pci:v000010B5d00008747sv000010B5sd00008747bc06sc04i00"
41782-  Driver Info #0:
41783:    Driver Status: shpchp is active
41784:    Driver Activation Cmd: "modprobe shpchp"
41785-  Config Status: cfg=no, avail=yes, need=no, active=unknown
41786-  Attached to: #55 (PCI bridge)
--
41803-  Module Alias: "pci:v000010B5d00008747sv000010B5sd00008747bc06sc04i00"
41804-  Driver Info #0:
41805:    Driver Status: shpchp is active
41806:    Driver Activation Cmd: "modprobe shpchp"
41807-  Config Status: cfg=no, avail=yes, need=no, active=unknown
41808-  Attached to: #55 (PCI bridge)
--
41825-  Module Alias: "pci:v000010B5d00008747sv000010B5sd00008747bc06sc04i00"
41826-  Driver Info #0:
41827:    Driver Status: shpchp is active
41828:    Driver Activation Cmd: "modprobe shpchp"
41829-  Config Status: cfg=no, avail=yes, need=no, active=unknown
41830-  Attached to: #55 (PCI bridge)
--
42801-  Module Alias: "pci:v00001B21d00001184sv00001B21sd0000118Fbc06sc04i00"
42802-  Driver Info #0:
42803:    Driver Status: shpchp is active
42804:    Driver Activation Cmd: "modprobe shpchp"
42805-  Config Status: cfg=no, avail=yes, need=no, active=unknown
42806-  Attached to: #42 (PCI bridge)
--
42822-  Module Alias: "pci:v00001B21d00001184sv00001B21sd0000118Fbc06sc04i00"
42823-  Driver Info #0:
42824:    Driver Status: shpchp is active
42825:    Driver Activation Cmd: "modprobe shpchp"
42826-  Config Status: cfg=no, avail=yes, need=no, active=unknown
42827-  Attached to: #121 (PCI bridge)
--
42843-  Module Alias: "pci:v00001B21d00001184sv00001B21sd0000118Fbc06sc04i00"
42844-  Driver Info #0:
42845:    Driver Status: shpchp is active
42846:    Driver Activation Cmd: "modprobe shpchp"
42847-  Config Status: cfg=no, avail=yes, need=no, active=unknown
42848-  Attached to: #121 (PCI bridge)

Hi
Did you try as suggested in the output;


modprobe thermal; modprobe fan

Just did, no effect. Here’s the full block of info from the lines with the word “fan” on them:

41049-  Config Status: cfg=no, avail=yes, need=no, active=unknown
41050-
41051-02: None 00.0: 10107 System
41052-  [Created at sys.63]
41053-  Unique ID: rdCR.n_7QNeEnh23
41054-  Hardware Class: system
41055-  Model: "System"
41056-  Formfactor: "desktop"
41057-  Driver Info #0:
41058:    Driver Status: thermal,**fan** are not active
41059:    Driver Activation Cmd: "modprobe thermal; modprobe **fan**"
41060-  Config Status: cfg=no, avail=yes, need=no, active=unknown
41061-
41062-03: None 00.0: 10104 FPU

On Thu 15 Jun 2017 08:26:01 PM CDT, Reg gie wrote:

Just did, no effect. Here’s the full block of info from the lines with
the word “fan” on them:

Code:

41049- Config Status: cfg=no, avail=yes, need=no, active=unknown
41050-
41051-02: None 00.0: 10107 System
41052- [Created at sys.63]
41053- Unique ID: rdCR.n_7QNeEnh23
41054- Hardware Class: system
41055- Model: “System”
41056- Formfactor: “desktop”
41057- Driver Info #0:
41058: Driver Status: thermal,fan are not active
41059: Driver Activation Cmd: “modprobe thermal; modprobe fan
41060- Config Status: cfg=no, avail=yes, need=no, active=unknown
41061-
41062-03: None 00.0: 10104 FPU


Hi
From the following document I see a N/A for that board and openSUSE, the
later model has been tested with Leap 42.1;

There are no thermal settings in the BIOS?

Might be worth a bug report to see if one of the kernel folks has an
idea.


Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
openSUSE Leap 42.2|GNOME 3.20.2|4.4.62-18.6-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

That’s a great PDF you found. There certainly is plenty of thermal settings in the BIOS so I’m not sure why N/A would be marked there unless it’s just a way of showing that no-one has addressed it yet for openSUSE.

I think at this point you are right, a bug report is in order.

Thanks.