Fan goes crazy and keeps spinning

I’d like to ask some opinions about a problem that i am having with a brand new Toshiba laptop (L355-S7902). I never had similar problems with any other laptop or PC and i have not been able to find working solutions so far.

Basically, some time after boot the fan kicks in and keeps spinning even if the CPUs’ temperature is most probably low (however something is wrong with the temperature sensors as i keep getting 0deg: cat /proc/acpi/thermal_zone/THRM/temperature always returns 0) and nothing is consuming CPU cycles. The two CPUs (Intel Pentium Processor T3400) may run at something like 5% and no heavy applications are running, yet the fan keeps spinning all the time, and it is really annoying because it is very noisy. When it kicks in, it never stops.
Even rebooting X server does not help, when no users are active, simply at the login screen, the fan is still spinning like crazy. The only way to shut it up is rebooting the laptop, but at the next boot after about 10-15 minute the problem starts again.
The command
cat /proc/acpi/fan/FAN/state
always returns “on” and the application that takes the biggest chunk of resources is Xorg.
My video card is Intel Mobile GM45 Express Chipset
I am using KDE 3.5 on Opensuse 11.1 32 bit.
I also have Vista 32 bit Home Premium in dual boot, and this problem never happened in Vista, not even after hours and when heavy processes are running.

Any ideas??
Thanks a bunch in advance for any opinion!

EDIT: i booted Vista to see if the CPU temperature was reported, installed a little app that monitors it and it works fine with both cores, which are around 45 deg typically

Not my area this but have you tried some of the failsafe arguments or eg: acpi=off or noapic
HCL/Laptops/Toshiba - openSUSE

caf4926 wrote:
> Not my area

not my area either, i think i’ll just give:“laptop+fan”

/( )\ natural_pilot

thanks for the answers.

I think that indeed acpi=off would be the best bet, just that, weird enough, whenever i add that as a boot parameter, or noapic, X-server is unable to start, and i end up with a gray scrambled screen.

natural_pilot, thank you. I had indeed checked many times around the forum and googling around and around. With no solution. I found several Dell laptops with that problem, but for instance one of the proposed solutions CTRL+Z that forces the BIOS to read again the sensor, is not associated to anything in my BIOS. I have the latest Intel driver so no update for now can fix the problem (one of the proposed solutions that i found googling around).

I think (not sure though) the root of the problem is the fact that the CPU temperature is read as 0, that might screw up the fan on/off settings.

Thanks again for the replies!

I was just wondering Rosanna, did you consider that fact that you would want to use Linux on this before you purchased?:wink:

I would probably put it thru the Mill and try every disc I had to hand. Not making any apostate recommendations you understand!

before purchasing it i read various comments around, all were excellent, including those at Newegg - TOSHIBA Satellite L355-S7902 NoteBook Intel Pentium dual-core T3400(2.16GHz) 17.0" Wide XGA+ 3GB Memory DDR2 800 250GB HDD 5400rpm DVD Super Multi Intel GMA 4500M - Laptops / Notebooks , where a user commented:
"I have setup to dual boot XP Pro & Ubuntu 8.10 and it’s seamless, yet to experience a problem with either. "

From the specification it is not predictable that it has a problem. And indeed other than the fan/CPU temperature everything works perfectly even without the need of any adjustment and fix

I wonder if any of the BIOS settings could affect this behavior? Not sure about Laptops but my Box has whole range of BIOS settings which can affect the CPU and Fan.

> "I have setup to dual boot XP Pro & Ubuntu 8.10 and it’s seamless, yet
> to experience a problem with either. "

i have read in these openSUSE fora at least one person who said [where
‘it’ could be many different features] “it worked in Ubundu (or other
distro) but not in openSUSE”

so, if i were you i think i’d try Ubuntu…and, IF it works see if
you can figure out why…and, give the openSUSE developers the clue!!

/( )\ natural_pilot

i checked the BIOS and there is no setting that allows to play with fan or CPU temperature sensors. The only 2 options that refer to CPU is dynamic scheduling and dual core enabled.

I read googling around a ubuntu user with a toshiba laptop similar to mine (satellite L305 while mine is satellite L355) having the same problem. It might be that the ubuntu user that posted in newegg did not pay attention to the fan problem before posting. Anyway even if it should work in ubuntu it is really hard to track down why it works and why in suse it does not. It would imply to analyze a bunch of kernel modules and more. Maybe i will do… for fun in my vacation time :smiley:

I heard the ubuntu user with that problem talking about omnibook kernel module (a user was saying that it solved the problem if compiled with certain parameters) and i saw it is available also for opensuse but not installed by default. I guess it would be worth giving it a shot. Has anyone ever heard about it? the description in yast says that “it includes kernel modules for several HP Omnibooks/HP Pavilion, HP/Compaq nx*, Compal, Fujitsu Siemens Amilo, Acer Aspire and Toshiba Satellite machines. This module include ac, battery, fan, lcd, ec, onetouch, temperature, touchpad and util support.”


I’ve a Toshiba Satellite L300D-10Q, and I’ve just done a fresh install with openSUSE 11.2, which brought back the ‘fan goes crazy’ problem.

I did look around for solutions, and what improved matters was omnibook. If you want to test it out log in as root and pass a parameter value to omnibook – the actual value may involve some trial and error. For example what works for me is …

>modprobe -r omnibook ectype=15

… , the fan did quieten immediately.

To make the change permanent use yast/system/sysconfig/system/kernel/MODULES_LOADED_ON_BOOT to make omnibook load automatically. Then edit modprobe.conf.local with the module parameter. I’ve still to do this.

Good Luck

oops, wrong syntax on command. That should be …

>modprobe -v omnibook ectype=15

Hi zmez, thanks for that tip, I did not know that.

What concerns me is: does the fan spin faster when it is needed?
In fact, my fear is that in trying to make it quite, it does not spin faster when it is needed and this would cause a bad overheating problem.

I have a Toshiba Statellite Pro L300 and had the same problem. Solved by adding acpi_osi=“Linux” to the grub menu boot options. Make sure you have a recent BIOS version, on the L300 it apparently requires BIOS > 4.80 to work.

Add “acpi_osi=Linux” to kernel boot options.
I have such lines in my /boot/grub/menu.lst

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.1 -
    root (hd0,1)
    kernel /boot/vmlinuz- root=/dev/disk/by-id/ata-WDC_WD2500BEVS-26VAT0_WD-WXE409P58888-part2 resume=/dev/disk/by-id/ata-WDC_WD2500BEVS-26VAT0_WD-WXE409P58888-part1 splash=silent showopts vga=0x317 acpi_osi=Linux
    initrd /boot/initrd-