Fake wifi conection, but when wired connection works

When I run ping in my OpenSUSE Leap 15.5 when there is no cable connection but kde claims that it is connected to the internet , I get:

$ ping
PING ( 56(84) Bytes an Daten.
Von icmp_seq=1 Zielhost nicht erreichbar

but ip a says like KDE that I am connected to the internet:

 wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 1:11:11:11:11:11 brd ff:ff:ff:ff:ff:ff permaddr 22:22:22:22:22:11
    altname wlo1
    altname wlp1s0
    inet brd scope global dynamic noprefixroute wlan0
       valid_lft 2828sec preferred_lft 2828sec

Note that I am able to connect to opensuse.org if I use a cable connection.

Not, that is not what “ip address” is saying, it is telling that it has an interface that has address and that the interface is UP, nothing more than that.

Likely that address was acquired using DHCP from the WLAN Acces Point with address, can you ping that?

If so, try “tracepath”.

You can also try “ip link”

 1?: [LOCALHOST]                      pmtu 1500
 1:                                           1.954ms 
 1:                                           1.053ms 
 2:                                          12.366ms 
 3:  keine Antwort
 4:  keine Antwort
 5:                                           16.986ms 
 6:  **censored**            22.857ms 
 7:  **censored**         14.136ms 
 8:  **censored**          16.494ms 
 9:                            19.772ms asymm 11 

ip link

2: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DORMANT group default qlen 1000
    link/ether 11:11:11:11:11:11 brd ff:ff:ff:ff:ff:ff permaddr 11:11:11:11:11:11
    altname wlo1
    altname wlp1s0

Your “ip link” and “tracepath” output should that the WiFi connection to your Access Point is fine. is not a normal IP address so if you want to debug why this connection is not working better show us what a ping/tracepath to or another well know website gives.

It works now. No idea what it was failing.
Maybe false alarm of my homeserver failing at ssh.