Failure of some software to dowmload and install:

There are many instances that software that I select for downloading and installing don’t get installed or downloaded. The yast screen shows it being downloaded then installed, but, most of the times it never transpired. No sign of it anywhere ? I am really perplexed as what is happening. There are other times when all goes well.

So maybe some are just command line applications? If you log into YaST software management and search on the application you installed, is there a check box ticked saying it’s installed? If so in the bottom right window, click on the file list, this will show where the application is installed and and the binary name to use in one of /usr/bin or /bin or /usr/sbin or /sbin depending on the application.

Maybe some examples of applications you have installed but can’t find would help :slight_smile:

I have tried to install Idle … yast shows it downloading and installing ,but , it can’t be found, not even from the terminal.

Funny, on this sandbox laptop I have dozens of repos active, and none of them provides “Idle”.
If the package name is “Idle” it doesn’t mean the program name is “Idle” as well. Something like

rpm -qa | grep Idle

should show the packages installed with “Idle” in their name.

I just tried it . Installed (it does not go to the menu) opened a konsole and typed idle and got a python shell.

So you will have to add it manually to the menu if you want it there.

If you need instruction state the desktop you use.

I’m currently using the KDE version of openSusa 12.3. And thank you in advance for the help.:slight_smile:

I just checked and was able to run from the terminal. now how do I get it on my menu ?

Let’s say the program name is “amarok”. Open a terminal and do

whereis amarok

it will return something like

amarok: /usr/bin/amarok

Now right click the kickerbutton and click “Edit programs” or something like that.
Select a submenu where you want the program to show up and click on the Add Item button
Enter a name that you want the application to have and pick an icon
In the “Command” field, put the result of thewhereis command, in this case


Click File - Exit, save the changes when prompted for.

I do not know what “idle” is, but as it does not install an entry in the start menu, it is probably not a GUI program at all. In that case the method Knurpht describes will not give you the result wanted. In that case, you have to start a terminal with the idle command in it.

Can you tell us if it is a CLI program or a GUI program?

Idle is a editor / command line interface for python. From suggestions I have received in this forum I have been able to run it from the terminal. There was also a help message that popped up on how to use zypper to install it to my menu.

I tried it it installed but did not show in menu. ran dine from command line. Added to the KDE menu and it starts fine there also.