"failure loading applications.menu".

When I click on Computer->More applications I get “failure loading applications.menu”.
Any idea on how to repair this?
I am on 11.4 (64bit).

Is this the KDE or GNOME desktop? Can you run anything from your desktop now?

Thank You,

find ${XDG_CONFIG_HOME//:/ }/menus -name "*applications.menu" -ls
find ${XDG_CONFIG_DIRS//:/ }/menus -name "*applications.menu" -ls
find /etc/xdg/menus -name "*applications.menu" -ls

Gnome desktop. I can still run programs from the desktop and from the menu, when I click on More Applications it seems to fail.
This happened after I tried to install a TV capture card via Yast. I removed the capture card and still nada.

@Please_try - not sure where to look at these.

Just type (or copy/paste) these commands one by one in a terminal. We’re looking for ‘applications.menu’ where it is supposed to be. The default location is /etc/xdg/menus. Maybe applications.menu is missing, has wrong permissions or ownership or contains syntax errors. Whether Gnome uses applications.menu or gnome-applications.menu depends on the value of XDG_MENU_PREFIX. I don’t remember what’s used by default. It might be gnome-applications.menu, actually. I think the value is hardcoded in some file. But you can explicitely set XDG_MENU_PREFIX to an empty string to use ‘applications.menu’. That’s what I do and that’s what I’m not sure what’s the default. Is that a fresh 11.4 install or did you update from a previous version? - because I think the default has changed.

Desktop Menu Specification

It is clean install.

Sorry, I ran the first command and since it was no reply I figured I did something wrong. Here’s the output:

~> find ${XDG_CONFIG_HOME//:/ }/menus -name "*applications.menu" -ls
find: `/menus': No such file or directory
~> find ${XDG_CONFIG_DIRS//:/ }/menus -name "*applications.menu" -ls
1052402   36 -rw-r--r--   1 root     root        33473 Jun  7  2011 /etc/xdg/menus/applications.menu
1050813    4 -rw-r--r--   1 root     root         4085 Feb 22  2011 /etc/xdg/menus/gnome-applications.menu
~> find /etc/xdg/menus -name "*applications.menu" -ls
1052402   36 -rw-r--r--   1 root     root        33473 Jun  7  2011 /etc/xdg/menus/applications.menu
1050813    4 -rw-r--r--   1 root     root         4085 Feb 22  2011 /etc/xdg/menus/gnome-applications.menu

The files are OK. I have the same ones (same size) in 11.4. Two things you can try:

  • Look if you can find some info in the error log ~/.xsession-errors just after clicking on “More applications”.
    Maybe you can find what went wrong here. This file can be pretty long. The following command displays the last 20 lines:
tail -20 ~/.xsession-errors

This command displays the whole file:

cat ~/.xsession-errors

You can also use more or less :wink:

more ~/.xsession-errors
less ~/.xsession-errors
  • Create a new user and log in as this user to see if the problem persists.

I’m not using the default menu though, and I don’t have other advice or explanation to offer.

Thanks, I’ll try these.

Honestly I don’t like that menu this much as I find it bloated and showing too few of the programs. I liked the Ubuntu Gnome menu a lot better but have no idea on how to create it.

Well, you can create the menu you like. Everything you need to know is explained on the freedesktop site. All freedesktop compliant desktop (including KDE, Gnome, Xfce and LXDE) follow the same specifications. Otherwise there are several tools to customize menus at a user level that might be easier to use.

Maybe read this post: http://forums.opensuse.org/english/get-technical-help-here/applications/473531-lxde-menu-entirely-uneditable.html#post2449225

I created a new user and the menu functions ok there, so in this case I just need to copy the files to my original menu to repair it, right?

Where can I find these files?

I don’t edit menus at user level, but I would look for .menu files in the user home directory and delete these files. As the user who has the wrong menus, type:

find ~ -name "*.menu"

and delete these files - although I’m not sure you will find any.

You may also check if there isn’t a wrong path in ~/.config/user-dirs.dirs:

cat ~/.config/user-dirs.dirs

or just rename the user ~/.config directory and re-log in into Gnome. You will lose most desktop and application settings for this user though:

mv ~/.config ~/.config.bak