Failure in OBS with some

Hello,

I’m maintainer of PokerTH in OBS.

Before I build a new version of PokerTH in the “Games” repository, so I want to test to compile the package:
https://build.opensuse.org/package/show?package=pokerth&project=home%3AFreespacer%3Apokerth

It seems some errors, but I can’t understand this failure:
https://build.opensuse.org/package/live_build_log?arch=x86_64&package=pokerth&project=home%3AFreespacer%3Apokerth&repository=openSUSE_11.1

In function 'memcpy',
inlined from 'libirc_new_dcc_session' at src/third_party/libircclient/src/dcc.c:534:
/usr/include/bits/string3.h:52: warning: call to __builtin___memcpy_chk will always overflow destination buffer

few lines later…

Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.43781
+ umask 022
+ cd /usr/src/packages/BUILD
+ cd PokerTH-0.6.4-src
+ '' /var/tmp/pokerth-0.6.4-build '!=' / ']'
+ '' -d /var/tmp/pokerth-0.6.4-build ']'
+ rm -rf /var/tmp/pokerth-0.6.4-build
+ exit 0
... checking for files with abuild user/group
... running 00-check-install-rpms
... installing all built rpms
Preparing packages for installation...
pokerth-0.6.4-1.1
pokerth-server-0.6.4-1.1
... running 01-check-debuginfo
... testing for empty debuginfo packages
... running 02-check-gcc-output
... testing for serious compiler warnings
(using /usr/lib/build/checks-data/check_gcc_output)
(using //.build.log)

I: Statement is overflowing a buffer
E: pokerth bufferoverflow src/third_party/libircclient/src/dcc.c:534
System halted.

If I run on my local opensuse 11.1 with rpmbuild, it can package the rpm without any failure.
But in OBS, it’s failed. I don’t understand that. How can I fixed it?

Thank you for any tips.

Regards,

Sebastian

Hi,

this are errors from rpmlint checks. It gives hints about errors or programming failures. If you are sure that this is no error then you can disable the rpmlint checks by adding


BuildRequires: -post-build-checks -rpmlint-Factory

to the BuildRequires

Hope this helps

Hi
Whilst that will work, I think a buffer overflow is potentially a
serious error??

@OP have you emailed the developer to see if this is a known problem.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (i586) Kernel 2.6.27.15-2-default
up 13:20, 1 user, load average: 0.36, 0.21, 0.25
GPU GeForce 6600 TE/6200 TE - Driver Version: 185.13