Failure: Boot 13.1 install media-> black screen

Hi, I have been trying to install openSuSE 13.1 on a new laptop, a Toshiba Satellite P70 w/ NVIDIA GT 740m GPU, without any success. Booting from either a complete DVD ISO or a network install CD ISO results in the same thing: after grub loads and I have the choice of installing or not (and I try to install) I get a quick scroll of not-so-alarming messages, and then a black screen, and cannot get any further responses without killing power. I went back a version and installed 12.3, but that freezes frequently and has glitchy mouse behaviour (basically unusable after 20-90 minutes), so I’m hoping to move on to something that is still supported, but this is a frustrating start. I think the bad behaviour in oS 12.3 is because of an NVIDIA/intel conflict (I’ve tried using bumblebee, but that wasn’t working and I’m not doing anyone any favors helping debug an obsolete system). But really, I don’t know what the problem is, the /var/log files in oS 12.3 have nothing obvious after a system freeze. I did have to disable “secure boot” to get oS 12.3 installed (otherwise it boots to Windows 8 {yuck! - I removed that partition before I figured out there was something called “secure boot”}), but this doesn’t seem to make any difference with 13.1 -> always black screen with installation media, never actually installed. I don’t really know where to start, I haven’t any info for the 13.1 install, except that the ISO download had the correct MD5sum. Any ideas? Or any info that I should have given but didn’t? Thanks (apologies for the wall of text, this forum won’t let me format it in an obvious way).

The Nvidia graphics are likely the cause of your problem.

You will need to put “nomodeset” on the linux command line during the boot. That should allow you to have a screen, though with crappy graphics. Once installed, you can then install the nvidia drivers to give better graphics.

If this is a UEFI box, you will need to hit ‘e’ on the grub boot command line. Then scroll down to the “linux” line, hit the END key to get to the end of the line, and append “nomodeset”

If this is not UEFI, then it is easier and more obvious how to proceed. There’s also a function key definition for graphics, where you can select NOKMS (does the same thing as “nomodeset”).

Thanks for the fast reply, nrickert! This is UEFI, but what you said worked; 13.1 is now installed. I’ve probably still got troubles ahead to get nvidia to work, but at least I’ve got a foothold to work from.

I’ll update this post/thread with whatever happens.

I’m glad it’s working.

If you can put up with the crappy graphics, it should continue to work. Then take your time to look into nvidia drivers.

I do suggest that you use online update to get your system fully up-to-date before trying to get the nvidia drivers installed. That’s because one of the updates was to Xorg, and it broke the nvidia driver support for some users. So best to get that update out of the way.

Personally, I installed the nvidia drivers “the hard way”, because that seemed easier to me. But that’s a matter of how I use computers. There are other folk here who can better advise you on installing from the nvidia repos.

OK, I think things are working now: No freezes (yet); output of ‘optirun glxspheres64’ is

Polygons in scene: 62464
Visual ID of window: 0x20
Context is Direct
OpenGL Renderer: GeForce GT 740M/PCIe/SSE2
212.851791 frames/sec - 237.542599 Mpixels/sec
212.487107 frames/sec - 237.135611 Mpixels/sec
213.329156 frames/sec - 238.075338 Mpixels/sec
212.454691 frames/sec - 237.099435 Mpixels/sec
213.763089 frames/sec - 238.559607 Mpixels/sec
213.286043 frames/sec - 238.027224 Mpixels/sec
213.597230 frames/sec - 238.374509 Mpixels/sec
212.380424 frames/sec - 237.016554 Mpixels/sec
213.066025 frames/sec - 237.781684 Mpixels/sec
212.243191 frames/sec - 236.863401 Mpixels/sec
213.194337 frames/sec - 237.924880 Mpixels/sec
213.648580 frames/sec - 238.431815 Mpixels/sec
210.660853 frames/sec - 235.097511 Mpixels/sec
212.285579 frames/sec - 236.910706 Mpixels/sec

After some flailing, this is what I did to get where I am. More or less:

I’d removed “nomodeset” from start of /etc/default/grub line GRUB_CMDLINE_LINUX_DEFAULT then run “/usr/sbin/grub2-mkconfig --output=/boot/grub2/grub.cfg”
I believe this stops forcing fallback to fbdev, so that now intel can be used.

Installing the nvidia driver rpms from the nvidia repository in Yast didn’t seem to do anything, but installing with the script at least got “nvidia” mentioned in the Xorg.0.log file. Installing the bumblebee & dkms rpms from Overman79 repository is apparently needed because of this Optimus thing that you can’t set in the BIOS. Using “nvidia-xconfig” or trying to force nvidia driver with any xorg.conf file just caused the server to fail to start.

I might not be done, because there are some possibly troubling issues:

  1. “primusrun glxspheres64” just makes the computer hot, doesn’t output anything.
  2. KDE menu is really slow, I thought my system froze again, but it was just that menu. This might be due to some animation, though I think I’ve got all that turned off.

We’ll see. Thanks again.