Failed upgrade from 15.0 to 15.1; not enough space on device

How much space do I need on my computer for an upgrade?

I’m finally getting around to upgrading my OS. I was using the instructions at this link:

Everything was going good. I downloaded everything, then logged out and then entered the commands to switch to the purely textual interface. At that point, in root, I entered the command for the upgrade. It was over half complete when it gave an error message that there was not enough space on the device.

After downloading all the new packages, I only have 6.5 GB on the root folder. I have another partition with 25.4 GB free.

If I have to delete some files or folders from root. Any suggestions on which ones are safe? Would it be better to upgrade from a bootable USB?

Thanks for any insights!


I’ve decided to do a fresh install on my computer. It is long over due and I need to set up my partitions differently so there is more space in the future.

Don’t bother answering this thread. Admin’s; feel free to delete this. I couldn’t figure out how to do it myself.

You might get it to finish by using --download-as-needed as a zypper option even without freeing up any space on disk first.

There are several places to delete old files wasting space, among them:

  • /var/log/journal//
  • /var/adm/backup/rpmdb/*gz
  • /var/lib/systemd/coredump/*
  • /var/log/updateTestcase*
  • /var/log/*.xz & *.old
  • /tmp/*
  • /root/.cache/*
  • if /home is on the / filesystem, ~/.cache/*
  • if using BTRFS, old snapshots

Can you give me the exact code for the download-as-needed option?

If you want it enabled all the time, as do I, because of chronically limited space on /, then put commit.downloadMode = DownloadAsNeeded in /etc/zypp/zypp.conf. For a one time use use

sudo zypper dup --download-as-needed

as man zypper directs.

Doesn’t work. I get this message, which I tried to get past before by choosing the “vendor change” option for all 5. I’ve already deleted all the extra repo:

You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See ‘man zypper’ for more information about this command.
Computing distribution upgrade…
5 Problems:
Problem: problem with installed package libvlc5-
Problem: problem with installed package libvlccore9-
Problem: problem with installed package vlc-
Problem: problem with installed package vlc-noX-
Problem: problem with installed package vlc-qt-

Problem: problem with installed package libvlc5-
Solution 1: install libvlc5- (with vendor change) → openSUSE
Solution 2: keep obsolete libvlc5-

Any ideas?

I’m on the verge of just doing a fresh install and fixing my partition size problem permanently. But I’m still tempted to try and make this upgrade work. It’s normally 3 days of dedicated computer work to get a the fresh install tuned just right. I’d rather use my time differently :slight_smile:

Sure. Answer 1. It’s OK to switch back from Packman packages to openSUSE packages to get an upgrade to succeed. Once the upgrade is successful, you can switch back to Packman as your needs may require. Since 15.0 release, some copyrights have expired, so you may not even need the Packman versions.

Please use Code-Tags for terminal output:

Good news. Upgrade fully successful. I went ahead and bumped right up to 15.2. I had to do some minor tune ups, but now everything is working perfectly. Maybe the fastest double upgrade I’ve done. Thanks for the assist.

I think my computer still needs a bit of attention. I noticed that during boot up, the screen displays the “Tumbleweed” icon. But I have Leap. I double checked that I used the commands to upgrade to Leap. I did. I checked all my repos, they all are Leap based.

The computer is working fine… at the moment. But I’m concerned that somehow some Tumbleweed code is integrated into my system just waiting to cause problems.

Can anyone help me solve this?

Post the list of your repos

zypper lr -d

But as already asked, use CODE tags around a complete copy/paste of he command and the output.

By the way, this occurred while I was upgrading a second time from 15.1 to 15.2. I’m not sure if that matters, but mentioning in case it does. Here is that output:

#  | Alias                                 | Name                                | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                           | Service
 1 | Virtualization                        | Virtualization (openSUSE_Leap_15.2) | Yes     | (r ) Yes  | No      |   99     | rpm-md | | 
 2 |$releasever | Packman Repository                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |            | 
 3 |  | Virtualization                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | | 
 4 | packman                               | packman                             | Yes     | (r ) Yes  | Yes     |   90     | rpm-md |            | 
 5 | repo-debug                            | Debug Repository                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |           | 
 6 | repo-debug-update                     | Update Repository (Debug)           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                       | 
 7 | repo-non-oss                          | Non-OSS Repository                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |             | 
 8 | repo-oss                              | openSUSE-Leap-15.2-Oss              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                 | 
 9 | repo-source                           | Source Repository                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |          | 
10 | repo-update                           | openSUSE-Leap-15.2-Update           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                            | 
11 | repo-update-non-oss                   | Update Repository (Non-Oss)         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                        | 
12 | x86_64                                | x86_64                              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |            | 

Basically it looks fine, bit the last one (with the not very explaining name x86_64) is still from 15.0.

Did you ever use a Tumbleweed repo where this could have come from?


As I asked you “use CODE tags around a complete copy/paste of the command and the output
The line with the command is missing here. While people in this case possibly can guess what you commanded, make it a good practice to include that one more line at the top of your copy sweep. Not much effort I hope and very helpful for all.

I have never intentionally used a tumbleweed repo. But I recall accidentally doing it once before. Maybe it was associated with that one. I’m not even sure what that is for.

How about I remove that and see if it fixes it?

Remove what?

There are two things here:

  1. you complain about seeing something Tumbleweed during boot;
  2. I seeing a 15.0 repo in your repo list

About 2:
I do not know why you have it, but either you need it and then you have to change it to 15.1 and do a zypper dup --from of it, or you do not need it and then you better remove it.

About 1:
It could indeed be that you earlier had a TW repo by incident. But that is not now teher. When you have done a proper zypper dup to upgrade 15.0 to15.1, I assume there is not a big problem now. It could be that re-creating inird helps in removing the TW thing.

dracut --force

I ran the dracut code and restarted the computer, but the TW label is still there.

About that repo from 15.0, I am confident that is unrelated. I now remember adding that repo after upgrading (which means after this problem was present). I still cannot recall what application needed it, but I do recall there was one that ran on the old 15.0 repo and the website suggested using it on 15.2. I’ll see if I can recall the specifics, but the point it, that isn’t the cause of this TW thing.

As I tried to explain at least two times, there are two unrelated issues.

The 15.0 repo must either be replaced by a 15.2 one (when you still need packages from it), or it must be deleted.
It has no connection at all with your TW picture.

Yep, I agree. Unrelated.

Should I just ignore the TW thing for now? Any other actions to take?

Maybe yes. It is only an image. It is however possible that others have an idea.

Well, IMHO that 15.0 repo is more problematic.


cat /usr/lib/os-release