failed to Start Store Sound Card State.

Hi,
I am unable to boot into my opensuse 13.1 installation.

During boot I get this message.

failed to Start Store Sound Card State.
See 'systemctl status alsa-store.service' for details.

I have used chroot to access the root directory and run the above suggest command.

localhost:/> systemctl stop dbus.service
Failed to get D-Bus connection: No connection to service manager.

thanks


localhost:/> systemctl status alsa-store.service
Failed to get D-Bus connection: No connection to service manager.
localhost:/> 



???
Why do you want to stop dbus.service? systemctl needs dbus to talk to systemd.
The suggestion was to run “systemctl status alsa-store.service” to find out why it failed.

How/where did you use chroot?
This doesn’t help you as you need to run systemctl in the same boot, i.e. with the same instance of systemd running, to get the result from that boot.

And how does the boot fail?
Do you get to emergency mode or text mode? Then run “systemctl status alsa-store.service” there, without a chroot.

During the boot process I receive the message “failed to start store sound card…” then the OS reboots (This happens every time, even in safe mode).

[OK] Reached target shutdown

. #Message appears after failed step in boot process

Is there a way I can boot into text mode? I tried setting the runtime level to 3 in /etc/inittab, but this didn’t work.

This is definitely not caused by the “failed to start store sound card…”.

Most likely you set the default boot target to “shutdown”, so it shuts down immediately when booting. (Similar to setting the default runlevel to “0” :wink: )

Is there a way I can boot into text mode? I tried setting the runtime level to 3 in /etc/inittab, but this didn’t work.

Yes. Systemd does not use/respect /etc/inittab (it has no runlevels anyway).

Try adding a “1” or “3” to the kernel boot options to boot to text mode just like in pre-systemd days. But in your case even adding “5” to boot to graphical mode should work.

systemd’s default target is defined by the symlink /etc/systemd/system/default.target.
Use “systemctl get-default” to find out what it is set to, and use “systemctl set-default graphical.target” to set it back to boot the graphical system.

Or change it in YaST->System->Services Manager.

Thank you wolfi323, the commands worked! great help thanks!