Failed to start Load Kernel Modules : systemd-vconsole-setup[224]: /usr/bin/setfont failed

setfont failed with error 1
I built a new system 2 weeks ago - Gigabyte GA-X99-UD3 motherboard
Intel i7-5820K cpu
16GB DDR4
PRO850W psu
NVIDIA GTX970 graphics card

Result of “sudo lspci -vnn | grep -A12 VGA”

04:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:13c2] (rev a1) (prog-if 00 [VGA controller])
        Subsystem: ASUSTeK Computer Inc. Device [1043:8508]
        Physical Slot: 4
        Flags: bus master, fast devsel, latency 0, IRQ 11
        Memory at fa000000 (32-bit, non-prefetchable) [size=16]
        Memory at e0000000 (64-bit, prefetchable) [size=256]
        Memory at f0000000 (64-bit, prefetchable) [size=32]
        I/O ports at e000 [size=128]
        Expansion ROM at fb000000 [disabled] [size=512]
        Capabilities: [60] Power Management version 3
        Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [78] Express Legacy Endpoint, MSI 00
        Capabilities: [100] Virtual Channel


this error seems to be causing problems with installing graphics card
also console sometimes only shows blank screen even though it is working
eventually the system becomes unusable
this has been true for more than 15 installations with both BTRFS and EXT4
any assistance is appreciated[/size][/size][/size][/size][/size]

This sets the font for the text mode console, probably not related to your actual problem.

Your graphics card is quite new, you probably should install the proprietary nvidia driver.
Does it work in recovery mode? See Advanced Options in the boot menu.

Unfortunately the G03 (340.xx) driver doesn’t support this card (yet?), you would need the latest 343.xx version. But that is not available in the nvidia repo, so you would have to download it and install it “the hard way”:
https://en.opensuse.org/SDB:NVIDIA_the_hard_way

I was thinking it may cause later problems?
I have tried proprietary, and one click - both 343.22 <https://forums.opensuse.org/showthread.php/502180-openSUSE-13-2-and-GTX-970?highlight=black+console+screen&gt;

Is there a way for me to post journalctl and/or dmesg output in formatted form?

I don’t think so.
Again, this is for text mode only, and not setting a font should not giving any problem like you describe. In the worst case you wouldn’t see certain characters like äöü.

I have tried proprietary, and one click - both 343.22

There is no 343.22 in the nvidia repo.
Which “one click” was that?
nvidia-bumblebee will not work without Bumblebee.

For installing it “the hard way” via the .run installer, you would have to add “nomodeset” to the kernel boot options, or blacklist nouveau. (on 13.1 and lower you should also set NO_KMS_IN_INITRD=“yes” in /etc/sysconfig/kernel)
Then run “sudo /sbin/mkinitrd” afterwards.

Did you do that?

I did post a link to detailed instructions though…

https://forums.opensuse.org/showthread.php/502180-openSUSE-13-2-and-GTX-970?highlight=black+console+screen

According to that thread, a GTX 970 should work, when installing via the .run installer from nvidia’s homepage.
https://forums.opensuse.org/showthread.php/502180-openSUSE-13-2-and-GTX-970?p=2673407#post2673407

But again, the packages from the Bumblebee repo will not work without Bumblebee (which in turn only works on an Optimus-System, i.e. hybrid intel and nvidia graphics).

Is there a way for me to post journalctl and/or dmesg output in formatted form?

Upload it to a sharing/pasting site like http://susepaste.org and post a link.

All fixed :slight_smile:
The bumblebee driver didn’t fix graphics, but did make console viewable.
Then delete all open source for NVIDIA and install proprietary driver
At this point I’m still stuck in 1600x1200 and having to use Advance/Recovery to log in.
The proprietary install broke some minor programs so I cleaned them out.
Then an install of kernel 3.18 from the stable directory.
This revealed what I believe to be the base problem - can’t mount cifs drive!
I had: //xxx.xxx.x.x/USB_Storage /directory-for-drive cifs guest 0 0
A quick search revealed that this was trying to mount the drive before the network!
The fix was to add _netdev
e.g. //xxx.xxx.x.x/USB_Storage /directory-for-drive cifs guest,_netdev 0 0
On reboot all is well :wink:
Only problem now is to get two monitors working - one on display port 3840x2160 and one on HDMI 1920x1200
Thanks wolfi323 for making me think logically :slight_smile:

Hmmm what open source NVIDIA driver?? neavue should NOT be deleted

IF you boot to recovery you are NOT using the NVIDIA driver

You do not need Bumblebee. It is only needed for Optimus systems.

If you have a Intel/AMD processor with built in GPU. Turn off that GPU in the BIOS if you want to run the NVIDIA. It could be confusing things.

I worded that incorrectly - I meant the NVIDIA drivers installed by one click
Noveau is blissfully blacklisted
I haven’t managed to get both monitors working properly yet, but NVIDIA has my phillips running in full 3840x2160

I did speak too soon about my cifs drive attached to my router by USB - my fstab entry is:
//192.168.1.1/USB_Storage /media/readyshare cifs guest 0 0
this has been working for the last four months
then today when NVIDIA started working, it started giving cifs error code 13
I tried user, user_xattr and default and it asks for a password - I have never put a password on this drive

Any help would be greatly appreciated ty

I don’t know if this is related to my cifs drive error, but on further inspection I found this error:
EDAC sbridge: ECC is disabled. Aborting
EDAC sbridge: Couldn’t find mci handler

Best I can gather is it is a type of memory activated by the BIOS that doesn’t lots of power
It wasn’t there this morning and I haven’t been in the BIOS today

Any ideas greatly appreciated ty

ECC is error correcting memory. Most non-commercial machines do not use it. The OS is just check to see if you have it. It should not be a problem

I would not think that the NVIDIA driver has anything to do with any drive.

What does fdisk -l show? do you see the drive?

If you really think that the NVIDIA driver is a problem with the drive boot to recovery mode as a test this will load generic drivers.



snow@rocky:~> sudo fdisk -l
root's password:

Disk /dev/sda: 3.7 TiB, 4000787030016 bytes, 7814037168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 465D6B80-0277-4552-AFB8-F72ABAAD6611

Device     Start        End    Sectors  Size Type
/dev/sda1   2048 7814035455 7814033408  3.7T Microsoft basic data

Disk /dev/sdb: 3.7 TiB, 4000787030016 bytes, 7814037168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 99573344-A5D3-49C0-9EEB-C1426C703FB6

Device            Start             End          Sectors  Size Type
/dev/sdb1            2048       10489855       10487808     5G  Microsoft basic data
/dev/sdb2     10489856    5   2436991      41947136   20G  Microsoft basic data
/dev/sdb3     52436992     681588735    629151744  300G Microsoft basic data
/dev/sdb4    681588736    891301887    209713152  100G Microsoft basic data
/dev/sdb5    891301888  1101015039    209713152  100G Microsoft basic data
/dev/sdb6  1101015040  1415583743    314568704  150G Microsoft basic data
/dev/sdb7  1415583744  1625296895    209713152  100G Microsoft basic data
/dev/sdb8  1625296896  7810047999  6184751104    2.9T Microsoft basic data

Disk /dev/sdc: 1.8 TiB, 2000398934016 bytes, 3907029168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 0617A31E-ACF8-4E43-9B34-3A576DF54BEE


hmmm interesting…
sdb1 is efi/boot
2-8 are swap, root, opt, var, usr/local, tmp and home - all ext4
sdc is one I hope to be doing some forensics on if I can get this computer stable
sda is my anything goes disk - translation: I’m too lazy to organize it :wink:

no cifs drive
However, in dolphin sidebar it appears
Error message when clicked:
<<
An error occurred while accessing ‘USB_Storage on 192.168.0.1’, the system responded: mount: only root can mount //192.168.0.1/USB_Storage on /media/readyshare
>>

Error message when I try to “mount -a”:
<<
snow@rocky:~> mount -a
mount: only root can use “–all” option
snow@rocky:~> sudo mount -a
root’s password:
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
snow@rocky:~>

>>

I have read the man pages for mount.cifs and mount plus a few more - all very edifying, but I must be blonde because I can’t see the problem :confused:

Also I can’t find the cifs error code listing

Of course not.
fdisk only shows the disks/partition physically present on your computer, not remote filesystems.

However, in dolphin sidebar it appears

Yes, because of the entry in the fstab.

Error message when clicked:
<<
An error occurred while accessing ‘USB_Storage on 192.168.0.1’, the system responded: mount: only root can mount //192.168.0.1/USB_Storage on /media/readyshare
>>

According to “man mount.cifs”:

This command may be used only by root, unless installed setuid

So you would have to set the suid bit on /sbin/mount.cifs to make it possible for a user to mount a share.

snow@rocky:~> sudo mount -a
root’s password:
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
snow@rocky:~>

Can you remove the “guest” option as a test?
Does it work then?
Maybe try to explicitely set a user name in the fstab entry (user=xxx). Perhaps a password is required for mounting as root.

Sorry for not replying wolfie, I had the mother of crashes :confused:
Took two days and a lot of old school voodoo firstly to get anything recognised by the computer << Parted Magic, System Restore, GParted, HDD’s, Sata, USB"s, DVD’s etc. etc. >>
Then to actually get it to install << I ended up doing a legacy installation ( basically just to prime the system ) through the legacy set up program SuSE defaults to on abort
This was the only way I could get my USB set up disks recognised and, when asked for a USB directory, I could point it at root “/” and it would find it
The end result is I now have the best installation since I started using 13.2rc1 :slight_smile:
These are the journalctl, dmesg and one of the old journalctl:

http://paste.opensuse.org/64628141
http://paste.opensuse.org/90127811
http://paste.opensuse.org/73523093

Be interested to know if you see anything bad in the new ones - I’m somewhat new at this and don’t understand most of it

The only reason I can see for multiple, widespread and inconsistent problems like this is the combination of recent releases in motherboard and graphics card plus just released green operating system and BIOS