Failed to start Apply Kernel Variables message on dup to 20200914 snapshot

I just dup’d Tumbleweed to the 20200914 snapshot, and have a new ‘Failed to start Apply Kernel Variables’ error message on boot:

From journalctl -b:

Sep 15 21:01:59 localhost systemd[1]: Finished Load Kernel Modules.Sep 15 21:01:59 localhost systemd[1]: Starting Apply Kernel Variables...
Sep 15 21:01:59 localhost systemd[1]: systemd-sysctl.service: Main process exited, code=exited, status=1/FAILURE
Sep 15 21:01:59 localhost systemd[1]: systemd-sysctl.service: Failed with result 'exit-code'.
Sep 15 21:01:59 localhost systemd[1]: Failed to start Apply Kernel Variables.

And from # systemctl status systemd-sysctl.service:


● systemd-sysctl.service - Apply Kernel Variables     Loaded: loaded (/usr/lib/systemd/system/systemd-sysctl.service; static; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/system/systemd-sysctl.service.d
             └─50-kernel-uname_r.conf
     Active: failed (Result: exit-code) since Tue 2020-09-15 19:02:01 CEST; 8min ago
       Docs: man:systemd-sysctl.service(8)
             man:sysctl.d(5)
    Process: 1016 ExecStartPre=/usr/lib/systemd/systemd-sysctl /boot/sysctl.conf-5.8.7-1-default (code=exited, status=0/SUCCESS)
    Process: 1021 ExecStart=/usr/lib/systemd/systemd-sysctl (code=exited, status=1/FAILURE)
   Main PID: 1021 (code=exited, status=1/FAILURE)


Sep 15 19:02:01 localhost systemd[1]: Starting Apply Kernel Variables...
Sep 15 19:02:01 localhost systemd-sysctl[1021]: Couldn't write '"0 2147483647"' to 'net/ipv4/ping_group_range': Invalid argument
Sep 15 19:02:01 localhost systemd[1]: systemd-sysctl.service: Main process exited, code=exited, status=1/FAILURE
Sep 15 19:02:01 localhost systemd[1]: systemd-sysctl.service: Failed with result 'exit-code'.
Sep 15 19:02:01 localhost systemd[1]: Failed to start Apply Kernel Variables.]

Everything seems to work, at least so far.

Is there a setting I can edit on my own? Should I file a bug report?

I found and updated this bugzilla: https://bugzilla.opensuse.org/show_bug.cgi?id=1174504

It affects the ping command, but the failure above shouldn’t affect any system, it was a partial and apparently untested solution. You can wait for a fixed package arriving in TW.

Yes, I am seeing the same.

Should I file a bug report?

Yes, I would suggest that.

That was quick! Thanks for the response. I’ll bookmark bug https://bugzilla.opensuse.org/show_bug.cgi?id=1174504 and wait for the fix to arrive in TW.

After reading Hans-Peter Jansen’s helpful message at: [https://lists.opensuse.org/opensuse-factory/2020-09/msg00147.html](https://net.ipv4.ping_group_range = 0 2147483647), I fixed this by booting to terminal and:

# vim  /usr/lib/sysctl.d/50-default.conf

In the editor, I changed:

net.ipv4.ping_group_range = **"** 0 2147483647 **"**

to

net.ipv4.ping_group_range = 0 2147483647

then saved the file, and wrapped up with:

# mkinitrd

Problem gone, no errors on boot. Thank you, Hans-Peter!