Failed to mount cd:/// etcetera

Hi -


Setting up my DSL. After I’ve selected my ISP and entered my UN/PW, etcetera, OpenSUSE tries to read the software repository on the install DVD, but it can’t. Error message after spinning up: “Failed to mount cd:///?devices=/dev/sr0 on /var/adm/mount/AP_0x0000001: Mounting media failed”.

So then I tried getting OpenSUSE to simply read the DVD. But after spinning up, I got the error message “Failed to mount ‘SU1100.01’. no ← (action, result).”


New Linux user here. Installed OpenSUSE 11 on Sunday. To my great joy, after a disheartening failure with Ubuntu, the dual-boot OpenSUSE/Win XP installation worked (two hard drives). And yet there are problems. But I’d like to do my troubleshooting from the Xfce desktop, rather than boot into Win XP, write out notes by hand, and then reboot into Linux to try stuff out. So getting online is my first priority.

Others in this forum have brought up the first of the two error messages, but only as an aside, and the solutions do not address this “failed to mount” problem—except for one guy who talks vaguely about deleting something, which I didn’t understand. Here are the links if you’re curious:

Problems With Update - openSUSE Forums [Amarok update problem] [WinRAR install question]

My first thought is that I’ve got to mount my DVD player somehow, although it does spin up before the error messages appear. My second thought is that because the first error message refers to a CD (“cd:///”), but the device label (or whatever we call it) “/dev/sr0” is the same as that for my DVD player, it’s a conflict between my hardware and the default system settings. Any ideas?


OpenSUSE 11 (Xfce)


Gigabyte GA-P35-DS3L
1.8 GHz dual-core Pentium
Nvidia 8600 GT 256 MB
2 gigs ram
Optiarc DVD RW AD-7170A [firmware updated]

I know you’re a new user, so some of the issues you encounter and the cause may not be obvious. Incorrect policykit settings can cause this type of problem. (PolicyKit controls who gets access to various devices). To check this, open a console (terminal) and type

su (enter root password when prompted to become root user)

Then do

cat /usr/share/PolicyKit/policy/

You will get some output including this section:

<action id=“”>
<description>Mount file systems from removable drives.</description>
<message>System policy prevents mounting removable media</message>

The <allow_active> tag value is important. Mine is set to ‘yes’. Yours may be set to ‘auth_admin_keep_always’ or similar. If it looks like mine, we will have to investigate other possible causes… maybe someone else can shed some light on this.

Forgot to mention, after the initial installation you can disable the DVD repo with YaST > Software > Software repositories (just uncheck the ‘Enabled’ box for the openSUSE-DVD 11.0 repository). Thats one problem taken care of.

Thanks very much for the reply, deano. I did a forehead slap here about 15 minutes ago, when I learned that I can mount the media from console with the command “mount -t iso9660 -r /dev/sr0 /mnt”. Et voila: disk mounted. So now my DSL is set up, and I’ve just got to figure out where to click to get online, which I can do on my own steam.

I’ll keep your advice about policykit settings in mind as I scale the Linux learning curve. Disabling repo could be very helpful too. Onward and upward :slight_smile:

Good work. :slight_smile: