Failed to find MBR identifier

I installed openSUSE-12.3-KDE-Live-i686 to a pen drive.

It showed a screen then it said that it failed to find the MBR identifier.

I had to reboot into Windows XP.

Can someone help me ?


Do you have openSUSE running on any computer? Can you create a Live DVD and boot from it? I have a bash script that will work, but you must already be running openSUSE from a normal install or from a Live-DVD boot, where you download the script and ISO from the Live session. For this bash script, have a look here:

S.C.L.U. - SuSE Create Live USB - Blogs - openSUSE Forums

Tell us if you must create the PEN drive while using Windows only or if you have no DVD drive burner.

Thank You,


I have it installed on my hard drive and I need help with another item.

I need to be able to edit grub.cfg, but I don’t have the right permission.

I want to change the default o.s. that boots up to my Windows XP menu entry.

Even when I was able to edit that file, it was very confusing. :slight_smile:


You need to be root since that is a system wide setting and not user specific.

Try Yast-boot manager You should be able to set priority there

You will find Yast in the menu

For working with Grub 2, the default with openSUSE 12.3, look no further than my bash script you can find here: GNU Grub2 Command Listing Helper with --help & Input - Blogs - openSUSE Forums

You can set any menu/advanced menu option as the default to load after the default time out has been reached. You can use the following terminal command to download and install the bash script for you:

rm ~/bin/grub2cmd ; wget -nc -O ~/bin/grub2cmd ; chmod +x ~/bin/grub2cmd

Just copy from here, paste into terminal and press enter. Once complete, start it running with the command: ** grub2cmd**

Thank You,