Failed to create mount unit file /run/systemd/generator/sysroot.mount, as it already exists

Hello All,

after having upgraded from 13.2 to TW, I get the following error message at startup:

[FONT=courier new]Failed to create mount unit file /run/systemd/generator/sysroot.mount, as it already exists. Duplicate [/FONT][FONT=arial black][FONT=courier new]entry in /etc/fstab?

I’m not the first to get this error, as it has been already documented here: [/FONT]
Anyone has any idea on how to solve the issue without re-installing the system? I’ve got plenty applications that I would rather keep

Thanks in advance [/FONT]

There is no need to shout so loud. This is well known issue, it is cosmetic (it does not cause any harm) and it should be fixed in one of future updates.

Sorry, arvidjaar, but I cannot see the point of your answer. I have a problem that prevents me from booting my computer, whether is going to be fixed in a future upgrade is irrelevant to me at the moment, as since I cannot boot my computer I will not be able to implement the bugfix anyway.By the way, if your “There is no need to shout” was referred to the uppercase Tumbleweed in the title, please note that it is a tag that the forum allows you to choose for your post from a drop-down list, whre you have no choice but uppercase.

So, I will ask again: Is there any way to recover the situation without reinstalling from scratch?
I could think of using a rescue disk top get to a command line, but what next?

Thanks in advance

I’m not sure that there’s anything to recover. If your system isn’t booting, perhaps there is some other reason.

I am seeing that message in a system where I did a clean install less than 1 week ago. So a clean install won’t solve that problem, though perhaps it will solve some other problem that you are having.

Note also, that I see the same message on a system where I am using an encrypted LVM. The message shows up before I have given the encryption key. So it isn’t seeing a problem in the file system. It is presumably seeing a problem in the temporary file system provided by the “initrd”.

No; it was referring to text which appeared all bold and rather large.

Is there any way to recover the situation without reinstalling from scratch?

Which situation? The message you mention is cosmetic; it does not cause any known problems. To fix a problem this problem first needs to be identified. So start with describing symptoms (what happens in your case), not your conclusion what may be causing your problem.

The message you mention is cosmetic; it does not cause any known problems. To fix a problem this problem first needs to be identified.

Ok, maybe I started with the wrong foot, I’ll try harder:

Current situation:

  • I switched from 13.2 to TW
  • After the installation, at boot, I get this error message:
Failed to create mount unit file /run/systemd/generator/sysroot.mount, as it already exists. Duplicate entry in /etc/fstab?  
  • After giving this message, the system hangs, and there’s nothing else I can do


  • Is there a way to recover from this error?

The hang is probably caused by something else, and not related to the message that you are seeing.

As soon as you see the plymouth splash screen during boot, hit ESC. That should give you more information on what is happening during boot. See if there is anything there that might hint at the cause of your problem.

Maybe boot to a Live USB/DVD and look at the file etc/fstab on the partition containing root for your system.

Thatat least appears where the problem is

It occurs to me that you might have a graphics driver problem.

On my system with an nvidia card, login appears to hang on the first try. If I had setup automatic login, that might have looked like the system hanging during boot.

So what graphics card do you have? What desktop did you install (the default is KDE/Plasma 5)? And did you go with the default of automatic login?

Even better - in bootloader menu hit ‘e’ to edit menu commands, move to line starting with “linux” or “linuxefi”, delete “splash=silent” and “quiet” words and press F10. This should give verbose boot messages.

Thanks for the suggestions above!

So, I have an old nVidia graphic card, I knew already that was going to be a problem and I had already downloaded the appropriate proprietary driver to install.

Eliminating the splash=silent and the quiet options from the booting process worked, in a strange way: My data partition is crypted, and removing these options actually make the system visualise the password prompt. That allowed me to access the command line and install the nVidia driver.

After that, I rebooted with the standard options, and the system hanged again.

Now, I am writing you from the sparkling new Plasma 5 interface of my laptop, that I had to start by once again eliminating the splash and the quiet option. Looks like that with them active, the system does not give a password prompt.

Have you got any idea why?

The normal opensuse default is to use automatic login. If your system is set up that way, then there normally would not be a password prompt. Your changes may have forced a command line login, which gave a password prompt for that one boot. If that’s part of the issue, then try CTRL-ALT-F1 to get to a command line login.

On my system with older nvidia graphics, I found that plasma 5 does not like my graphics card, even with the nvidia driver installed. You may have the same problem.

My “solution” was to look for the file “$HOME/.config/kwinrc”. That file contained a line “OpenGLIsUnsafe=false” (in the “[Compositing]” section). I changed the “false” to “true”, and then plasma 5 worked. I later changed desktop effects to use XRender (instead of OpenGL), and then desktop effects started working.

I don’t know whether or not that is helpful with your problem.

After the 20151201 TW snapshot, the “Failed to create mount …” error is no longer displayed at boot.

Obviously won’t help with “MadSplinter’s” problem though.

Same here. :wink:

Oops. I meant to reply that I no longer have the same message. It is gone from my boot.

That’s correct, it’s fixed and completely on-topic.