Failed to create GRUB bootloader config on installation


I am running into a problem on my brand new laptop, a HP Pavilion Entertainment PC dv6. It came pre-installed with Windows Vista Home Premium edition. My goal was to install OpenSuse 11.1 next to it in a dual boot configuration.

Installation wend well at first. I used the installer-advised setup and let it change my partitioning, shrinking the windows partition to make space for OpenSuse. The problem started when the bootloader was to be created. There was an error (that I unfortunately did not copy or write down) from GRUB. It told me something about a partition that did not exist. I tried about every option in the installer at that point, end ended up in a situation where the installer insisted on creating a bootfloppy, while the laptop has no floppy drive. At one point I still got the error from the installer itself, but this time there were two GRUB outputs under one another, the second one claiming that the process had gone OK. I think that was after I checked another location for the bootloader or something like that. Sorry I am not being more precise here…

The installer restarted the laptop, and… nothing. The bios, which I can’t really enter, claims that there is no OS installed, and it can’t start from the OpenSuse DVD that I burned. I managed to start the laptop using an older OpenSuse Live CD. I used the partitioner to get an overview of my current HD partition layout:

/dev/sda   232.8 GB   Hitachi-HTS54322
/dev/sda1  100.5 GB   HPFS/NTFS
/dev/sda2   10.5 GB   HPFS/NTFS  (Label: Recovery)
/dev/sda3  121.7 GB   Extended
/dev/sda5    2.0 GB   Linux Swap
/dev/sd6    20.0 GB   Linux native
/dev/sda7   99.7 GB   Linux native

I have copied the above from a screenshot, and left out the start and end columns and the other columns that were empty.

When I start the bootloader utiltiy from Yast, I get the following error:

Because of the partitioning, the boot loader cannot be installed properly

Since I am using the partitioning suggested by the installer, that suprised me…

Can somebody please point me in the right direction to make the system usable again? Since I don’t have Vista installation media and I need windows for work, I can not really afford to loose the windows partitions. Of course, I would prefer a solution to make the dual boot work, but at least making windows boot again would already be a huge advantage.

Thanks for any pointers you can provide me.

It’s possible the grub was trying to install to a /boot partition, which does not exist.
I would boot the dvd and proceed as if to install by chooing Installation, then at this screen: Installation/11.1 DVD Install - openSUSE
Choose repair option

Go to the expert mode, as if you know what you are doing and choose to repair the grub bootoloader (not sure exactly how it will be described: Booting, Bootloader, Grub - you get the idea)

Now. So long as you have a windows dvd or recovery dvd - you can put the bootloader on the MBR
see these screens in order and select the MBR radio button only

If you don’t have a windows dvd and don’t want the bootloader on the MBR, install grub to ‘root’ only. And then you perhaps want to use EasyBDC to boot from windows.

There is also the possibility that you may have to change the boot flag on the partitions, you didn’t show that in your details, it is shown by *

See how you get on. Don’t panic, everything is still there according to your partitions. I’m out for the rest of today. But others will be able to help too.

Probably your system is OK, except for this boot loader issue. Usually it’s not all that difficult to fix.

Regarding the “no OS” error message: There are actually two such messages, very similar to one another (so w/o seeing the exact wording, it’s impossible to know which). One is thrown by the BIOS when it cannot find executable code in the MBR, the other is thrown by Windows boot code in the MBR when it cannot find its next stage program in Windows.

Ordinarily I would suggest restoring the Vista boot code and setup, then installing EasyBCD (here: Download EasyBCD 1.7.2) and using it to configure Vista to boot openSUSE. Restoring the Vista code requires Vista recovery media; you can get that here Windows Vista Recovery Disc Download (that’s a bittorrent download, btw). If you have another working machine where you can download and burn this disc, we can point you to instructions for how to do this.

If you don’t have another machine, you can install grub to the MBR for booting openSUSE, from there you can configure grub to boot Vista. If you wish to revert boot control to Vista as ref’d above, you can do that once you have grub booting the system.

To install grub to the MBR, boot the openSUSE LiveCD. Then open a terminal, and do:


which will give you root privilege. Then do:

find /boot/vmlinuz

From your partitioning, the find command should return: (hd0,5). Assuming it does, then do:

root (hd0,5)
setup (hd0)

After the setup command, grub should return abt 7 lines of messages indicating what it has done (this may not make much sense to you). Grub should now be installed in the MBR, pointing to openSUSE on sda6. If you intend to return boot control to Vista, then you should additionally do the following while still in the terminal:

root (hd0,5)
setup (hd0,5) (hd0,5)

That will install grub also in the openSUSE partition boot sector. You’ll need this to configure Vista to boot openSUSE.

Now reboot the machine and report back.

Thanks a million guys.
While trying to repair windows using the windows Vista repair disc I downloaded through the torrent you linked did not work (even after repeatingly chosing the repair boot option the system still gave the following error:

Error No operating system

I used the grub option instead, and that seems to work fine. My computer now boots again. I first get a Suse boot menu with four options (OpenSuse, Windows 1, Windows 2, and Open Suse failsave), and after choosing windows, I get another menu with offers me the choice of the OpenSuse installation (I started the installation originally from Windows using the DVD, because it turns out my DVD is not bootable) or boot Vista. Booting Vista from there works fine. I used the EasyDCD program from Vista to remove the OpenSuse option from the Windows menu, so I think I will be able to work it out from here for now.

Again, thanks a lot!

I now know what happened, given that you shared that you launched the installation from within Vista (rather than booting the DVD). That process sets up a boot entry in Vista’s boot manager database, which is supposed to be removed as the final step after installation, when the machine reboots. But sometimes this method doesn’t work; Vista is very finicky about the boot database. It was this temporary entry that you removed with EasyBCD. This is also why the automatic boot recovery didn’t work from the Vista CD; in that case, from that CD you run a command window and enter the commands which flush and rebuild the database (this is what I earlier offered to point you to).

As it is, you’ve got grub in the MBR and you are “chainloading” from grub to the Vista boot manager. That is why you see the second boot menu, from Vista (altho when there is only one entry in the Vista database, it may skip the menu). Probably the reason you have two Windows menu entries in grub is that there is a second “recovery” Windows partition; you can delete that if you wish and change the menu selection title, all in YaST Boot Loader. Or you can directly edit the menu text file (as root); it’s located at /boot/grub/menu.lst.

Welcome to the community!