Failed to complete boot - nouveau - nVidia

Hey experts and those to aspire to become such (like myself)

It’s been three weeks now that I’m using OpenSuSe Leap 15.0 on my new Lenovo T480. Today, rather unexpectedly (I was just browsing the web), the system crashed. I will try to describe everything as detailed as I can, but as a novice please have some patience with me and I will do my best, to provide all the information you’re asking for.

So, as I said, just browsing the web when the computer crashed. Turned it off using the power button (Nothing else worked) and went to reboot. After choosing which version to boot (Leap 15.0 as usual) it showed the following the messages

CPUn: Package temperature above threshold, cpu clock throttled

for all CPUs. And then continued to:

nouveau 0000:01:00.0: DRM: Pointer to TMDS table invalid
nouveau 0000:01:00.0: DRM: failed to create kernel channel, -22
kvm: disabled by bios

which was only displayed for a brief moment before the screen went black, with only an underscore in the top left corner.
I let it cool down and did some (and eventually some more and even more) reading on this.
I retried a few times but always with the same outcome (though without the temperature warning). Once, I let it sit at the black screen but with time the laptop only got hot. Opening an yesterday’s read-only version I was able to start the computer but then again, it would eventually get real hot and crash (at latest by the time I try to turn it off)
In all the reading I did, I was beginning to think this might have something to do with the NVidia graphics card and the missing installation of bumblebee. Yet, I would not how to do install bumblbee on the computer since it doesn’t really start up. So, I do appreciate any input on how to get the computer to run again. Oh, and I would appreciate it even more, if you pick me up from where I currently am -> zero knowledge. So, thanks again for all your help! I know, there probably are more exciting problems to solve out there, so I really value your help and will do my best!

Here’s some information on the computer:
Lenovo T480
Graphics: Intel UHD 620 + nVidia GeForce MX150
Intel Core i5-8250U CPU (1.6 GHz)
Linux Version 4.12.14-lp150.11-default
OpenSuSe 15.0

If it worked and then stopped and there was no kernel update immediately before it sounds more like hardware issue.

Hey, thanks for taking the time to read this!
It was like that: I opened a new window in Firefox and this window did not load. I was still able to move the cursor and to click on things, only that no reactions occurred. Also no reactions on any keyboard commands, which had me ultimately shutdown the computer using the power button.

Nevertheless, speaking against a HW issue, would be the fact that the integrated Lenovo-HW test says it’s all fine. But can I provide you with any data to confirm or discard your assumption?

I bought a B250 Kaby Lake motherboard last December. I used it sporadically over a period of 5 months. Then right in the middle of idling on the desktop, or maybe running a trivial utility in Konsole, it completely froze. I had to use the power button, but it never would POST again until I removed a RAM stick. It ultimately turned out that either of two of the four RAM slots were blocking POST if populated. It was down 6 weeks by the time Gigabyte had a working replacement in my possession, after first wasting 2+ weeks getting the RAM replaced.

IOW, just because it’s new is no guarantee against hardware failure. Try and reseating, swapping or pulling a RAM stick or two.

Hey! Thanks for the advice. I have now tried the memtest a couple of times and it always stops somewhere halfway through, goes to a black screen and then restarts the BIOS as usual and as nothing has happened. I guess this also hints at a HW issue?
I am now running the extended, all system, pre installed Lenovo Hardware test hoping it doesn’t crash.

Another clue, maybe hinting at a HW issue: I tried to rollback to an earlier snapshot and boot it from there and it returned:

 null src bitmap in grub_video_bitmap_create_scaled. 

May that also hint at HW?

Sometimes, this type of booting problems has faced, and at the result of it, it can get hanged and all the booting setup process can be reprocessed by the user in an easy way. and with the help of Netgear Support you can get to know all the booting and rebooting process.

Hey everyone,

Over the course of the weekend I have tried different things.
First, I have tried running the Memtest several times. It crashes each time of the beginning of the Bit fade test. Logfile says:

2018-10-08 09:41:26 - Start bit fade test (0x0 - 0x27F800000)
2018-10-08 09:41:26 - Locking all memory ranges first...
2018-10-08 09:41:26 - Memory range locked: 0xC000 - 0x58000 (8159600KB of available memory left)
2018-10-08 09:41:27 - Reducing memory range: 0x100000000 - 0x27F800000 ==> 0x100000000 - 0x27F700000
2018-10-08 09:41:27 - Memory range locked: 0x100000000 - 0x27F700000 (1024KB of available memory left)
2018-10-08 09:41:27 - All memory ranges successfully locked

and ends there. It did the same thing no matter if I chose one CPU or let it go at all at the same time. It crashes there or continues to start the OS.

After that, I have cleaned up the Laptop and formatted my openSuse partition. Instead, I created a Partition and installed Windows 10, which runs perfectly fine. On a second partition I installed Fedora. Fedora boots fine, but crashes during shutdown with a


on any CPU. MemTest returns the same results.

Any ideas on what the issue might be? As I said before, I’m not that profound in knowing whats going on inside the computer and would be glad for any input. (Especially if it doesnt include taking apart my three week-old laptop. If that is the only option, you see any chance of settling this under warranty issues? Then again, why does Windows run without any issues? To this point at least…)

Well, thanks again and looking forward to any response,

One possibility…

I had a new desktop crash quite a bit many years ago, I eventually tracked it down to some performance/overclocking BIOS settings that had somehow been enabled (I may have received a previously returned motherboard). No similar problems since disabling them.

I would just be taking it back to where I bought it and saying “Replace or my money back”. Might even insist on a different brand/model.

Then again, why does Windows run without any issues? To this point at least...)

My assumption would be that, so far, Windows has not hit the section with the HW glitch, yet. But, will.

So, I would be back at the store right away, with the purchase fresh and they are more likely to just do a swap to another laptop, rather than wait and have to deal with it on warranty alone, shipping it away, waiting for it to come back, hope they fixed it, and that it won’t happen again after the warranty runs out, perhaps stone-cold dead.