Failed To Add Repositories

Hi, I’ve tried to install Heimdall and I’m having a bit of difficulty with repositories - I wondered if someone could help.
I’ve tried installing from here with a 1 click install:

http://software.opensuse.org/package/heimdall

I’ve tried to add the repository using YaST and got the same error:


Cannot access installation media
http://download.opensuse.org/distribution/13.2/repo/non-oss/(Medium 1).
Check whether the server is accessible.
URL: http://download.opensuse.org/distribution/13.2/repo/non-oss/
Download (curl) error for 'http://download.opensuse.org/repositories/hardware/openSUSE_13.2/repo/repoindex.xml':
Error code: Connection failed
Error message: Failed to connect to download.opensuse.org port 80: Network is unreachable

There’s nothing wrong with my internet connection & I can browse to:

http://download.opensuse.org/repositories/hardware/openSUSE_13.2/

Can anyone help?

Thanks,
Mike

Hi,
I’ve seen a few of these problems pop up lately and I’d request that you try something out to see if it helps since I can’t replicate the problem.

Would you please add


options single-request

to your /etc/resolv.conf and re-try zypper?

If that doesn’t help, try:


options single-request-reopen

If neither of them help - just remove them and let’s try some other alternatives.

we’ve had a lot of updates recently, at least today I had a new updates available pop-up and then all repo’s wore unreachable, after ~20 mins the repop’s wore up and I had ~250 parches to download (a lot of kde4 was updated I downloaded all delta rpm’s), I think the reason is time zone’s and a lot of recent patches.
why time zone’s well not everyone updates at the same time and the servers will be overwelmed with updates for most of the day.

Yeah my rsync went totally bonkers because I have a multi-arch, multi-distro patch mirror setup :smiley:

Trying again, I find that I can’t refresh any of the repositories starting http://download.opensuse.org/ . I suspect that there is something wrong with the server so I’ll try again tomorrow.

There are a lot of patches out today, big one’s too, almost all of kde4 has been updated, I’m not sure if they use meta links for online repo’s but they could be updating some of the mirror’s, or maybe some of the mirror’s aren’t updated and the main server can’t take the load, try again in 20-30 minutes or tomorrow.

The repos are all down for me too. Is there some sort of outage right now?

I had an issue like this yesterday.

But with attempt 4 it suddenly worked.

All OK now - just a server issue. As I_A pointed out, there were tons of updates and the server was either out or struggling. I got the updates today (it took a while). The repositories were added without any problem & installation of Heimdall went ahead without any problem. Thanks.

It’s down again for me today.

I can install packages, (though I sometimes have to hit retry), but can’t do a zypper ref. I’m guessing the timeout is too short.