Failed to access media error

Hi everyone

I posted a thread under the network/internet section, but realised that the people looking at this sections of the forum will probably be able to help me as well.

I am very new to linux, and am using OpenSUSE 10.3 on a VMWare workstation running on a Windows XP computer. I need Linux for a Texas Davinci DM6446 control environment, but am battling to get things set up so that I can start with actually using the Texas device.

The biggest problem I have is that I have tried installing other “modules” from Software Management such as Yast2 NFS server, etc., and even just normal network settings adjustments, but everytime the system spits out the following error:
In SUSE 10.3: "Insert ‘CD 1’ and in OpenSUSE 11.1, which I also tried it said something like Cannot access media (Medium 1), but clearly this is the same error message. The detail is something like “Failed to mount cd:///?devices=/dev/sr0…” Is there a problem with the repositories? The DVD that is in the drive is the same one that I just used to install OpenSUSE from. I have tried with fresh installations of both OpenSUSE 10.3 and 11.1.

So now I have resorted to asking the experts (should have done this a long time ago…)

Thanks in advance


To add to my confusion: when I installed OpenSUSE 10.3, it recommended checking the media from where I install. I did this, and the result was perfect. Yet, when I did a media check just now, the system does not seem to pick up the DVD that is in the drive? Any ideas?

This is a vmware error and nothing to do with Suse. I can’t comment but do find occasionally vmware doesn’t always see peripherals I fight my sound card sometimes.

As for fixing well I tend to remove the hardware aspect out of it and use the iso. Though if you have network there is nothing to stop you removing the dvd as a source from your repos.

Basically you have the guest/s and host arguing over who should be using it. Perhaps the host is using it.

For the other people that may stumble accross this erros. I have solved it in 2 different ways…

The easiest is to disconnect the cd-rom in the bottom bar of the VM. Go into Windows and then open the cd-rom by pressing the button on the cd-rom. Then, connect the cd-rom in the bottom bar of the VM again, and then click inside the VM to use Linux. After that, just close the cd-rom, and the VM then picks it up. What I then did was copy the whole DVD onto the VM’s disk space, and created a new repository (local directory) thal links to it. This solved most of my problems…