Failed install, wrong digest

While attempting to install the latest OpenSuse 13.2, I receive the following error:

"Wrong Digest
The expected checksum of the file /var/cache/zypp/raw/openSUSE-13.2-0laAerh/suse/setup/descr/app_icons.tar.gz is <long hex value> but the current checksum is <different long hex value>.

The file has been changed by accident or by an attacker since the repository creator signed it. Using it is a big risk for the integrity and security of your system."

Does anyone know why this message appears?? This seems a disaster as I have downloaded from the official opensuse web site. I want to try openSUSE but I do not trust this now.




Does not seem to be an official repo but i might be mistaken.

Any way you might just have a corrupted file, did you have a recent unclean shutdown or a power failure maybe?

You can cd inside that directory and run

file app-icons.tar.gz 

and see what does it has to say.

I download directly from openSUSE. I chose the Direct Link method. How can this not be “official”? I have downloaded 3 different times now with the same results. I also downloaded from a few different mirrors with the same result. I do not want to run this installation if the digest cannot be verified. If this is not the official link, can you direct me to the official download link?

Thank you so much for your help.


This is a large down load. No data transfer is perfect. and you start seeing the errors at about 4 gig. There are some error correction features of the the Ethernet protocol but they are not perfect so some times the file downloaded is just not right. The Installer has to be perfect unlike audio and video media that a small difference would not be evident. Remember that 4 gig is 32 billion bits and ever one must be right.

A better methodology is torrents. they do a lot more checking on each and every chunk. So if the check sums do not match the files is bad download again maybe using a torrent Note if you point the torrent to your file it will fix it with minimum down loading

It is very unclear what you were doing when you got this message.

Were you downloading something. Or were you running the NET installer, and the installer was downloading? Or was this a repo refresh?

I received this message at the time when I attempted to install the ISO image of openSUSE-13.2-0 on a new system. This message appeared at the beginning of the installation process from the installer. I tried installing multiple times using ISO images from different mirror sites in addition to the main direct link. All produced the same error. I have a very fast high speed internet connection (fibre) so I would be surprised to discover this is a bandwidth issue. Besides, the installation failed in the exact same way regardless from which mirror link I download. This seems very suspicious!


What medium are you installing from, DVD, USB? Did you check the md5 or sha sum?

If DVD, then ensure you have burned at the slowest possible speed and use from memory -R media(?)

When installing are you asking the system to update during the install, if so it could be choosing a flaky/incomplete mirror so just do the install whithout adding online repos, it will add them later in the install, just not use them…

looks like hardware issue to me, bad ram or a bad hard disk sector.

btw you didn’t say what are you using as install media the 32 or 64 bit installer, or the net installer, are you using extra repositories during set or only files from the install DVD, there is an option to run a media check on the installer did you try and run it.

Thanks for all the good suggestions. I am installing x64 ISO image I burned to a bootable USB. I will run a media check and see what is the result. I will check the md5 and sha256. I am currently not connected to the internet during install so there has been no update during install. I only attempted to install what comes with the ISO image. Thanks again for the help and suggestions. I will try again.

Best regards,

Ok exactly how did you “burn” the image to the USB stick? In’ openSUSE you do NOT use the extra programs that other distros may need. So did you add any extra stuff to make USB boot. It is not needed for openSUSE a straight binary copy to the device (not a partition) is all that is needed.

I used unetbootin to create a bootable USB from the openSUSE ISO image downloaded directly from openSUSE (Direct Link option). I have used unetbootin in the past with openSUSE installs and there were no problems. I don’t believe unetbootin is installing anything extra but I will check again. I believe all it does is unpack the ISO to the USB and then make it bootable. I will check.

Thanks again for the help and ideas.


Not any more. Do not use any Linux boot helper. Follow instruction here

If running from any Linux you can use cp or dd to copy to the device. Note again it is to the device not a partition on the device.

That is the problem. openSUSE is designed to boot correctly from a USB with out any extra stuff just a binary copy to the device

Thanks, I will give that a try.