failed install hypervisor and tools on yast control panel


I need a simple hypervisor like virtualbox.
So I tried to install XEN hypervisor and tools on YAST Control Panel. But the installation failed.
I’m on Opensuse Tumbleweed.

Thank you very much for your help

How? What did you see that made you conclude that it failed?

This is the video of failure:
I would like to give more information but I don’t know what to show.
I tried to run yast gui on terminal but it’s the same.
I searched a lot in yast log by running this command:

maurizio@localhost:~> sudo vi /var/log/YaST2/y2log

but I can’t find the line that tells it failed.

Before writing a lot of yast log lines in this thread, maybe there is a command that install the same packages installed by yast control panel. And maybe it’s easier to understand the error.

Sorry I’m new to Opensuse.
Thanks for your kind help

Why not use VirtualBox? much easier to set up the Xen

Ah, you get a pop-up window saying that the installation failed. That is why you say so.

Until now you never said you got a message, you only told that you think it failed, but not where this was based on.
Thanks for explaining that now.

Before anything else,
Your error suggests that your hardware may not support virtualization.
You should inspect your system BIOS and look for a virtualization feature.
When you find it, enable the feature.

If you can’t find that feature in your BIOS,
Either run one of the various commands that will query for Intel VTx or AMD=V extensions or post your CPU model (it’s easy to look up your CPU nowadays).
Practically all x86/x64 CPUs from Intel and AMD dated 2008 or later support some version of these virtualization extensions although some PC OEMs turn them off.

Only <after> you determine and enable support for virtualization,
You can either
Re-run the YaST virtualization install again, or
Install virtualbox, which would probably be much better for you if you haven’t run virtualization before.
To install Virtualbox, you can either find it in YaST Software Manager
Run the following command in an elevated console

zypper install virtualbox

BTW - You need to enable virtualization in your BIOS no matter what virtualization you install.