Failed dual boot, help please!

Hello guys,

I’m kinda desperate, I hope I can get some help please! The thing is, I tried to make a dual boot windows8/openSUSE 13.1 and I messed it up, and now I can’t boot windows 8 neither linux… The history of steps I did (with lots of mistakes, I know):

  • Received my dell vostro 5470 (ultrabook) with windows 8 pre-installed;
  • Reduced the volume of the biggest partition 3 times to create empty spaces to the linux’ partitions swap, / and /home;
  • Started the process to make the dual boot as I had a notebook instead of an ultrabook ( I don’t know how messy it got by doing this);
  • First tried linux mint 16 and it failed, with UEFI problems;
  • Tried openSUSE 13.1, and failed again.

Now I can only get access to a grub gnu 2.0-something command line with “grub>”, and access the bios where I can change from legacy to uefi and enable/disable secure boot… Thats all I can do now… What can I do to fix my problem? I gave up doing dual boot for now, I just want my windows 8 back to read more and start over… please help me!!!

Thank you! (sorry for my english)


I used USB to install mint and opensuse later and tried a bunch of things I’ve seen on other posts;
I tried reinstalling windows 8 via USB too, but my laptop won’t read it and start the installation… it just gives me a black screen

It’s a bit hard to guess what is broken, when you have not told us exactly what you did.

If possible, tell your BIOS to enable UEFI, disable secure-boot, and enable legacy MBR support.

Hit the F12 key during boot, and see if that provides a menu of what you can boot.

Then try with a live opensuse 13.1 system (on DVD or USB), and see if you can boot that (again, with F12 while booting). If you can, then I would like to see the output from:

# parted -l
# efibootmgr -l

If you have the 13.1 DVD image on USB, that might do to. But boot it to rescue mode if you can.

When using F12 during boot, there might be two entries for the USB that you are booting from. One of those entries would be for a UEFI boot, and the other for an MBR boot. If possible, use the UEFI boot. But using the MBR boot at least gives us some information.

not that clear


How did you ‘start the process to make the dual boot’ ?

You have to tell a bit more about what you exactly did.

What do you want to tell by that ?

It seems to me that your system/installation has been damaged prior to the installation of any Linux.

Specifying what I did:

I made 3 partitions for swap, / and /home, and then I made a boot usb with mint 16, went to my bios and changed to legacy mode (so I could read the usb). After that I installed mint 16 with the partitions I mentioned, but grub2 wouldn’t show up when I started the system and I couldn’t log into windows anymore (even in UEFI + secure boot mode). It was giving me the message “Missing OS” or “No bootable device found”. I tried to fix my grub2 installation by starting the live mode with usb. Nothing could help me, so I tried to format my 3 new partitions with gparted as fat32 (because after some research, I figured that opensuse was better for uefi systems, and I wanted to give it a try) and made a opensuse 13.1 usb installation, which gave me my actual state, with the grub command line.


I’ll try to do what you said

It seems to me that the desaster started here.

Did you?
I could imagine that you destroied more than you installed.

You said that you installed in ‘legacy mode’, which could well explain your problems,
i.e. installing in ‘legacy mode’ on an UEFI system with a GPT hard disc can do no good !

Seems that you disabled your system by the way you installed Mint !

After that one - forget it !
You managed to completely destroy the software installed on your system.

Re-install windows, if you can.

After that you may try to re-install a dual boot with any linux,
but not in the way you did before.

If windows is lost for you, then it may even be quite easy:
install openSUSE 13.1 from the 64bit installer DVD,
after having wiped the remainders of the partitions of your hard disk - if there are any.

Single-booting Linux is always easier than dual booting with windows.

So long

Okay, I’ll try to reinstall via DVD and USB and see if something works… But if I get the black screen again, does that mean I lost my windows forever and my only option is to single boot linux?


you wrote before that you

Maybe there’s a chance to get windows back.
Getting you right, windows could perhaps still be present on your hard disk.
You should focus now on recovering windows, if you would like to keep it.

To be clear: you used the installer of Mint in the wrong (‘legacy’) mode.

Good luck


Ok, thank you for the attention!! I’ll try my best


I could manage to enter in my opensuse installation (I guess) with the USB Live (Test firmware -> Boot installation -> Chose the root partition) and made the commands you asked:

henrique@linux-imkx:~> su
linux-imkx:/home/henrique # parted -l
Model: ATA TOSHIBA MQ01ABF0 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number Start End Size File system Name Flags
1 1049kB 525MB 524MB fat32 EFI system partition boot
2 525MB 567MB 41,9MB fat32 Basic data partition hidden
3 567MB 701MB 134MB Microsoft reserved partition msftres
4 701MB 1215MB 514MB ntfs Basic data partition hidden, diag
5 1215MB 406GB 405GB ntfs Basic data partition boot
6 406GB 458GB 52,4GB ext4 Basic data partition boot
7 458GB 486GB 27,3GB ext4 Basic data partition boot
8 486GB 490GB 4194MB linux-swap(v1) Basic data partition
9 490GB 500GB 10,2GB ntfs Microsoft recovery partition hidden, diag

Model: SanDisk Cruzer Fit (scsi)
Disk /dev/sdb: 8004MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 1049kB 8004MB 8003MB primary fat32 boot, type=0b

linux-imkx:/home/henrique # efibootmgr -l
efibootmgr: option requires an argument – ‘l’
efibootmgr version 0.5.4.suse2
usage: efibootmgr [options]
-a | --active sets bootnum active
-A | --inactive sets bootnum inactive
-b | --bootnum XXXX modify BootXXXX (hex)
-B | --delete-bootnum delete bootnum (hex)
-c | --create create new variable bootnum and add to bootorder
-d | --disk disk (defaults to /dev/sda) containing loader
-e | --edd [1|3|-1] force EDD 1.0 or 3.0 creation variables, or guess
-E | --device num EDD 1.0 device number (defaults to 0x80)
-g | --gpt force disk with invalid PMBR to be treated as GPT
-H | --acpi_hid XXXX set the ACPI HID (used with -i)
-i | --iface name create a netboot entry for the named interface
-l | --loader name (defaults to \elilo.efi)
-L | --label label Boot manager display label (defaults to “Linux”)
-n | --bootnext XXXX set BootNext to XXXX (hex)
-N | --delete-bootnext delete BootNext
-o | --bootorder XXXX,YYYY,ZZZZ,… explicitly set BootOrder (hex)
-O | --delete-bootorder delete BootOrder
-p | --part part (defaults to 1) containing loader
-q | --quiet be quiet
| --test filename don’t write to NVRAM, write to filename.
-t | --timeout seconds set boot manager timeout waiting for user input.
-T | --delete-timeout delete Timeout.
-u | --unicode | --UCS-2 pass extra args as UCS-2 (default is ASCII)
-U | --acpi_uid XXXX set the ACPI UID (used with -i)
-v | --verbose print additional information
-V | --version return version and exit
-w | --write-signature write unique sig to MBR if needed
-@ | --append-binary-args file append extra args from file (use “-” for stdin)

I’m putting part of the quote in a code block to see if that helps readability.

I gave you wrong params for “efibootmgr”. Sorry about that.

Your EFI partition is intact. Try to get Windows booting if you can. You’ll need to be in UEFI mode in the BIOS, and you might have to hit F12 while booting. If there is no entry shown for Windows, then there might be an entry showing the hard drive as a boot device. If there is, give that a try.

I hitted F12 while booting, and I selected “Windows boot manager” something like that, but it failed and redirected me to the gnu grub command lines again.

The options I have hitting F12 are:

Boot mode is set to: UEFI with Legacy OPROM; Secure boot: OFF

Removable Drive
+Hard Drive ---------------> Missing OS Operation System not found ----> No bootable devices - strike F1 to retry boot, F2 for setup utility, Press F5 to run onboard diagnostics.

Windows Boot Manager → Fail —> gnu grub
ubuntu------------------------------> gnu grub
Onboard NIC-IPv4
Onboard NIC-IPv6

Peripheral Device setting (OPROM setting)
CHange boot mode setting

Then you have probably lost Windows. If you want it, you will need to reinstall. Call Dell support, or use the restored media that you were supposed to create.

And no, I didn’t create the restore media on my Dell box, either. If Windows 8 fails, I’ll just do without it.

I have been down that road and not too long ago. You cannot “easily” dual boot with UEFI. What it does is allow windows to boot from BIOS directly using codesigned drivers and you can now use GPT disks. T he problem is that you need to install Linux in Legacy mode. You cannot mix the two. It’s either UEFI or Legacy. If you select UEFI windows only. If you select Legacy you can do both. Unless you are some kind of ultra secure environment it isnt needed other than for large boot disks. You may be able to recover windows but if it the windows install does not see the old installation you are probably dead (ie. partitions are gone). If you start from scratch again go legacy all the way.

This (in particular, the last line above) tells me that your Windows is still there, but that you can even start the entire system fresh from square one, which is what I would recommend in your situation. Your easiest choice would be to begin by restoring your system to the state it was shipped from the factory by using the Factory Recovery option.

To find out how to do that, read your manual or go to Dell’s support pages on their website for the specific instructions for your machine.

After you have done that successfully, come back here for instructions on how to set up a Windows / openSUSE dual boot system.

But, judging from your earlier posts, do not do anything once you have Windows restored until you get specific instructions here. Then, carefully follow the instructions given by the openSUSE forum members.

Good luck,

Okay, I’ll try to restore my system from the beginning, I’ll search for dell’s support.

One last doubt; what should I do in case my windows 8 dvd doesn’t work (even to format my entire system)? I mean, if it goes black screen just like my usb did?

Thank you for all your attention!!

I don’t agree with that.

I have both Windows 8.1 and opensuse 13.1, and both are booting in UEFI mode. I probably have the same BIOS as the OP. My computer is a Dell Inspiron 660, and the BIOS says it is also for Dell Vostro.

Yes. If done right, it should work just fine. Just don’t thrash around in the dark, come here and ask people like nrickert for the proper procedure, then follow the advice carefully.


I put my windows 8 DVD installation on my laptop and tried to repair. It said my windows partition is missing. Now I’m trying to install it again, and it tells me to choose a partition where I want it to install. I’m afraid messing it up again, because I select my windows partition and it says I can’t install on it. Should I format it? (I have that option in the installation; or should I format everything and extend partitions to start from zero?)

Actually I’m unable to do anything with this DVD… I tried to repair, it didn’t work; I tried to install windows in different partitions and it wouldn’t allow me (saying it is a system EFI partition, impossible to format. When I tried to exclude a partition and create another as primary, I could click on advance, but It didn’t start saying “We couldn’t create another partition or find an existing one” - it was in another language, so, I don’t know if it is the exactly translation.). What am I supposed to do now? I can only delete partitions in this dvd =P Should I try to boot again in opensuse and fix something with my partitions?

I can also access a windows command prompt;

PS: I guess once I had opensuse installed, I tried to change some flags in gparted, I don’t know if it helped to my crash

You have to be in UEFI mode when you boot the DVD. Also you may need to select to boot the DD in EFI mode. ie F12 again

If you boot in to the old MBR mode it want to install as MBR not EFI

I am already in UEFI mode, but how do I boot the dvd in EFI?